aboutsummaryrefslogtreecommitdiff
path: root/devel/libusb
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-04-13 10:22:22 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-04-13 10:22:22 +0000
commit7fdd27b92c540bd68505273c104dfddbf3767f07 (patch)
tree71d155c951d7c5283a8d9cce28f1abc3a763415a /devel/libusb
parent6df31055016995ce876873fd43bce255be4270d0 (diff)
downloadports-7fdd27b92c540bd68505273c104dfddbf3767f07.tar.gz
ports-7fdd27b92c540bd68505273c104dfddbf3767f07.zip
- update to libusb-0.1.10a
- bump library version to all ports that depends on libusb PR: 79084 Submitted by: John Reynolds <johnjen@reynoldsnet.org>
Notes
Notes: svn path=/head/; revision=133226
Diffstat (limited to 'devel/libusb')
-rw-r--r--devel/libusb/Makefile5
-rw-r--r--devel/libusb/distinfo4
-rw-r--r--devel/libusb/files/patch-bsd.c62
-rw-r--r--devel/libusb/files/patch-configure19
-rw-r--r--devel/libusb/files/patch-ltmain.sh16
-rw-r--r--devel/libusb/pkg-plist7
6 files changed, 33 insertions, 80 deletions
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
index 3630bc2a620b..a0dcd04cf3b5 100644
--- a/devel/libusb/Makefile
+++ b/devel/libusb/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= libusb
-PORTVERSION= 0.1.7
-PORTREVISION= 1
+PORTVERSION= 0.1.10a
+#PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,5 +18,6 @@ COMMENT= Library giving userland programs access to USB devices
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-build-docs
INSTALLS_SHLIB= yes
+USE_GCC= 3.1+
.include <bsd.port.mk>
diff --git a/devel/libusb/distinfo b/devel/libusb/distinfo
index a512b5498fc7..b887fec70b2d 100644
--- a/devel/libusb/distinfo
+++ b/devel/libusb/distinfo
@@ -1,2 +1,2 @@
-MD5 (libusb-0.1.7.tar.gz) = 4c7abee86d8715bccb43428a500d2170
-SIZE (libusb-0.1.7.tar.gz) = 193075
+MD5 (libusb-0.1.10a.tar.gz) = c6062b29acd2cef414bcc34e0decbdd1
+SIZE (libusb-0.1.10a.tar.gz) = 375144
diff --git a/devel/libusb/files/patch-bsd.c b/devel/libusb/files/patch-bsd.c
deleted file mode 100644
index 7f188bf7feb0..000000000000
--- a/devel/libusb/files/patch-bsd.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- bsd.c.orig Mon Nov 11 19:04:16 2002
-+++ bsd.c Sun Nov 23 15:51:49 2003
-@@ -276,7 +276,7 @@
- int usb_bulk_write(usb_dev_handle *dev, int ep, char *bytes, int size,
- int timeout)
- {
-- int fd, ret, sent = 0;
-+ int fd, ret;
-
- /* Ensure the endpoint address is correct */
- ep &= ~USB_ENDPOINT_IN;
-@@ -298,8 +298,7 @@
- USB_ERROR_STR(ret, "error setting timeout: %s",
- strerror(errno));
-
-- do {
-- ret = write(fd, bytes+sent, size-sent);
-+ ret = write(fd, bytes, size);
- if (ret < 0)
- #if __FreeBSD__
- USB_ERROR_STR(ret, "error writing to bulk endpoint %s.%d: %s",
-@@ -309,16 +308,13 @@
- dev->device->filename, UE_GET_ADDR(ep), strerror(errno));
- #endif
-
-- sent += ret;
-- } while(ret > 0 && sent < size);
--
-- return sent;
-+ return ret;
- }
-
- int usb_bulk_read(usb_dev_handle *dev, int ep, char *bytes, int size,
- int timeout)
- {
-- int fd, ret, retrieved = 0, one = 1;
-+ int fd, ret, one = 1;
-
- /* Ensure the endpoint address is correct */
- ep |= USB_ENDPOINT_IN;
-@@ -345,8 +341,7 @@
- USB_ERROR_STR(ret, "error setting short xfer: %s",
- strerror(errno));
-
-- do {
-- ret = read(fd, bytes+retrieved, size-retrieved);
-+ ret = read(fd, bytes, size);
- if (ret < 0)
- #if __FreeBSD__
- USB_ERROR_STR(ret, "error reading from bulk endpoint %s.%d: %s",
-@@ -355,10 +350,8 @@
- USB_ERROR_STR(ret, "error reading from bulk endpoint %s.%02d: %s",
- dev->device->filename, UE_GET_ADDR(ep), strerror(errno));
- #endif
-- retrieved += ret;
-- } while (ret > 0 && retrieved < size);
-
-- return retrieved;
-+ return ret;
- }
-
- int usb_control_msg(usb_dev_handle *dev, int requesttype, int request,
diff --git a/devel/libusb/files/patch-configure b/devel/libusb/files/patch-configure
new file mode 100644
index 000000000000..86fff3308225
--- /dev/null
+++ b/devel/libusb/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig Fri Feb 25 23:04:35 2005
++++ configure Fri Feb 25 23:05:03 2005
+@@ -21635,16 +21635,10 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <dev/usb/usb.h>
+-int
+-main ()
+-{
+ int main(void)
+ {
+ int a = ((struct usb_ctl_request *)0L)->ucr_addr;
+ return 0;
+ }
+- ;
+- return 0;
+-}
+ _ACEOF
+ rm -f conftest.$ac_objext
diff --git a/devel/libusb/files/patch-ltmain.sh b/devel/libusb/files/patch-ltmain.sh
index e71718a9f08e..3fd2c8d82822 100644
--- a/devel/libusb/files/patch-ltmain.sh
+++ b/devel/libusb/files/patch-ltmain.sh
@@ -1,16 +1,6 @@
---- ltmain.sh.orig Sat Sep 22 20:10:52 2001
-+++ ltmain.sh Tue Nov 20 21:14:55 2001
-@@ -2444,6 +2444,9 @@
- *-*-openbsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4210,10 +4213,12 @@
+--- ltmain.sh.orig Fri Feb 25 21:55:10 2005
++++ ltmain.sh Fri Feb 25 21:55:38 2005
+@@ -5550,10 +5550,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/devel/libusb/pkg-plist b/devel/libusb/pkg-plist
index 6633c0a45124..6e7f1c475334 100644
--- a/devel/libusb/pkg-plist
+++ b/devel/libusb/pkg-plist
@@ -1,6 +1,11 @@
bin/libusb-config
include/usb.h
-lib/libusb-0.1.so.7
+include/usbpp.h
+lib/libusb-0.1.so.8
lib/libusb-0.1.so
lib/libusb.so
lib/libusb.a
+lib/libusbpp-0.1.so.8
+lib/libusbpp-0.1.so
+lib/libusbpp.so
+lib/libusbpp.a