aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-07-02 20:23:00 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-07-02 20:23:00 +0000
commitd92add59e5d87bfc1604fada0c3505b3a522eba9 (patch)
treef61ddce117e4a8871b57ba9d36b9393ca93499c1 /devel/libvirt/Makefile
parentaad5f9af942b3af149ac911c1782a5a2fd0d8df1 (diff)
downloadports-d92add59e5d87bfc1604fada0c3505b3a522eba9.tar.gz
ports-d92add59e5d87bfc1604fada0c3505b3a522eba9.zip
- update to 1.1.0 and bump shared libraries in respective ports
- while here: - fix option check in sysutils/cfengine34 - move devel/libvirt-glib to use glib20 in favor of gio-fam-backend (suggested by kwm@) - restore ABI version in net-mgmt/collectd5
Notes
Notes: svn path=/head/; revision=322201
Diffstat (limited to 'devel/libvirt/Makefile')
-rw-r--r--devel/libvirt/Makefile37
1 files changed, 13 insertions, 24 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index ddd73589e1e7..60ccd85e7b78 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.0.6
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -19,9 +18,18 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
gnutls:${PORTSDIR}/security/gnutls \
ssh2:${PORTSDIR}/security/libssh2
-OPTIONS_DEFINE= QEMU DOCS
+OPTIONS_DEFINE= QEMU DOCS NLS
QEMU_DESC= QEMU bindings
+OPTIONS_SUB= yes
+
+QEMU_CONFIGURE_ON= --with-qemu
+QEMU_CONFIGURE_OFF= --without-qemu
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
CONFIGURE_ARGS= --without-sasl \
@@ -33,7 +41,7 @@ CONFIGURE_ARGS= --without-sasl \
--without-netcf \
--without-network \
--without-sysctl \
- --with-libssh2
+ --with-ssh2
#limit to non-stable release x.x.x
PORTSCOUT= limit:\d+\.\d+\.\d+$$
@@ -44,32 +52,13 @@ USES= charsetfix pathfix
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
-SHLIB_VER= 1000
+SHLIB_VER= 1001
PLIST_SUB= PORTVERSION="-${PORTVERSION}" \
SHLIB_VER=${SHLIB_VER}
PORTDOCS= *
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MQEMU}
-CONFIGURE_ARGS+= --with-qemu
-PLIST_SUB+= QEMU=""
-QEMU_CONFIG= qemu
-.else
-CONFIGURE_ARGS+= --without-qemu
-PLIST_SUB+= QEMU="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CONFIGURE_ARGS+= --enable-nls \
- --with-libintl-prefix=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
MAN1= virsh.1 virt-pki-validate.1 virt-xml-validate.1 virt-host-validate.1
MAN8= libvirtd.8