aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-10-29 22:17:55 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-10-29 22:17:55 +0000
commit763dd97ec9e0e7a458dc76cb6bd951a3a5877758 (patch)
treeb988045db1b22cddb3760168ef998ed5d0876d74 /devel/libvirt
parent990677bda1bc8d488d6cb0acffae222c1df3ab09 (diff)
downloadports-763dd97ec9e0e7a458dc76cb6bd951a3a5877758.tar.gz
ports-763dd97ec9e0e7a458dc76cb6bd951a3a5877758.zip
- update libvirt,py-libvirt,libvirt-glib to 0.1.9
- shift var from ${PREFIX} to /var - bump shared libs of dep. port PR: 192441 (based on) Submitted by: olevole@olevole.ru
Notes
Notes: svn path=/head/; revision=371717
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile34
-rw-r--r--devel/libvirt/distinfo4
-rw-r--r--devel/libvirt/files/libvirtd.in2
-rw-r--r--devel/libvirt/pkg-plist29
4 files changed, 61 insertions, 8 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index cf0d21645f28..5681a5b21f29 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.2.6
-PORTREVISION= 4
+PORTVERSION= 1.2.9
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -43,6 +42,8 @@ NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+VARDIR= /var
+
USE_RC_SUBR= libvirtd
GNU_CONFIGURE= yes
@@ -55,7 +56,8 @@ CONFIGURE_ARGS= --without-sasl \
--without-sysctl \
--without-lxc \
--without-uml \
- --with-ssh2
+ --with-ssh2 \
+ --localstatedir=${VARDIR}
# random_data fix can be removed when 8.x is eol
CONFIGURE_ENV= ac_cv_type_struct_random_data=""
@@ -65,11 +67,12 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
-USES= charsetfix gmake libtool pathfix pkgconfig perl5
+USES= charsetfix gmake libtool pathfix pkgconfig perl5 cpe
+CPE_VENDOR= redhat
USE_PERL5= build
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-SHLIB_VER= 0.1002.6
+SHLIB_VER= 0.1002.9
PLIST_SUB= PORTVERSION="-${PORTVERSION}" \
SHLIB_VER=${SHLIB_VER}
PORTDOCS= *
@@ -81,6 +84,10 @@ PORTDOCS= *
PLIST_SUB+= BHYVE="@comment "
.endif
+.if ${PORT_OPTIONS:MBHYVE}
+STRIP_FILES+= libvirt/connection-driver/libvirt_driver_bhyve.so
+.endif
+
post-patch:
.if ${OSVERSION} < 900000
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||' \
@@ -109,6 +116,23 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
+.for dir in run/libvirt/network \
+ run/libvirt/qemu \
+ run/libvirt/lockd \
+ log/libvirt/uml \
+ log/libvirt/qemu \
+ log/libvirt/lxc \
+ lib/libvirt/boot \
+ lib/libvirt/lockd/files \
+ lib/libvirt/images \
+ lib/libvirt/dnsmasq \
+ lib/libvirt/filesystems \
+ lib/libvirt/network \
+ lib/libvirt/qemu/channel/target \
+ cache/libvirt/qemu
+ @${MKDIR} "${STAGEDIR}/${VARDIR}/${dir}"
+.endfor
+
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index 2f72d59e5d38..105631966af2 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvirt-1.2.6.tar.gz) = 38a224559a1d04e5d4163c5c1b810df1f29804ebbb1f057d4abcb41a9e5d5dea
-SIZE (libvirt-1.2.6.tar.gz) = 29346718
+SHA256 (libvirt-1.2.9.tar.gz) = 95931a5a52f451b9ab73d6a5ae11a5740e1ba69a66520c2a0cffc6068a7e8fc4
+SIZE (libvirt-1.2.9.tar.gz) = 30154430
diff --git a/devel/libvirt/files/libvirtd.in b/devel/libvirt/files/libvirtd.in
index 8503f54c5c36..856e0ec7f295 100644
--- a/devel/libvirt/files/libvirtd.in
+++ b/devel/libvirt/files/libvirtd.in
@@ -20,7 +20,7 @@ rcvar=libvirtd_enable
load_rc_config $name
command=%%PREFIX%%/sbin/libvirtd
-pidfile=%%LOCALBASE%%/var/run/${name}.pid
+pidfile=/var/run/${name}.pid
command_args="--daemon --pid-file=${pidfile}"
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 498ea0970bbd..ba3f2c69c19c 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -102,6 +102,7 @@ share/augeas/lenses/tests/test_virtlockd.aug
%%DOCSDIR%%%%PORTVERSION%%/html/formatsecret.html
%%DOCSDIR%%%%PORTVERSION%%/html/formatsnapshot.html
%%DOCSDIR%%%%PORTVERSION%%/html/formatstorage.html
+%%DOCSDIR%%%%PORTVERSION%%/html/formatdomaincaps.html
%%DOCSDIR%%%%PORTVERSION%%/html/formatstorageencryption.html
%%DOCSDIR%%%%PORTVERSION%%/html/generic.css
%%DOCSDIR%%%%PORTVERSION%%/html/goals.html
@@ -180,6 +181,7 @@ share/gtk-doc/html/libvirt/up.png
%%DATADIR%%/schemas/basictypes.rng
%%DATADIR%%/schemas/capability.rng
%%DATADIR%%/schemas/domain.rng
+%%DATADIR%%/schemas/domaincaps.rng
%%DATADIR%%/schemas/domaincommon.rng
%%DATADIR%%/schemas/domainsnapshot.rng
%%DATADIR%%/schemas/interface.rng
@@ -272,3 +274,30 @@ lib/libvirt/connection-driver/libvirt_driver_network.so
lib/libvirt/connection-driver/libvirt_driver_secret.so
lib/libvirt/connection-driver/libvirt_driver_storage.so
lib/libvirt/connection-driver/libvirt_driver_vbox.so
+lib/libvirt/connection-driver/libvirt_driver_vbox_network.so
+lib/libvirt/connection-driver/libvirt_driver_vbox_storage.so
+%%QEMU%%@unexec rmdir /var/run/libvirt/qemu
+%%QEMU%%@unexec rmdir /var/lib/libvirt/qemu/channel/target
+%%QEMU%%@unexec rmdir /var/lib/libvirt/qemu/channel
+%%QEMU%%@unexec rmdir /var/lib/libvirt/qemu
+%%QEMU%%@unexec rmdir /var/cache/libvirt/qemu
+@unexec rmdir /var/cache/libvirt
+@unexec rmdir /var/cache
+@unexec rmdir /var/lib/libvirt/boot
+@unexec rmdir /var/lib/libvirt/dnsmasq
+@unexec rmdir /var/lib/libvirt/filesystems
+@unexec rmdir /var/lib/libvirt/images
+@unexec rmdir /var/lib/libvirt/lockd/files
+@unexec rmdir /var/lib/libvirt/lockd
+@unexec rmdir /var/lib/libvirt/network
+@unexec rmdir /var/lib/libvirt
+@unexec rmdir /var/lib
+@unexec rmdir /var/log/libvirt/lxc
+@unexec rmdir /var/log/libvirt/qemu
+@unexec rmdir /var/log/libvirt/uml
+@unexec rmdir /var/log/libvirt
+@unexec rmdir /var/log
+@unexec rmdir /var/run/libvirt/lockd
+@unexec rmdir /var/run/libvirt/network
+@unexec rmdir /var/run/libvirt
+@unexec rmdir /var/run