aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2017-08-17 13:24:45 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2017-08-17 13:24:45 +0000
commitc58a42f6275414a4823aa67918e2357ff14126d8 (patch)
tree3ac57497761f42393ef447a1f8c1b468a4f7a71a /devel/libvirt
parentd672c94edb8c177e56b57bf0c9e7f4b6efc63e6a (diff)
downloadports-c58a42f6275414a4823aa67918e2357ff14126d8.tar.gz
ports-c58a42f6275414a4823aa67918e2357ff14126d8.zip
devel/libvirt: add yajl dependency for nss
The nss plugin requires yajl. It's pulled for qemu when it's enabled, but build fails when nss plugin is enabled and qemu driver is disabled, so add a dependency on yajl for both options. PR: 221279 Reported by: vvd@unislabs.com
Notes
Notes: svn path=/head/; revision=448098
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 8fe8904ea620..b41d5829a9ad 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -41,9 +41,7 @@ OPTIONS_SUB= yes
BHYVE_CONFIGURE_WITH= bhyve
-QEMU_CONFIGURE_WITH= qemu yajl
-QEMU_CFLAGS= -I${LOCALBASE}/include
-QEMU_LIB_DEPENDS= libyajl.so:devel/yajl
+QEMU_CONFIGURE_WITH= qemu
QEMU_RUN_DEPENDS= dmidecode:sysutils/dmidecode \
qemu-io:emulators/qemu
@@ -112,6 +110,11 @@ SUB_LIST+= PORTVERSION="-${PORTVERSION}"
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MQEMU} || ${PORT_OPTIONS:MNSS}
+LIB_DEPENDS+= libyajl.so:devel/yajl
+CONFIGURE_ARGS+= --with-yajl=${LOCALBASE}
+.endif
+
.if !${PLIST_SUB:MXEN}
PLIST_SUB+= XEN="@comment "
.endif