aboutsummaryrefslogtreecommitdiff
path: root/devel/lincvs
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-12-04 23:51:22 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-12-04 23:51:22 +0000
commit39f6f12fafc82a9743356ce714d4e19840578bbd (patch)
tree1c1f6de729d9c25879f363cc241c218319af142a /devel/lincvs
parent5827170a6a1950a6de9ea901ea8158db2638fe22 (diff)
downloadports-39f6f12fafc82a9743356ce714d4e19840578bbd.tar.gz
ports-39f6f12fafc82a9743356ce714d4e19840578bbd.zip
LinCVS is a QT2-based frontend for the CVS-client supporting
both CVS-versions 1.9 and 1.10, perhaps even older ones.... PR: 15245 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Notes
Notes: svn path=/head/; revision=23596
Diffstat (limited to 'devel/lincvs')
-rw-r--r--devel/lincvs/Makefile28
-rw-r--r--devel/lincvs/distinfo1
-rw-r--r--devel/lincvs/files/patch-aa26
-rw-r--r--devel/lincvs/pkg-comment1
-rw-r--r--devel/lincvs/pkg-descr12
-rw-r--r--devel/lincvs/pkg-plist4
6 files changed, 72 insertions, 0 deletions
diff --git a/devel/lincvs/Makefile b/devel/lincvs/Makefile
new file mode 100644
index 000000000000..a0dd1ca09b3e
--- /dev/null
+++ b/devel/lincvs/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: lincvs
+# Version required: 0.2.2
+# Date created: 03 December 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= lincvs_0.2.2
+PKGNAME= lincvs-0.2.2
+CATEGORIES= devel kde
+MASTER_SITES= http://ppprs1.phy.tu-dresden.de/~trogisch/lincvs/download/
+
+MAINTAINER= jedgar@fxp.org
+
+USE_QT2= yes
+WRKSRC= ${WRKDIR}/LinCVS-0.2.2
+
+do-configure:
+ @${PERL} -pi.orig -e 's|__X11BASE__|${X11BASE}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/LinCVS ${PREFIX}/bin/lincvs
+ ${MKDIR} ${PREFIX}/share/doc/lincvs
+ ${INSTALL_DATA} ${WRKSRC}/doc/index.html ${PREFIX}/share/doc/lincvs
+ ${INSTALL_DATA} ${WRKSRC}/doc/index-1.html ${PREFIX}/share/doc/lincvs
+
+.include <bsd.port.mk>
diff --git a/devel/lincvs/distinfo b/devel/lincvs/distinfo
new file mode 100644
index 000000000000..f5d9d47dcb83
--- /dev/null
+++ b/devel/lincvs/distinfo
@@ -0,0 +1 @@
+MD5 (lincvs_0.2.2.tar.gz) = 2469a7be85fe3d29a76b0664104dcf54
diff --git a/devel/lincvs/files/patch-aa b/devel/lincvs/files/patch-aa
new file mode 100644
index 000000000000..ca3b44e973fb
--- /dev/null
+++ b/devel/lincvs/files/patch-aa
@@ -0,0 +1,26 @@
+--- Makefile.orig Fri Dec 3 10:45:01 1999
++++ Makefile Fri Dec 3 11:18:26 1999
+@@ -7,15 +7,15 @@
+
+ ####### Compiler, tools and options
+
+-CC = gcc
+-CXX = g++
+-CFLAGS = -pipe -Wall -W -O3 -DLINCVS_APP
+-CXXFLAGS= -pipe -Wall -W -O3 -DLINCVS_APP
+-INCPATH = -I./include -I./res -I./themes/include -I./themes/res -I$(QTDIR)/include
+-LINK = g++
++#CC = gcc
++#CXX = g++
++CFLAGS+= -DLINCVS_APP
++CXXFLAGS= $(CFLAGS)
++INCPATH = -I./include -I./res -I./themes/include -I./themes/res -I__X11BASE__/include/qt2
++LINK = $(CXX)
+ LFLAGS =
+-LIBS = -L$(QTDIR)/lib -lqt -L/usr/X11R6/lib -lXext -lX11 -lm
+-MOC = moc
++LIBS = -L__X11BASE__/lib -lqt2 -lXext -lX11 -lm
++MOC = __X11BASE__/bin/moc2
+
+ TAR = tar -cf
+ GZIP = gzip -9f
diff --git a/devel/lincvs/pkg-comment b/devel/lincvs/pkg-comment
new file mode 100644
index 000000000000..cb1187788f97
--- /dev/null
+++ b/devel/lincvs/pkg-comment
@@ -0,0 +1 @@
+Graphical CVS front-end using QT2
diff --git a/devel/lincvs/pkg-descr b/devel/lincvs/pkg-descr
new file mode 100644
index 000000000000..7e337671c9dc
--- /dev/null
+++ b/devel/lincvs/pkg-descr
@@ -0,0 +1,12 @@
+LinCVS is a QT2-based frontend for the CVS-client supporting
+both CVS-versions 1.9 and 1.10, perhaps even older ones....
+It allows to check out a module from and import of a module to a
+repository, to update or retrieve the status of a working directory
+or single files and common operations like add, remove and commit,
+diff against the repository or view of the log messages in list
+form.
+
+WWW: http://ppprs1.phy.tu-dresden.de/~trogisch/lincvs/lincvsen.html
+
+- Chris D. Faulhaber
+jedgar@fxp.org
diff --git a/devel/lincvs/pkg-plist b/devel/lincvs/pkg-plist
new file mode 100644
index 000000000000..7cc5a2758850
--- /dev/null
+++ b/devel/lincvs/pkg-plist
@@ -0,0 +1,4 @@
+bin/lincvs
+share/doc/lincvs/index.html
+share/doc/lincvs/index-1.html
+@dirrm share/doc/lincvs