aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /devel/llvm-devel
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index ef79fa4d3953..b34bbd81c518 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -19,7 +19,7 @@ DATADIR= ${PREFIX}/share/${PORTNAME}${LLVM_SUFFIX}
BUILD_DEPENDS=
-USES= cmake:outsource compiler:c++11-lib libedit perl5 \
+USES= cmake compiler:c++11-lib libedit perl5 \
shebangfix
USE_LDCONFIG= ${LLVM_PREFIX}/lib
_USES_PYTHON?= python:build:2.7