aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2021-10-05 22:34:23 +0000
committerBrooks Davis <brooks@FreeBSD.org>2021-10-05 22:36:17 +0000
commit7e2f156ce907e7785863d49cbd33d36f07df7eae (patch)
tree6fac1aee15b844edc8b1dc6a86cfe8b19014ee09 /devel/llvm-devel
parent671a984e9f7f53edd4d7dccf1ec57e1bf8d4171e (diff)
downloadports-7e2f156ce907e7785863d49cbd33d36f07df7eae.tar.gz
ports-7e2f156ce907e7785863d49cbd33d36f07df7eae.zip
devel/llvm-devel: Update to a new snapshot
Add a patch to workaround lldb not compiling without PT_COREDUMP support (not yet in all supported releases). Sponsored by: DARPA
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile.COMMANDS3
-rw-r--r--devel/llvm-devel/Makefile.snapshot4
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/files/patch-lldb-PT_COREDUMP.diff45
-rw-r--r--devel/llvm-devel/pkg-plist108
5 files changed, 139 insertions, 27 deletions
diff --git a/devel/llvm-devel/Makefile.COMMANDS b/devel/llvm-devel/Makefile.COMMANDS
index 8b79bd406155..1c0f2155cc6b 100644
--- a/devel/llvm-devel/Makefile.COMMANDS
+++ b/devel/llvm-devel/Makefile.COMMANDS
@@ -71,8 +71,10 @@ CLANG_COMMANDS= \
clang-cpp \
clang-extdef-mapping \
clang-format \
+ clang-nvlink-wrapper \
clang-offload-bundler \
clang-offload-wrapper \
+ clang-repl \
clang-scan-deps \
diagtool \
hmaptool \
@@ -126,7 +128,6 @@ LLDB_COMMANDS= \
MLIR_COMMANDS= \
mlir-cpu-runner \
- mlir-linalg-ods-gen \
mlir-lsp-server \
mlir-opt \
mlir-reduce \
diff --git a/devel/llvm-devel/Makefile.snapshot b/devel/llvm-devel/Makefile.snapshot
index 2fe00c21ea66..d4b97f63c5d0 100644
--- a/devel/llvm-devel/Makefile.snapshot
+++ b/devel/llvm-devel/Makefile.snapshot
@@ -4,6 +4,6 @@
#
LLVM_MAJOR= 14
LLVM_RELEASE= ${LLVM_MAJOR}.0.0
-SNAPDATE= 20210811
+SNAPDATE= 20211005
-LLVM_PROJECT_COMMIT= a614a28772cbd8e0fc3c5fcf836493c2c8bc80da
+LLVM_PROJECT_COMMIT= 7d541eb4d49aaaab6a51a3568b9214fd8691e2d3
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 54499c9cd2b6..25dafd095a31 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628712194
-SHA256 (llvm-llvm-project-14.0.d20210811-a614a28772cbd8e0fc3c5fcf836493c2c8bc80da_GH0.tar.gz) = fa8f6d329aeaeabb9b76f3596e9738e4dbe36f9c8b0fa96e3fc6d5cec464e71d
-SIZE (llvm-llvm-project-14.0.d20210811-a614a28772cbd8e0fc3c5fcf836493c2c8bc80da_GH0.tar.gz) = 147717126
+TIMESTAMP = 1633469733
+SHA256 (llvm-llvm-project-14.0.d20211005-7d541eb4d49aaaab6a51a3568b9214fd8691e2d3_GH0.tar.gz) = 23788c802e1c6b39aa3d1562a514feec9efe145204aa08ecf3deea7ac228f184
+SIZE (llvm-llvm-project-14.0.d20211005-7d541eb4d49aaaab6a51a3568b9214fd8691e2d3_GH0.tar.gz) = 149515726
diff --git a/devel/llvm-devel/files/patch-lldb-PT_COREDUMP.diff b/devel/llvm-devel/files/patch-lldb-PT_COREDUMP.diff
new file mode 100644
index 000000000000..455afa5d89c2
--- /dev/null
+++ b/devel/llvm-devel/files/patch-lldb-PT_COREDUMP.diff
@@ -0,0 +1,45 @@
+diff --git lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.cpp lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.cpp
+index d795a43375ca..e7745180a081 100644
+--- lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.cpp
++++ lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.cpp
+@@ -131,8 +131,11 @@ NativeProcessFreeBSD::Factory::Attach(
+ NativeProcessFreeBSD::Extension
+ NativeProcessFreeBSD::Factory::GetSupportedExtensions() const {
+ return Extension::multiprocess | Extension::fork | Extension::vfork |
+- Extension::pass_signals | Extension::auxv | Extension::libraries_svr4 |
+- Extension::savecore;
++ Extension::pass_signals | Extension::auxv | Extension::libraries_svr4
++#ifdef PT_COREDUMP
++ | Extension::savecore
++#endif
++ ;
+ }
+
+ // Public Instance Methods
+@@ -1011,6 +1014,7 @@ void NativeProcessFreeBSD::MonitorClone(::pid_t child_pid, bool is_vfork,
+ }
+ }
+
++#ifdef PT_COREDUMP
+ llvm::Expected<std::string>
+ NativeProcessFreeBSD::SaveCore(llvm::StringRef path_hint) {
+ using namespace llvm::sys::fs;
+@@ -1037,3 +1041,4 @@ NativeProcessFreeBSD::SaveCore(llvm::StringRef path_hint) {
+ close_err, "Unable to close the core dump after writing");
+ return path.str().str();
+ }
++#endif
+diff --git lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.h lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.h
+index 44b8a53699bb..0f5976b1a7d4 100644
+--- lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.h
++++ lldb/source/Plugins/Process/FreeBSD/NativeProcessFreeBSD.h
+@@ -91,7 +91,9 @@ public:
+
+ bool SupportHardwareSingleStepping() const;
+
++#ifdef PT_COREDUMP
+ llvm::Expected<std::string> SaveCore(llvm::StringRef path_hint) override;
++#endif
+
+ protected:
+ llvm::Expected<llvm::ArrayRef<uint8_t>>
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index b44b954348db..2d3f84774cfd 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -70,8 +70,10 @@ bin/split-file-devel
%%CLANG%%bin/clang-cpp-devel
%%CLANG%%bin/clang-extdef-mapping-devel
%%CLANG%%bin/clang-format-devel
+%%CLANG%%bin/clang-nvlink-wrapper-devel
%%CLANG%%bin/clang-offload-bundler-devel
%%CLANG%%bin/clang-offload-wrapper-devel
+%%CLANG%%bin/clang-repl-devel
%%CLANG%%bin/clang-scan-deps-devel
%%CLANG%%bin/diagtool-devel
%%CLANG%%bin/hmaptool-devel
@@ -110,7 +112,6 @@ bin/split-file-devel
%%LLDB%%bin/lldb-server-devel
%%LLDB%%bin/lldb-vscode-devel
%%MLIR%%bin/mlir-cpu-runner-devel
-%%MLIR%%bin/mlir-linalg-ods-gen-devel
%%MLIR%%bin/mlir-lsp-server-devel
%%MLIR%%bin/mlir-opt-devel
%%MLIR%%bin/mlir-reduce-devel
@@ -158,12 +159,14 @@ llvm-devel/bin/bugpoint
%%CLANG%%llvm-devel/bin/clang-format
%%EXTRAS%%llvm-devel/bin/clang-include-fixer
%%EXTRAS%%llvm-devel/bin/clang-move
+%%CLANG%%llvm-devel/bin/clang-nvlink-wrapper
%%CLANG%%llvm-devel/bin/clang-offload-bundler
%%CLANG%%llvm-devel/bin/clang-offload-wrapper
%%EXTRAS%%llvm-devel/bin/clang-query
%%CLANG%%llvm-devel/bin/clang-refactor
%%EXTRAS%%llvm-devel/bin/clang-rename
%%EXTRAS%%llvm-devel/bin/clang-reorder-fields
+%%CLANG%%llvm-devel/bin/clang-repl
%%CLANG%%llvm-devel/bin/clang-scan-deps
%%EXTRAS%%llvm-devel/bin/clang-tidy
%%EXTRAS%%llvm-devel/bin/clangd
@@ -255,7 +258,6 @@ llvm-devel/bin/llvm-undname
llvm-devel/bin/llvm-windres
llvm-devel/bin/llvm-xray
%%MLIR%%llvm-devel/bin/mlir-cpu-runner
-%%MLIR%%llvm-devel/bin/mlir-linalg-ods-gen
%%MLIR%%llvm-devel/bin/mlir-linalg-ods-yaml-gen
%%MLIR%%llvm-devel/bin/mlir-lsp-server
%%MLIR%%llvm-devel/bin/mlir-opt
@@ -379,6 +381,7 @@ llvm-devel/bin/verify-uselistorder
%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/StringLiteralWithEmbeddedNulCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/SuspiciousEnumUsageCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/SuspiciousIncludeCheck.h
+%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/SuspiciousMemoryComparisonCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/SuspiciousMemsetUsageCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/SuspiciousMissingCommaCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/bugprone/SuspiciousSemicolonCheck.h
@@ -432,6 +435,7 @@ llvm-devel/bin/verify-uselistorder
%%EXTRAS%%llvm-devel/include/clang-tidy/cppcoreguidelines/ProTypeVarargCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/cppcoreguidelines/SlicingCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/cppcoreguidelines/SpecialMemberFunctionsCheck.h
+%%EXTRAS%%llvm-devel/include/clang-tidy/cppcoreguidelines/VirtualClassDestructorCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/darwin/AvoidSpinlockCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/darwin/DispatchOnceNonstaticCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/fuchsia/DefaultArgumentsCallsCheck.h
@@ -548,12 +552,14 @@ llvm-devel/bin/verify-uselistorder
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/AvoidConstParamsInDecls.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/BracesAroundStatementsCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/ConstReturnTypeCheck.h
+%%EXTRAS%%llvm-devel/include/clang-tidy/readability/ContainerDataPointerCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/ContainerSizeEmptyCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/ConvertMemberFunctionsToStatic.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/DeleteNullPointerCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/ElseAfterReturnCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/FunctionCognitiveComplexityCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/FunctionSizeCheck.h
+%%EXTRAS%%llvm-devel/include/clang-tidy/readability/IdentifierLengthCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/IdentifierNamingCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/ImplicitBoolConversionCheck.h
%%EXTRAS%%llvm-devel/include/clang-tidy/readability/InconsistentDeclarationParameterNameCheck.h
@@ -825,6 +831,7 @@ llvm-devel/bin/verify-uselistorder
%%CLANG%%llvm-devel/include/clang/Basic/BuiltinsX86.def
%%CLANG%%llvm-devel/include/clang/Basic/BuiltinsX86_64.def
%%CLANG%%llvm-devel/include/clang/Basic/BuiltinsXCore.def
+%%CLANG%%llvm-devel/include/clang/Basic/CLWarnings.h
%%CLANG%%llvm-devel/include/clang/Basic/CapturedStmt.h
%%CLANG%%llvm-devel/include/clang/Basic/CharInfo.h
%%CLANG%%llvm-devel/include/clang/Basic/CodeGenOptions.def
@@ -926,7 +933,6 @@ llvm-devel/bin/verify-uselistorder
%%CLANG%%llvm-devel/include/clang/Basic/Version.h
%%CLANG%%llvm-devel/include/clang/Basic/Version.inc
%%CLANG%%llvm-devel/include/clang/Basic/Visibility.h
-%%CLANG%%llvm-devel/include/clang/Basic/X86Target.def
%%CLANG%%llvm-devel/include/clang/Basic/XRayInstr.h
%%CLANG%%llvm-devel/include/clang/Basic/XRayLists.h
%%CLANG%%llvm-devel/include/clang/Basic/arm_cde_builtin_aliases.inc
@@ -1288,6 +1294,7 @@ llvm-devel/bin/verify-uselistorder
%%FLANG%%llvm-devel/include/flang/Evaluate/intrinsics-library.h
%%FLANG%%llvm-devel/include/flang/Evaluate/intrinsics.h
%%FLANG%%llvm-devel/include/flang/Evaluate/logical.h
+%%FLANG%%llvm-devel/include/flang/Evaluate/pgmath.h.inc
%%FLANG%%llvm-devel/include/flang/Evaluate/real.h
%%FLANG%%llvm-devel/include/flang/Evaluate/rounding-bits.h
%%FLANG%%llvm-devel/include/flang/Evaluate/shape.h
@@ -1301,6 +1308,7 @@ llvm-devel/bin/verify-uselistorder
%%FLANG%%llvm-devel/include/flang/Frontend/FrontendAction.h
%%FLANG%%llvm-devel/include/flang/Frontend/FrontendActions.h
%%FLANG%%llvm-devel/include/flang/Frontend/FrontendOptions.h
+%%FLANG%%llvm-devel/include/flang/Frontend/FrontendPluginRegistry.h
%%FLANG%%llvm-devel/include/flang/Frontend/PreprocessorOptions.h
%%FLANG%%llvm-devel/include/flang/Frontend/TextDiagnostic.h
%%FLANG%%llvm-devel/include/flang/Frontend/TextDiagnosticBuffer.h
@@ -1351,6 +1359,7 @@ llvm-devel/bin/verify-uselistorder
%%FLANG%%llvm-devel/include/flang/Optimizer/Support/InitFIR.h
%%FLANG%%llvm-devel/include/flang/Optimizer/Support/InternalNames.h
%%FLANG%%llvm-devel/include/flang/Optimizer/Support/KindMapping.h
+%%FLANG%%llvm-devel/include/flang/Optimizer/Support/Utils.h
%%FLANG%%llvm-devel/include/flang/Optimizer/Transforms/Passes.h
%%FLANG%%llvm-devel/include/flang/Optimizer/Transforms/Passes.h.inc
%%FLANG%%llvm-devel/include/flang/Optimizer/Transforms/Passes.td
@@ -1371,6 +1380,30 @@ llvm-devel/bin/verify-uselistorder
%%FLANG%%llvm-devel/include/flang/Parser/tools.h
%%FLANG%%llvm-devel/include/flang/Parser/unparse.h
%%FLANG%%llvm-devel/include/flang/Parser/user-state.h
+%%FLANG%%llvm-devel/include/flang/Runtime/allocatable.h
+%%FLANG%%llvm-devel/include/flang/Runtime/assign.h
+%%FLANG%%llvm-devel/include/flang/Runtime/c-or-cpp.h
+%%FLANG%%llvm-devel/include/flang/Runtime/character.h
+%%FLANG%%llvm-devel/include/flang/Runtime/command.h
+%%FLANG%%llvm-devel/include/flang/Runtime/cpp-type.h
+%%FLANG%%llvm-devel/include/flang/Runtime/derived-api.h
+%%FLANG%%llvm-devel/include/flang/Runtime/descriptor.h
+%%FLANG%%llvm-devel/include/flang/Runtime/entry-names.h
+%%FLANG%%llvm-devel/include/flang/Runtime/io-api.h
+%%FLANG%%llvm-devel/include/flang/Runtime/iostat.h
+%%FLANG%%llvm-devel/include/flang/Runtime/magic-numbers.h
+%%FLANG%%llvm-devel/include/flang/Runtime/main.h
+%%FLANG%%llvm-devel/include/flang/Runtime/matmul.h
+%%FLANG%%llvm-devel/include/flang/Runtime/memory.h
+%%FLANG%%llvm-devel/include/flang/Runtime/misc-intrinsic.h
+%%FLANG%%llvm-devel/include/flang/Runtime/numeric.h
+%%FLANG%%llvm-devel/include/flang/Runtime/pointer.h
+%%FLANG%%llvm-devel/include/flang/Runtime/random.h
+%%FLANG%%llvm-devel/include/flang/Runtime/reduction.h
+%%FLANG%%llvm-devel/include/flang/Runtime/stop.h
+%%FLANG%%llvm-devel/include/flang/Runtime/time-intrinsic.h
+%%FLANG%%llvm-devel/include/flang/Runtime/transformational.h
+%%FLANG%%llvm-devel/include/flang/Runtime/type-code.h
%%FLANG%%llvm-devel/include/flang/Semantics/attr.h
%%FLANG%%llvm-devel/include/flang/Semantics/expression.h
%%FLANG%%llvm-devel/include/flang/Semantics/runtime-type-info.h
@@ -1658,7 +1691,6 @@ llvm-devel/bin/verify-uselistorder
%%LLDB%%llvm-devel/include/lldb/Host/SafeMachO.h
%%LLDB%%llvm-devel/include/lldb/Host/Socket.h
%%LLDB%%llvm-devel/include/lldb/Host/SocketAddress.h
-%%LLDB%%llvm-devel/include/lldb/Host/StringConvert.h
%%LLDB%%llvm-devel/include/lldb/Host/Terminal.h
%%LLDB%%llvm-devel/include/lldb/Host/ThreadLauncher.h
%%LLDB%%llvm-devel/include/lldb/Host/Time.h
@@ -1752,6 +1784,7 @@ llvm-devel/bin/verify-uselistorder
%%LLDB%%llvm-devel/include/lldb/Interpreter/Options.h
%%LLDB%%llvm-devel/include/lldb/Interpreter/Property.h
%%LLDB%%llvm-devel/include/lldb/Interpreter/ScriptInterpreter.h
+%%LLDB%%llvm-devel/include/lldb/Interpreter/ScriptedInterface.h
%%LLDB%%llvm-devel/include/lldb/Interpreter/ScriptedProcessInterface.h
%%LLDB%%llvm-devel/include/lldb/Symbol/ArmUnwindInfo.h
%%LLDB%%llvm-devel/include/lldb/Symbol/Block.h
@@ -1789,8 +1822,10 @@ llvm-devel/bin/verify-uselistorder
%%LLDB%%llvm-devel/include/lldb/Symbol/Variable.h
%%LLDB%%llvm-devel/include/lldb/Symbol/VariableList.h
%%LLDB%%llvm-devel/include/lldb/Target/ABI.h
+%%LLDB%%llvm-devel/include/lldb/Target/AppleArm64ExceptionClass.h
%%LLDB%%llvm-devel/include/lldb/Target/AssertFrameRecognizer.h
%%LLDB%%llvm-devel/include/lldb/Target/DynamicLoader.h
+%%LLDB%%llvm-devel/include/lldb/Target/DynamicRegisterInfo.h
%%LLDB%%llvm-devel/include/lldb/Target/ExecutionContext.h
%%LLDB%%llvm-devel/include/lldb/Target/ExecutionContextScope.h
%%LLDB%%llvm-devel/include/lldb/Target/InstrumentationRuntime.h
@@ -2082,6 +2117,7 @@ llvm-devel/include/llvm/Analysis/CmpInstAnalysis.h
llvm-devel/include/llvm/Analysis/CodeMetrics.h
llvm-devel/include/llvm/Analysis/ConstantFolding.h
llvm-devel/include/llvm/Analysis/ConstraintSystem.h
+llvm-devel/include/llvm/Analysis/CostModel.h
llvm-devel/include/llvm/Analysis/DDG.h
llvm-devel/include/llvm/Analysis/DDGPrinter.h
llvm-devel/include/llvm/Analysis/DOTGraphTraitsPass.h
@@ -2107,6 +2143,7 @@ llvm-devel/include/llvm/Analysis/IndirectCallVisitor.h
llvm-devel/include/llvm/Analysis/InlineAdvisor.h
llvm-devel/include/llvm/Analysis/InlineCost.h
llvm-devel/include/llvm/Analysis/InlineModelFeatureMaps.h
+llvm-devel/include/llvm/Analysis/InlineOrder.h
llvm-devel/include/llvm/Analysis/InlineSizeEstimatorAnalysis.h
llvm-devel/include/llvm/Analysis/InstCount.h
llvm-devel/include/llvm/Analysis/InstructionPrecedenceTracking.h
@@ -2253,6 +2290,7 @@ llvm-devel/include/llvm/CodeGen/BasicTTIImpl.h
llvm-devel/include/llvm/CodeGen/CSEConfigBase.h
llvm-devel/include/llvm/CodeGen/CalcSpillWeights.h
llvm-devel/include/llvm/CodeGen/CallingConvLower.h
+llvm-devel/include/llvm/CodeGen/CodeGenCommonISel.h
llvm-devel/include/llvm/CodeGen/CodeGenPassBuilder.h
llvm-devel/include/llvm/CodeGen/CommandFlags.h
llvm-devel/include/llvm/CodeGen/CostTable.h
@@ -2327,6 +2365,7 @@ llvm-devel/include/llvm/CodeGen/MIRFormatter.h
llvm-devel/include/llvm/CodeGen/MIRParser/MIParser.h
llvm-devel/include/llvm/CodeGen/MIRParser/MIRParser.h
llvm-devel/include/llvm/CodeGen/MIRPrinter.h
+llvm-devel/include/llvm/CodeGen/MIRSampleProfile.h
llvm-devel/include/llvm/CodeGen/MIRYamlMapping.h
llvm-devel/include/llvm/CodeGen/MachORelocation.h
llvm-devel/include/llvm/CodeGen/MachineBasicBlock.h
@@ -2698,6 +2737,7 @@ llvm-devel/include/llvm/ExecutionEngine/Interpreter.h
llvm-devel/include/llvm/ExecutionEngine/JITEventListener.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/EHFrameSupport.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/ELF.h
+llvm-devel/include/llvm/ExecutionEngine/JITLink/ELF_aarch64.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/ELF_riscv.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/ELF_x86_64.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/JITLink.h
@@ -2706,6 +2746,7 @@ llvm-devel/include/llvm/ExecutionEngine/JITLink/JITLinkMemoryManager.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/MachO.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/MachO_arm64.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/MachO_x86_64.h
+llvm-devel/include/llvm/ExecutionEngine/JITLink/aarch64.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/riscv.h
llvm-devel/include/llvm/ExecutionEngine/JITLink/x86_64.h
llvm-devel/include/llvm/ExecutionEngine/JITSymbol.h
@@ -2717,9 +2758,14 @@ llvm-devel/include/llvm/ExecutionEngine/Orc/CompileUtils.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Core.h
llvm-devel/include/llvm/ExecutionEngine/Orc/DebugObjectManagerPlugin.h
llvm-devel/include/llvm/ExecutionEngine/Orc/DebugUtils.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/ELFNixPlatform.h
llvm-devel/include/llvm/ExecutionEngine/Orc/EPCDebugObjectRegistrar.h
llvm-devel/include/llvm/ExecutionEngine/Orc/EPCDynamicLibrarySearchGenerator.h
llvm-devel/include/llvm/ExecutionEngine/Orc/EPCEHFrameRegistrar.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/EPCGenericDylibManager.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/EPCGenericJITLinkMemoryManager.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/EPCGenericMemoryAccess.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/EPCGenericRTDyldMemoryManager.h
llvm-devel/include/llvm/ExecutionEngine/Orc/EPCIndirectionUtils.h
llvm-devel/include/llvm/ExecutionEngine/Orc/ExecutionUtils.h
llvm-devel/include/llvm/ExecutionEngine/Orc/ExecutorProcessControl.h
@@ -2728,38 +2774,34 @@ llvm-devel/include/llvm/ExecutionEngine/Orc/IRTransformLayer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/IndirectionUtils.h
llvm-devel/include/llvm/ExecutionEngine/Orc/JITTargetMachineBuilder.h
llvm-devel/include/llvm/ExecutionEngine/Orc/LLJIT.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/LLVMSPSSerializers.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Layer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/LazyReexports.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/LookupAndRecordAddrs.h
llvm-devel/include/llvm/ExecutionEngine/Orc/MachOPlatform.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Mangling.h
llvm-devel/include/llvm/ExecutionEngine/Orc/ObjectLinkingLayer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/ObjectTransformLayer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/OrcABISupport.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/OrcRPCExecutorProcessControl.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetRPCAPI.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetServer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/RTDyldObjectLinkingLayer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/ExecutorAddress.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/FDRawByteChannel.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/OrcError.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/RPCUtils.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/RawByteChannel.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/Serialization.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/OrcRTBridge.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/SimplePackedSerialization.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/SimpleRemoteEPCUtils.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/TargetProcessControlTypes.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Shared/WrapperFunctionUtils.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/SimpleRemoteEPC.h
llvm-devel/include/llvm/ExecutionEngine/Orc/SpeculateAnalyses.h
llvm-devel/include/llvm/ExecutionEngine/Orc/Speculation.h
llvm-devel/include/llvm/ExecutionEngine/Orc/SymbolStringPool.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/ExecutorBootstrapService.h
llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/JITLoaderGDB.h
-llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/OrcRPCTPCServer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/RegisterEHFrames.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/SimpleExecutorDylibManager.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/SimpleExecutorMemoryManager.h
+llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/SimpleRemoteEPCServer.h
llvm-devel/include/llvm/ExecutionEngine/Orc/TargetProcess/TargetExecutionUtils.h
llvm-devel/include/llvm/ExecutionEngine/Orc/ThreadSafeModule.h
-llvm-devel/include/llvm/ExecutionEngine/OrcMCJITReplacement.h
-llvm-devel/include/llvm/ExecutionEngine/OrcV1Deprecation.h
llvm-devel/include/llvm/ExecutionEngine/RTDyldMemoryManager.h
llvm-devel/include/llvm/ExecutionEngine/RuntimeDyld.h
llvm-devel/include/llvm/ExecutionEngine/RuntimeDyldChecker.h
@@ -2945,6 +2987,7 @@ llvm-devel/include/llvm/MC/MCAsmInfo.h
llvm-devel/include/llvm/MC/MCAsmInfoCOFF.h
llvm-devel/include/llvm/MC/MCAsmInfoDarwin.h
llvm-devel/include/llvm/MC/MCAsmInfoELF.h
+llvm-devel/include/llvm/MC/MCAsmInfoGOFF.h
llvm-devel/include/llvm/MC/MCAsmInfoWasm.h
llvm-devel/include/llvm/MC/MCAsmInfoXCOFF.h
llvm-devel/include/llvm/MC/MCAsmLayout.h
@@ -3045,6 +3088,7 @@ llvm-devel/include/llvm/MCA/Stages/MicroOpQueueStage.h
llvm-devel/include/llvm/MCA/Stages/RetireStage.h
llvm-devel/include/llvm/MCA/Stages/Stage.h
llvm-devel/include/llvm/MCA/Support.h
+llvm-devel/include/llvm/MCA/View.h
llvm-devel/include/llvm/Object/Archive.h
llvm-devel/include/llvm/Object/ArchiveWriter.h
llvm-devel/include/llvm/Object/Binary.h
@@ -3187,6 +3231,7 @@ llvm-devel/include/llvm/Support/DataTypes.h
llvm-devel/include/llvm/Support/Debug.h
llvm-devel/include/llvm/Support/DebugCounter.h
llvm-devel/include/llvm/Support/Discriminator.h
+llvm-devel/include/llvm/Support/DivisionByConstantInfo.h
llvm-devel/include/llvm/Support/DynamicLibrary.h
llvm-devel/include/llvm/Support/ELFAttributeParser.h
llvm-devel/include/llvm/Support/ELFAttributes.h
@@ -3217,6 +3262,7 @@ llvm-devel/include/llvm/Support/GenericDomTreeConstruction.h
llvm-devel/include/llvm/Support/GenericIteratedDominanceFrontier.h
llvm-devel/include/llvm/Support/GlobPattern.h
llvm-devel/include/llvm/Support/GraphWriter.h
+llvm-devel/include/llvm/Support/HashBuilder.h
llvm-devel/include/llvm/Support/Host.h
llvm-devel/include/llvm/Support/InitLLVM.h
llvm-devel/include/llvm/Support/InstructionCost.h
@@ -3230,6 +3276,8 @@ llvm-devel/include/llvm/Support/Locale.h
llvm-devel/include/llvm/Support/LockFileManager.h
llvm-devel/include/llvm/Support/LowLevelTypeImpl.h
llvm-devel/include/llvm/Support/MD5.h
+llvm-devel/include/llvm/Support/MSP430AttributeParser.h
+llvm-devel/include/llvm/Support/MSP430Attributes.h
llvm-devel/include/llvm/Support/MSVCErrorWorkarounds.h
llvm-devel/include/llvm/Support/MachineValueType.h
llvm-devel/include/llvm/Support/ManagedStatic.h
@@ -3243,6 +3291,7 @@ llvm-devel/include/llvm/Support/Mutex.h
llvm-devel/include/llvm/Support/NativeFormatting.h
llvm-devel/include/llvm/Support/OnDiskHashTable.h
llvm-devel/include/llvm/Support/OptimizedStructLayout.h
+llvm-devel/include/llvm/Support/PGOOptions.h
llvm-devel/include/llvm/Support/Parallel.h
llvm-devel/include/llvm/Support/Path.h
llvm-devel/include/llvm/Support/PluginLoader.h
@@ -3407,7 +3456,6 @@ llvm-devel/include/llvm/Transforms/IPO/SyntheticCountsPropagation.h
llvm-devel/include/llvm/Transforms/IPO/ThinLTOBitcodeWriter.h
llvm-devel/include/llvm/Transforms/IPO/WholeProgramDevirt.h
llvm-devel/include/llvm/Transforms/InstCombine/InstCombine.h
-llvm-devel/include/llvm/Transforms/InstCombine/InstCombineWorklist.h
llvm-devel/include/llvm/Transforms/InstCombine/InstCombiner.h
llvm-devel/include/llvm/Transforms/Instrumentation.h
llvm-devel/include/llvm/Transforms/Instrumentation/AddressSanitizer.h
@@ -3532,6 +3580,7 @@ llvm-devel/include/llvm/Transforms/Utils/GuardUtils.h
llvm-devel/include/llvm/Transforms/Utils/HelloWorld.h
llvm-devel/include/llvm/Transforms/Utils/InjectTLIMappings.h
llvm-devel/include/llvm/Transforms/Utils/InstructionNamer.h
+llvm-devel/include/llvm/Transforms/Utils/InstructionWorklist.h
llvm-devel/include/llvm/Transforms/Utils/IntegerDivision.h
llvm-devel/include/llvm/Transforms/Utils/LCSSA.h
llvm-devel/include/llvm/Transforms/Utils/LibCallsShrinkWrap.h
@@ -3696,6 +3745,7 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/Conversion/Passes.h
%%MLIR%%llvm-devel/include/mlir/Conversion/Passes.h.inc
%%MLIR%%llvm-devel/include/mlir/Conversion/Passes.td
+%%MLIR%%llvm-devel/include/mlir/Conversion/ReconcileUnrealizedCasts/ReconcileUnrealizedCasts.h
%%MLIR%%llvm-devel/include/mlir/Conversion/SCFToGPU/SCFToGPU.h
%%MLIR%%llvm-devel/include/mlir/Conversion/SCFToGPU/SCFToGPUPass.h
%%MLIR%%llvm-devel/include/mlir/Conversion/SCFToOpenMP/SCFToOpenMP.h
@@ -3882,7 +3932,6 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/Dialect/LLVMIR/Transforms/Passes.h
%%MLIR%%llvm-devel/include/mlir/Dialect/LLVMIR/Transforms/Passes.h.inc
%%MLIR%%llvm-devel/include/mlir/Dialect/LLVMIR/Transforms/Passes.td
-%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Analysis/ConstraintsSet.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Analysis/DependenceAnalysis.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgBase.td
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgDoc.td
@@ -3890,8 +3939,6 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgInterfaces.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgInterfaces.h.inc
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgInterfaces.td
-%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgNamedStructuredOps.tcgen.cpp.inc
-%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgNamedStructuredOps.tcgen.td
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgNamedStructuredOps.yamlgen.cpp.inc
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgNamedStructuredOps.yamlgen.td
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/IR/LinalgOps.cpp.inc
@@ -3912,6 +3959,8 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Passes.h.inc
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Passes.td
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Transforms/CodegenStrategy.h
+%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Transforms/ComprehensiveBufferize.h
+%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Transforms/HoistPadding.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Transforms/Hoisting.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Transforms/Transforms.h
%%MLIR%%llvm-devel/include/mlir/Dialect/Linalg/Utils/Utils.h
@@ -4185,6 +4234,10 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/IR/BlockAndValueMapping.h
%%MLIR%%llvm-devel/include/mlir/IR/BlockSupport.h
%%MLIR%%llvm-devel/include/mlir/IR/Builders.h
+%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributeInterfaces.cpp.inc
+%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributeInterfaces.h
+%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributeInterfaces.h.inc
+%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributeInterfaces.td
%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributes.cpp.inc
%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributes.h
%%MLIR%%llvm-devel/include/mlir/IR/BuiltinAttributes.h.inc
@@ -4306,6 +4359,10 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/Interfaces/SideEffectInterfaces.h
%%MLIR%%llvm-devel/include/mlir/Interfaces/SideEffectInterfaces.h.inc
%%MLIR%%llvm-devel/include/mlir/Interfaces/SideEffectInterfaces.td
+%%MLIR%%llvm-devel/include/mlir/Interfaces/TilingInterface.cpp.inc
+%%MLIR%%llvm-devel/include/mlir/Interfaces/TilingInterface.h
+%%MLIR%%llvm-devel/include/mlir/Interfaces/TilingInterface.h.inc
+%%MLIR%%llvm-devel/include/mlir/Interfaces/TilingInterface.td
%%MLIR%%llvm-devel/include/mlir/Interfaces/VectorInterfaces.cpp.inc
%%MLIR%%llvm-devel/include/mlir/Interfaces/VectorInterfaces.h
%%MLIR%%llvm-devel/include/mlir/Interfaces/VectorInterfaces.h.inc
@@ -4369,6 +4426,7 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%MLIR%%llvm-devel/include/mlir/TableGen/Successor.h
%%MLIR%%llvm-devel/include/mlir/TableGen/Trait.h
%%MLIR%%llvm-devel/include/mlir/TableGen/Type.h
+%%MLIR%%llvm-devel/include/mlir/Target/Cpp/CppEmitter.h
%%MLIR%%llvm-devel/include/mlir/Target/LLVMIR/Dialect/AMX/AMXToLLVMIRTranslation.h
%%MLIR%%llvm-devel/include/mlir/Target/LLVMIR/Dialect/All.h
%%MLIR%%llvm-devel/include/mlir/Target/LLVMIR/Dialect/ArmNeon/ArmNeonToLLVMIRTranslation.h
@@ -4481,6 +4539,7 @@ llvm-devel/include/llvm/XRay/YAMLXRayRecord.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/clwbintrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/clzerointrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/cpuid.h
+%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/crc32intrin.h
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/cuda_wrappers/algorithm
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/cuda_wrappers/complex
%%CLANG%%llvm-devel/lib/clang/%%LLVM_RELEASE%%/include/cuda_wrappers/new
@@ -4608,6 +4667,7 @@ llvm-devel/lib/cmake/llvm/AddSphinxTarget.cmake
llvm-devel/lib/cmake/llvm/CheckAtomic.cmake
llvm-devel/lib/cmake/llvm/CheckCompilerVersion.cmake
llvm-devel/lib/cmake/llvm/ChooseMSVCCRT.cmake
+llvm-devel/lib/cmake/llvm/CoverageReport.cmake
llvm-devel/lib/cmake/llvm/CrossCompile.cmake
llvm-devel/lib/cmake/llvm/DetermineGCCCompatible.cmake
llvm-devel/lib/cmake/llvm/FindGRPC.cmake
@@ -4643,7 +4703,10 @@ llvm-devel/lib/cmake/llvm/VersionFromVCS.cmake
%%MLIR%%llvm-devel/lib/cmake/mlir/MLIRTargets-%%CMAKE_BUILD_TYPE%%.cmake
%%MLIR%%llvm-devel/lib/cmake/mlir/MLIRTargets.cmake
%%OPENMP%%llvm-devel/lib/cmake/openmp/FindOpenMPTarget.cmake
-%%STATIC_LIBS%%%%FLANG%%llvm-devel/lib/libFIROptimizer.a
+%%STATIC_LIBS%%llvm-devel/lib/libFIRCodeGen.a
+%%STATIC_LIBS%%llvm-devel/lib/libFIRDialect.a
+%%STATIC_LIBS%%llvm-devel/lib/libFIRSupport.a
+%%STATIC_LIBS%%llvm-devel/lib/libFIRTransforms.a
%%STATIC_LIBS%%%%FLANG%%llvm-devel/lib/libFortranCommon.a
%%STATIC_LIBS%%%%FLANG%%llvm-devel/lib/libFortranDecimal.a
%%STATIC_LIBS%%%%FLANG%%llvm-devel/lib/libFortranEvaluate.a
@@ -4926,6 +4989,7 @@ llvm-devel/lib/libLTO.so.%%LLVM_MAJOR%%git
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRQuant.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRROCDLIR.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRROCDLToLLVMIRTranslation.a
+%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRReconcileUnrealizedCasts.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRReduce.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRReduceLib.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRRewrite.a
@@ -4963,6 +5027,7 @@ llvm-devel/lib/libLTO.so.%%LLVM_MAJOR%%git
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRSupport.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRSupportIndentedOstream.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTableGen.a
+%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTargetCpp.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTargetLLVMIRExport.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTargetLLVMIRImport.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTensor.a
@@ -4975,6 +5040,7 @@ llvm-devel/lib/libLTO.so.%%LLVM_MAJOR%%git
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTestRewrite.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTestStandardToLLVM.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTestTransforms.a
+%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTilingInterface.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRToLLVMIRTranslationRegistration.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTosa.a
%%STATIC_LIBS%%%%MLIR%%llvm-devel/lib/libMLIRTosaTestPasses.a