aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-etoile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-04-07 18:45:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-04-07 18:45:00 +0000
commitd7ef5595516e11db2c118b67341810466aa644dd (patch)
tree1f97e747cb678168863c70567d03186688579368 /devel/llvm-etoile
parent65782daa2c7138ea95560bd92cf3bea3f92be05e (diff)
downloadports-d7ef5595516e11db2c118b67341810466aa644dd.tar.gz
ports-d7ef5595516e11db2c118b67341810466aa644dd.zip
Low Level Virtual Machine (LLVM) is:
- A compilation strategy designed to enable effective program optimization across the entire lifetime of a program. - A virtual instruction set. - A compiler infrastructure. - LLVM does not imply things that you would expect from a high-level virtual machine. It does not require garbage collection or run-time code generation. This port is only to build the Etoile project. WWW: http://llvm.cs.uiuc.edu/
Notes
Notes: svn path=/head/; revision=272350
Diffstat (limited to 'devel/llvm-etoile')
-rw-r--r--devel/llvm-etoile/Makefile143
-rw-r--r--devel/llvm-etoile/Makefile.svn_rev1
-rw-r--r--devel/llvm-etoile/distinfo2
-rw-r--r--devel/llvm-etoile/files/patch-tools_clang_lib_Headers_Makefile14
-rw-r--r--devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaChecking.cpp39
-rw-r--r--devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaDeclAttr.cpp17
-rw-r--r--devel/llvm-etoile/files/patch-tools_clang_utils_scan-build23
-rw-r--r--devel/llvm-etoile/pkg-descr12
-rw-r--r--devel/llvm-etoile/pkg-plist568
9 files changed, 819 insertions, 0 deletions
diff --git a/devel/llvm-etoile/Makefile b/devel/llvm-etoile/Makefile
new file mode 100644
index 000000000000..f476a9d70d7c
--- /dev/null
+++ b/devel/llvm-etoile/Makefile
@@ -0,0 +1,143 @@
+# New ports collection makefile for: llvm
+# Date created: 20 Nov 2005
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= llvm
+DISTVERSION= 2.6.r${SVN_REV}
+CATEGORIES= devel lang
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMESUFFIX= -etoile${PKGNAMESUFFIX2}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Low Level Virtual Machine
+
+.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
+BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
+.endif
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
+.endif
+
+CONFLICTS= llvm-devel-2* llvm-2*
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_PERL5= yes
+USE_PYTHON_RUN= yes
+MAKE_JOBS_SAFE= yes
+
+.if defined(MAINTAINER_MODE)
+CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --enable-optimized
+.endif
+
+MAN1= bugpoint.1 clang.1 llc.1 lli.1 llvmc.1 llvm-ar.1 \
+ llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
+ llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
+ llvm-prof.1 llvm-ranlib.1 llvmgcc.1 \
+ llvmgxx.1 opt.1 tblgen.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(BOOTSTRAP)
+SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d' ' -f2
+.else
+.include "Makefile.svn_rev"
+.endif
+
+.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
+BROKEN= does not compile
+.elif ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} \
+ http://llvm.org/svn/llvm-project/llvm/trunk ${WRKSRC}
+ svn export -r ${SVN_REV} \
+ http://llvm.org/svn/llvm-project/cfe/trunk ${WRKSRC}/tools/clang
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+ echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
+.if ${USER} == brooks
+ scp ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,\(PROJ_docsdir.*:=\).*$$,\1${DOCSDIR},g' \
+ ${WRKSRC}/Makefile.config.in
+ ${REINPLACE_CMD} -e 's,\(PROJ_mandir.*:=\).*$$,\1${MANPREFIX}/man,g' \
+ ${WRKSRC}/Makefile.config.in
+ ${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
+ ${WRKSRC}/tools/clang/utils/scan-build
+ ${REINPLACE_CMD} -e 's|/usr/bin/env perl|${PERL}|' \
+ ${WRKSRC}/tools/clang/utils/ccc-analyzer \
+ ${WRKSRC}/tools/clang/utils/scan-build
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/ccc-analyzer \
+ ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/clang/utils/scan-build \
+ ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/tools/clang/utils/scanview.css ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/tools/clang/utils/sorttable.js ${DATADIR}
+
+TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)'
+regression-test: ${BUILD_COOKIE}
+ if [ `${ID} -u` = 0 ]; then \
+ ${CHOWN} -R nobody ${WRKSRC}/test; \
+ su -m nobody -c ${TEST_CMD}; \
+ else \
+ ${SH} -c ${TEST_CMD}; \
+ fi
+
+PLIST_FILE_LIST= bin/bugpoint \
+ bin/ccc-analyzer \
+ bin/clang* \
+ bin/gccas \
+ bin/gccld \
+ bin/llc \
+ bin/lli \
+ bin/llvm* \
+ bin/opt \
+ bin/scan-build \
+ lib/CompilerDriver.o \
+ lib/LLVM* \
+ lib/libLTO.so \
+ lib/libLLVM* \
+ lib/libclang* \
+ lib/plugin_llvm* \
+ libexec/clang-cc
+PLIST_DIR_LIST= include/llvm-c \
+ include/llvm \
+ lib/clang
+build-plist:
+ ${RM} ${PLIST}
+ cd ${PREFIX} && \
+ (ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
+ ${SORT} >> ${PLIST}
+ ${FIND} ${DATADIR} ${DOCSDIR} -type f | \
+ ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+ -e 's|${DOCSDIR}|%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
+ cd ${PREFIX} && \
+ ${FIND} ${PLIST_DIR_LIST} -type d | \
+ ${SORT} -r | ${SED} -e 's|^|@dirrm |' >> ${PLIST}
+ ${FIND} ${DATADIR} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+ -e 's|${DOCSDIR}|%%DOCSDIR%%|' \
+ -e 's|^|@dirrm |' >> ${PLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/llvm-etoile/Makefile.svn_rev b/devel/llvm-etoile/Makefile.svn_rev
new file mode 100644
index 000000000000..2f314c22ae16
--- /dev/null
+++ b/devel/llvm-etoile/Makefile.svn_rev
@@ -0,0 +1 @@
+SVN_REV= 71086
diff --git a/devel/llvm-etoile/distinfo b/devel/llvm-etoile/distinfo
new file mode 100644
index 000000000000..6eac92392e45
--- /dev/null
+++ b/devel/llvm-etoile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (llvm-2.6.r71086.tar.bz2) = b39c9e110192498a4e6fbd07ba95d98925e069c2a087cd36242822fe238dc618
+SIZE (llvm-2.6.r71086.tar.bz2) = 7927312
diff --git a/devel/llvm-etoile/files/patch-tools_clang_lib_Headers_Makefile b/devel/llvm-etoile/files/patch-tools_clang_lib_Headers_Makefile
new file mode 100644
index 000000000000..7c7501cf1285
--- /dev/null
+++ b/devel/llvm-etoile/files/patch-tools_clang_lib_Headers_Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD: /tmp/pcvs/ports/devel/llvm-etoile/files/patch-tools_clang_lib_Headers_Makefile,v 1.1 2011-04-07 18:45:00 dinoex Exp $
+
+--- tools/clang/lib/Headers/Makefile.orig
++++ tools/clang/lib/Headers/Makefile
+@@ -13,7 +13,7 @@
+ # FIXME: Get version from a common place.
+ HeaderDir := $(PROJ_OBJ_ROOT)/$(BuildMode)/lib/clang/1.0/include
+
+-HEADERS := $(notdir $(wildcard $(PROJ_SRC_DIR)/*.h))
++HEADERS := $(notdir $(wildcard $(PROJ_SRC_DIR)/*mm*.h))
+
+ OBJHEADERS := $(addprefix $(HeaderDir)/, $(HEADERS))
+
diff --git a/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaChecking.cpp b/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaChecking.cpp
new file mode 100644
index 000000000000..90007aa0e714
--- /dev/null
+++ b/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaChecking.cpp
@@ -0,0 +1,39 @@
+
+$FreeBSD: /tmp/pcvs/ports/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaChecking.cpp,v 1.1 2011-04-07 18:45:00 dinoex Exp $
+
+--- tools/clang/lib/Sema/SemaChecking.cpp.orig
++++ tools/clang/lib/Sema/SemaChecking.cpp
+@@ -142,7 +142,7 @@
+
+ // Printf checking.
+ if (const FormatAttr *Format = FDecl->getAttr<FormatAttr>()) {
+- if (Format->getType() == "printf") {
++ if (Format->getType() == "printf" || Format->getType() == "printf0") {
+ bool HasVAListArg = Format->getFirstArg() == 0;
+ if (!HasVAListArg) {
+ if (const FunctionProtoType *Proto
+@@ -701,7 +701,6 @@
+ case 'u':
+ case 'x':
+ case 'X':
+- case 'D':
+ case 'O':
+ case 'U':
+ case 'e':
+@@ -717,9 +716,16 @@
+ case 'S':
+ case 's':
+ case 'p':
++ case 'r':
++ case 'y':
+ ++numConversions;
+ CurrentState = state_OrdChr;
+ break;
++ case 'b':
++ case 'D':
++ numConversions += 2;
++ CurrentState = state_OrdChr;
++ break;
+
+ // CHECK: Are we using "%n"? Issue a warning.
+ case 'n': {
diff --git a/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaDeclAttr.cpp b/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaDeclAttr.cpp
new file mode 100644
index 000000000000..6ab822427b94
--- /dev/null
+++ b/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaDeclAttr.cpp
@@ -0,0 +1,17 @@
+
+$FreeBSD: /tmp/pcvs/ports/devel/llvm-etoile/files/patch-tools_clang_lib_Sema_SemaDeclAttr.cpp,v 1.1 2011-04-07 18:45:00 dinoex Exp $
+
+--- tools/clang/lib/Sema/SemaDeclAttr.cpp.orig
++++ tools/clang/lib/Sema/SemaDeclAttr.cpp
+@@ -1011,7 +1011,10 @@
+ default: break;
+ case 5: Supported = !memcmp(Format, "scanf", 5); break;
+ case 6: Supported = !memcmp(Format, "printf", 6); break;
+- case 7: Supported = !memcmp(Format, "strfmon", 7); break;
++ case 7:
++ Supported = (!memcmp(Format, "strfmon", 7) ||
++ !memcmp(Format, "printf0", 7));
++ break;
+ case 8:
+ Supported = (is_strftime = !memcmp(Format, "strftime", 8)) ||
+ (is_NSString = !memcmp(Format, "NSString", 8)) ||
diff --git a/devel/llvm-etoile/files/patch-tools_clang_utils_scan-build b/devel/llvm-etoile/files/patch-tools_clang_utils_scan-build
new file mode 100644
index 000000000000..e3136472668f
--- /dev/null
+++ b/devel/llvm-etoile/files/patch-tools_clang_utils_scan-build
@@ -0,0 +1,23 @@
+
+$FreeBSD: /tmp/pcvs/ports/devel/llvm-etoile/files/patch-tools_clang_utils_scan-build,v 1.1 2011-04-07 18:45:00 dinoex Exp $
+
+--- tools/clang/utils/scan-build.orig
++++ tools/clang/utils/scan-build
+@@ -406,7 +406,7 @@
+
+ my $Dir = shift;
+
+- my $JS = Cwd::realpath("$RealBin/sorttable.js");
++ my $JS = Cwd::realpath("%%DATADIR%%/sorttable.js");
+
+ DieDiag("Cannot find 'sorttable.js'.\n")
+ if (! -r $JS);
+@@ -410,7 +410,7 @@
+ DieDiag("Could not copy 'sorttable.js' to '$Dir'.\n")
+ if (! -r "$Dir/sorttable.js");
+
+- my $CSS = Cwd::realpath("$RealBin/scanview.css");
++ my $CSS = Cwd::realpath("%%DATADIR%%/scanview.css");
+
+ DieDiag("Cannot find 'scanview.css'.\n")
+ if (! -r $CSS);
diff --git a/devel/llvm-etoile/pkg-descr b/devel/llvm-etoile/pkg-descr
new file mode 100644
index 000000000000..2d2f131e12ef
--- /dev/null
+++ b/devel/llvm-etoile/pkg-descr
@@ -0,0 +1,12 @@
+Low Level Virtual Machine (LLVM) is:
+- A compilation strategy designed to enable effective program
+ optimization across the entire lifetime of a program.
+- A virtual instruction set.
+- A compiler infrastructure.
+- LLVM does not imply things that you would expect from a high-level
+ virtual machine. It does not require garbage collection or run-time
+ code generation.
+
+This port is only to build the Etoile project.
+
+WWW: http://llvm.cs.uiuc.edu/
diff --git a/devel/llvm-etoile/pkg-plist b/devel/llvm-etoile/pkg-plist
new file mode 100644
index 000000000000..7633627d6d22
--- /dev/null
+++ b/devel/llvm-etoile/pkg-plist
@@ -0,0 +1,568 @@
+bin/bugpoint
+bin/ccc-analyzer
+bin/clang
+bin/gccas
+bin/gccld
+bin/llc
+bin/lli
+bin/llvm-ar
+bin/llvm-as
+bin/llvm-bcanalyzer
+bin/llvm-config
+bin/llvm-db
+bin/llvm-dis
+bin/llvm-extract
+bin/llvm-ld
+bin/llvm-link
+bin/llvm-nm
+bin/llvm-prof
+bin/llvm-ranlib
+bin/llvm-stub
+bin/llvmc
+bin/opt
+bin/scan-build
+include/llvm-c/Analysis.h
+include/llvm-c/BitReader.h
+include/llvm-c/BitWriter.h
+include/llvm-c/Core.h
+include/llvm-c/ExecutionEngine.h
+include/llvm-c/LinkTimeOptimizer.h
+include/llvm-c/Target.h
+include/llvm-c/Transforms/IPO.h
+include/llvm-c/Transforms/Scalar.h
+include/llvm-c/lto.h
+include/llvm/ADT/APFloat.h
+include/llvm/ADT/APInt.h
+include/llvm/ADT/APSInt.h
+include/llvm/ADT/BitVector.h
+include/llvm/ADT/DenseMap.h
+include/llvm/ADT/DenseSet.h
+include/llvm/ADT/DepthFirstIterator.h
+include/llvm/ADT/EquivalenceClasses.h
+include/llvm/ADT/FoldingSet.h
+include/llvm/ADT/GraphTraits.h
+include/llvm/ADT/HashExtras.h
+include/llvm/ADT/ImmutableList.h
+include/llvm/ADT/ImmutableMap.h
+include/llvm/ADT/ImmutableSet.h
+include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/IntrusiveRefCntPtr.h
+include/llvm/ADT/OwningPtr.h
+include/llvm/ADT/PointerIntPair.h
+include/llvm/ADT/PointerUnion.h
+include/llvm/ADT/PostOrderIterator.h
+include/llvm/ADT/PriorityQueue.h
+include/llvm/ADT/SCCIterator.h
+include/llvm/ADT/STLExtras.h
+include/llvm/ADT/ScopedHashTable.h
+include/llvm/ADT/SetOperations.h
+include/llvm/ADT/SetVector.h
+include/llvm/ADT/SmallPtrSet.h
+include/llvm/ADT/SmallSet.h
+include/llvm/ADT/SmallString.h
+include/llvm/ADT/SmallVector.h
+include/llvm/ADT/SparseBitVector.h
+include/llvm/ADT/Statistic.h
+include/llvm/ADT/StringExtras.h
+include/llvm/ADT/StringMap.h
+include/llvm/ADT/StringSet.h
+include/llvm/ADT/Tree.h
+include/llvm/ADT/Trie.h
+include/llvm/ADT/Triple.h
+include/llvm/ADT/UniqueVector.h
+include/llvm/ADT/VectorExtras.h
+include/llvm/ADT/ilist.h
+include/llvm/ADT/ilist_node.h
+include/llvm/ADT/iterator.cmake
+include/llvm/ADT/iterator.h
+include/llvm/AbstractTypeUser.h
+include/llvm/Analysis/AliasAnalysis.h
+include/llvm/Analysis/AliasSetTracker.h
+include/llvm/Analysis/CFGPrinter.h
+include/llvm/Analysis/CallGraph.h
+include/llvm/Analysis/CaptureTracking.h
+include/llvm/Analysis/ConstantFolding.h
+include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DebugInfo.h
+include/llvm/Analysis/DominatorInternals.h
+include/llvm/Analysis/Dominators.h
+include/llvm/Analysis/FindUsedTypes.h
+include/llvm/Analysis/Interval.h
+include/llvm/Analysis/IntervalIterator.h
+include/llvm/Analysis/IntervalPartition.h
+include/llvm/Analysis/LibCallAliasAnalysis.h
+include/llvm/Analysis/LibCallSemantics.h
+include/llvm/Analysis/LiveValues.h
+include/llvm/Analysis/LoopInfo.h
+include/llvm/Analysis/LoopPass.h
+include/llvm/Analysis/LoopVR.h
+include/llvm/Analysis/MemoryDependenceAnalysis.h
+include/llvm/Analysis/Passes.h
+include/llvm/Analysis/PostDominators.h
+include/llvm/Analysis/ProfileInfo.h
+include/llvm/Analysis/ProfileInfoLoader.h
+include/llvm/Analysis/ProfileInfoTypes.h
+include/llvm/Analysis/ScalarEvolution.h
+include/llvm/Analysis/ScalarEvolutionExpander.h
+include/llvm/Analysis/ScalarEvolutionExpressions.h
+include/llvm/Analysis/SparsePropagation.h
+include/llvm/Analysis/Trace.h
+include/llvm/Analysis/ValueTracking.h
+include/llvm/Analysis/Verifier.h
+include/llvm/Argument.h
+include/llvm/Assembly/AsmAnnotationWriter.h
+include/llvm/Assembly/Parser.h
+include/llvm/Assembly/PrintModulePass.h
+include/llvm/Assembly/Writer.h
+include/llvm/Attributes.h
+include/llvm/AutoUpgrade.h
+include/llvm/BasicBlock.h
+include/llvm/Bitcode/Archive.h
+include/llvm/Bitcode/BitCodes.h
+include/llvm/Bitcode/BitstreamReader.h
+include/llvm/Bitcode/BitstreamWriter.h
+include/llvm/Bitcode/Deserialize.h
+include/llvm/Bitcode/LLVMBitCodes.h
+include/llvm/Bitcode/ReaderWriter.h
+include/llvm/Bitcode/Serialization.h
+include/llvm/Bitcode/SerializationFwd.h
+include/llvm/Bitcode/Serialize.h
+include/llvm/CMakeLists.txt
+include/llvm/CallGraphSCCPass.h
+include/llvm/CallingConv.h
+include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/BreakCriticalMachineEdge.h
+include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/DAGISelHeader.h
+include/llvm/CodeGen/DebugLoc.h
+include/llvm/CodeGen/DwarfWriter.h
+include/llvm/CodeGen/ELFRelocation.h
+include/llvm/CodeGen/FastISel.h
+include/llvm/CodeGen/FileWriters.h
+include/llvm/CodeGen/GCMetadata.h
+include/llvm/CodeGen/GCMetadataPrinter.h
+include/llvm/CodeGen/GCStrategy.h
+include/llvm/CodeGen/GCs.h
+include/llvm/CodeGen/IntrinsicLowering.h
+include/llvm/CodeGen/LatencyPriorityQueue.h
+include/llvm/CodeGen/LinkAllAsmWriterComponents.h
+include/llvm/CodeGen/LinkAllCodegenComponents.h
+include/llvm/CodeGen/LiveInterval.h
+include/llvm/CodeGen/LiveIntervalAnalysis.h
+include/llvm/CodeGen/LiveStackAnalysis.h
+include/llvm/CodeGen/LiveVariables.h
+include/llvm/CodeGen/MachORelocation.h
+include/llvm/CodeGen/MachineBasicBlock.h
+include/llvm/CodeGen/MachineCodeEmitter.h
+include/llvm/CodeGen/MachineConstantPool.h
+include/llvm/CodeGen/MachineDominators.h
+include/llvm/CodeGen/MachineFrameInfo.h
+include/llvm/CodeGen/MachineFunction.h
+include/llvm/CodeGen/MachineFunctionPass.h
+include/llvm/CodeGen/MachineInstr.h
+include/llvm/CodeGen/MachineInstrBuilder.h
+include/llvm/CodeGen/MachineJumpTableInfo.h
+include/llvm/CodeGen/MachineLocation.h
+include/llvm/CodeGen/MachineLoopInfo.h
+include/llvm/CodeGen/MachineMemOperand.h
+include/llvm/CodeGen/MachineModuleInfo.h
+include/llvm/CodeGen/MachineOperand.h
+include/llvm/CodeGen/MachinePassRegistry.h
+include/llvm/CodeGen/MachineRegisterInfo.h
+include/llvm/CodeGen/MachineRelocation.h
+include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/PseudoSourceValue.h
+include/llvm/CodeGen/RegAllocRegistry.h
+include/llvm/CodeGen/RegisterCoalescer.h
+include/llvm/CodeGen/RegisterScavenging.h
+include/llvm/CodeGen/RuntimeLibcalls.h
+include/llvm/CodeGen/ScheduleDAG.h
+include/llvm/CodeGen/ScheduleHazardRecognizer.h
+include/llvm/CodeGen/SchedulerRegistry.h
+include/llvm/CodeGen/SelectionDAG.h
+include/llvm/CodeGen/SelectionDAGISel.h
+include/llvm/CodeGen/SelectionDAGNodes.h
+include/llvm/CodeGen/ValueTypes.h
+include/llvm/CodeGen/ValueTypes.td
+include/llvm/CompilerDriver/Action.h
+include/llvm/CompilerDriver/Common.td
+include/llvm/CompilerDriver/CompilationGraph.h
+include/llvm/CompilerDriver/Error.h
+include/llvm/CompilerDriver/Main.inc
+include/llvm/CompilerDriver/Plugin.h
+include/llvm/CompilerDriver/Tool.h
+include/llvm/Config/alloca.h
+include/llvm/Config/config.h
+include/llvm/Config/config.h.cmake
+include/llvm/Constant.h
+include/llvm/Constants.h
+include/llvm/Debugger/Debugger.h
+include/llvm/Debugger/InferiorProcess.h
+include/llvm/Debugger/ProgramInfo.h
+include/llvm/Debugger/RuntimeInfo.h
+include/llvm/Debugger/SourceFile.h
+include/llvm/Debugger/SourceLanguage.h
+include/llvm/DerivedTypes.h
+include/llvm/ExecutionEngine/ExecutionEngine.h
+include/llvm/ExecutionEngine/GenericValue.h
+include/llvm/ExecutionEngine/Interpreter.h
+include/llvm/ExecutionEngine/JIT.h
+include/llvm/ExecutionEngine/JITMemoryManager.h
+include/llvm/Function.h
+include/llvm/GlobalAlias.h
+include/llvm/GlobalValue.h
+include/llvm/GlobalVariable.h
+include/llvm/InlineAsm.h
+include/llvm/InstrTypes.h
+include/llvm/Instruction.def
+include/llvm/Instruction.h
+include/llvm/Instructions.h
+include/llvm/IntrinsicInst.h
+include/llvm/Intrinsics.gen
+include/llvm/Intrinsics.h
+include/llvm/Intrinsics.td
+include/llvm/IntrinsicsARM.td
+include/llvm/IntrinsicsAlpha.td
+include/llvm/IntrinsicsCellSPU.td
+include/llvm/IntrinsicsPowerPC.td
+include/llvm/IntrinsicsX86.td
+include/llvm/IntrinsicsXCore.td
+include/llvm/LinkAllPasses.h
+include/llvm/LinkAllVMCore.h
+include/llvm/Linker.h
+include/llvm/Module.h
+include/llvm/ModuleProvider.h
+include/llvm/OperandTraits.h
+include/llvm/Pass.h
+include/llvm/PassAnalysisSupport.h
+include/llvm/PassManager.h
+include/llvm/PassManagers.h
+include/llvm/PassSupport.h
+include/llvm/Support/AIXDataTypesFix.h
+include/llvm/Support/AlignOf.h
+include/llvm/Support/Allocator.h
+include/llvm/Support/Annotation.h
+include/llvm/Support/CFG.h
+include/llvm/Support/CallSite.h
+include/llvm/Support/Casting.h
+include/llvm/Support/CommandLine.h
+include/llvm/Support/Compiler.h
+include/llvm/Support/ConstantFolder.h
+include/llvm/Support/ConstantRange.h
+include/llvm/Support/DOTGraphTraits.h
+include/llvm/Support/DataFlow.h
+include/llvm/Support/DataTypes.h
+include/llvm/Support/DataTypes.h.cmake
+include/llvm/Support/Debug.h
+include/llvm/Support/Dwarf.h
+include/llvm/Support/DynamicLinker.h
+include/llvm/Support/ELF.h
+include/llvm/Support/FileUtilities.h
+include/llvm/Support/Format.h
+include/llvm/Support/GetElementPtrTypeIterator.h
+include/llvm/Support/GraphWriter.h
+include/llvm/Support/IRBuilder.h
+include/llvm/Support/InstIterator.h
+include/llvm/Support/InstVisitor.h
+include/llvm/Support/LeakDetector.h
+include/llvm/Support/ManagedStatic.h
+include/llvm/Support/Mangler.h
+include/llvm/Support/MathExtras.h
+include/llvm/Support/MemoryBuffer.h
+include/llvm/Support/MutexGuard.h
+include/llvm/Support/NoFolder.h
+include/llvm/Support/OutputBuffer.h
+include/llvm/Support/PassNameParser.h
+include/llvm/Support/PatternMatch.h
+include/llvm/Support/PluginLoader.h
+include/llvm/Support/PointerLikeTypeTraits.h
+include/llvm/Support/PredIteratorCache.h
+include/llvm/Support/PrettyStackTrace.h
+include/llvm/Support/Recycler.h
+include/llvm/Support/RecyclingAllocator.h
+include/llvm/Support/Registry.h
+include/llvm/Support/RegistryParser.h
+include/llvm/Support/SlowOperationInformer.h
+include/llvm/Support/StableBasicBlockNumbering.h
+include/llvm/Support/Streams.h
+include/llvm/Support/StringPool.h
+include/llvm/Support/SystemUtils.h
+include/llvm/Support/TargetFolder.h
+include/llvm/Support/Timer.h
+include/llvm/Support/TypeBuilder.h
+include/llvm/Support/ValueHandle.h
+include/llvm/Support/raw_ostream.h
+include/llvm/Support/type_traits.h
+include/llvm/SymbolTableListTraits.h
+include/llvm/System/Alarm.h
+include/llvm/System/Disassembler.h
+include/llvm/System/DynamicLibrary.h
+include/llvm/System/Host.h
+include/llvm/System/IncludeFile.h
+include/llvm/System/LICENSE.TXT
+include/llvm/System/Memory.h
+include/llvm/System/Mutex.h
+include/llvm/System/Path.h
+include/llvm/System/Process.h
+include/llvm/System/Program.h
+include/llvm/System/Signals.h
+include/llvm/System/Solaris.h
+include/llvm/System/TimeValue.h
+include/llvm/Target/DarwinTargetAsmInfo.h
+include/llvm/Target/ELFTargetAsmInfo.h
+include/llvm/Target/SubtargetFeature.h
+include/llvm/Target/Target.td
+include/llvm/Target/TargetAsmInfo.h
+include/llvm/Target/TargetCallingConv.td
+include/llvm/Target/TargetData.h
+include/llvm/Target/TargetELFWriterInfo.h
+include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetInstrDesc.h
+include/llvm/Target/TargetInstrInfo.h
+include/llvm/Target/TargetInstrItineraries.h
+include/llvm/Target/TargetIntrinsicInfo.h
+include/llvm/Target/TargetJITInfo.h
+include/llvm/Target/TargetLowering.h
+include/llvm/Target/TargetMachOWriterInfo.h
+include/llvm/Target/TargetMachine.h
+include/llvm/Target/TargetMachineRegistry.h
+include/llvm/Target/TargetOptions.h
+include/llvm/Target/TargetRegisterInfo.h
+include/llvm/Target/TargetSchedule.td
+include/llvm/Target/TargetSelectionDAG.td
+include/llvm/Target/TargetSubtarget.h
+include/llvm/Transforms/IPO.h
+include/llvm/Transforms/IPO/InlinerPass.h
+include/llvm/Transforms/Instrumentation.h
+include/llvm/Transforms/RSProfiling.h
+include/llvm/Transforms/Scalar.h
+include/llvm/Transforms/Utils/AddrModeMatcher.h
+include/llvm/Transforms/Utils/BasicBlockUtils.h
+include/llvm/Transforms/Utils/BasicInliner.h
+include/llvm/Transforms/Utils/Cloning.h
+include/llvm/Transforms/Utils/FunctionUtils.h
+include/llvm/Transforms/Utils/InlineCost.h
+include/llvm/Transforms/Utils/Local.h
+include/llvm/Transforms/Utils/PromoteMemToReg.h
+include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
+include/llvm/Transforms/Utils/UnrollLoop.h
+include/llvm/Transforms/Utils/ValueMapper.h
+include/llvm/Type.h
+include/llvm/TypeSymbolTable.h
+include/llvm/Use.h
+include/llvm/User.h
+include/llvm/Value.h
+include/llvm/ValueSymbolTable.h
+lib/CompilerDriver.o
+lib/LLVMARMAsmPrinter.o
+lib/LLVMARMCodeGen.o
+lib/LLVMAlphaAsmPrinter.o
+lib/LLVMAlphaCodeGen.o
+lib/LLVMCBackend.o
+lib/LLVMCellSPUAsmPrinter.o
+lib/LLVMCellSPUCodeGen.o
+lib/LLVMCppBackend.o
+lib/LLVMExecutionEngine.o
+lib/LLVMIA64AsmPrinter.o
+lib/LLVMIA64CodeGen.o
+lib/LLVMInterpreter.o
+lib/LLVMJIT.o
+lib/LLVMMSIL.o
+lib/LLVMMSP430.o
+lib/LLVMMipsAsmPrinter.o
+lib/LLVMMipsCodeGen.o
+lib/LLVMPIC16.o
+lib/LLVMPowerPCAsmPrinter.o
+lib/LLVMPowerPCCodeGen.o
+lib/LLVMSparcAsmPrinter.o
+lib/LLVMSparcCodeGen.o
+lib/LLVMX86AsmPrinter.o
+lib/LLVMX86CodeGen.o
+lib/LLVMXCore.o
+lib/clang/1.0/include/emmintrin.h
+lib/clang/1.0/include/mm_malloc.h
+lib/clang/1.0/include/mmintrin.h
+lib/clang/1.0/include/pmmintrin.h
+lib/clang/1.0/include/tmmintrin.h
+lib/clang/1.0/include/xmmintrin.h
+lib/libLLVMAnalysis.a
+lib/libLLVMArchive.a
+lib/libLLVMAsmParser.a
+lib/libLLVMAsmPrinter.a
+lib/libLLVMBitReader.a
+lib/libLLVMBitWriter.a
+lib/libLLVMCodeGen.a
+lib/libLLVMCore.a
+lib/libLLVMDebugger.a
+lib/libLLVMHello.so
+lib/libLLVMInstrumentation.a
+lib/libLLVMLinker.a
+lib/libLLVMScalarOpts.a
+lib/libLLVMSelectionDAG.a
+lib/libLLVMSupport.a
+lib/libLLVMSystem.a
+lib/libLLVMTarget.a
+lib/libLLVMTransformUtils.a
+lib/libLLVMipa.a
+lib/libLLVMipo.a
+lib/libLTO.so
+lib/libclangAST.a
+lib/libclangAnalysis.a
+lib/libclangBasic.a
+lib/libclangCodeGen.a
+lib/libclangDriver.a
+lib/libclangFrontend.a
+lib/libclangLex.a
+lib/libclangParse.a
+lib/libclangRewrite.a
+lib/libclangSema.a
+lib/plugin_llvmc_Base.o
+lib/plugin_llvmc_Clang.o
+libexec/clang-cc
+%%DATADIR%%/scanview.css
+%%DATADIR%%/sorttable.js
+%%DOCSDIR%%/html.tar.gz
+%%DOCSDIR%%/html/AliasAnalysis.html
+%%DOCSDIR%%/html/AnalyzerRegions.html
+%%DOCSDIR%%/html/BitCodeFormat.html
+%%DOCSDIR%%/html/Bugpoint.html
+%%DOCSDIR%%/html/CFEBuildInstrs.html
+%%DOCSDIR%%/html/CMake.html
+%%DOCSDIR%%/html/CodeGenerator.html
+%%DOCSDIR%%/html/CodingStandards.html
+%%DOCSDIR%%/html/CommandGuide/bugpoint.html
+%%DOCSDIR%%/html/CommandGuide/index.html
+%%DOCSDIR%%/html/CommandGuide/llc.html
+%%DOCSDIR%%/html/CommandGuide/lli.html
+%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
+%%DOCSDIR%%/html/CommandGuide/llvm-as.html
+%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
+%%DOCSDIR%%/html/CommandGuide/llvm-config.html
+%%DOCSDIR%%/html/CommandGuide/llvm-db.html
+%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
+%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
+%%DOCSDIR%%/html/CommandGuide/llvm-ld.html
+%%DOCSDIR%%/html/CommandGuide/llvm-link.html
+%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
+%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
+%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
+%%DOCSDIR%%/html/CommandGuide/llvmc.html
+%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
+%%DOCSDIR%%/html/CommandGuide/llvmgxx.html
+%%DOCSDIR%%/html/CommandGuide/manpage.css
+%%DOCSDIR%%/html/CommandGuide/opt.html
+%%DOCSDIR%%/html/CommandGuide/tblgen.html
+%%DOCSDIR%%/html/CommandLine.html
+%%DOCSDIR%%/html/CompilerDriver.html
+%%DOCSDIR%%/html/CompilerDriverTutorial.html
+%%DOCSDIR%%/html/CompilerWriterInfo.html
+%%DOCSDIR%%/html/DeveloperPolicy.html
+%%DOCSDIR%%/html/DriverInternals.html
+%%DOCSDIR%%/html/ExceptionHandling.html
+%%DOCSDIR%%/html/ExtendingLLVM.html
+%%DOCSDIR%%/html/FAQ.html
+%%DOCSDIR%%/html/GCCFEBuildInstrs.html
+%%DOCSDIR%%/html/GarbageCollection.html
+%%DOCSDIR%%/html/GetElementPtr.html
+%%DOCSDIR%%/html/GettingStarted.html
+%%DOCSDIR%%/html/GettingStartedVS.html
+%%DOCSDIR%%/html/GoldPlugin.html
+%%DOCSDIR%%/html/HowToReleaseLLVM.html
+%%DOCSDIR%%/html/HowToSubmitABug.html
+%%DOCSDIR%%/html/InternalsManual.html
+%%DOCSDIR%%/html/LangRef.html
+%%DOCSDIR%%/html/LanguageExtensions.html
+%%DOCSDIR%%/html/Lexicon.html
+%%DOCSDIR%%/html/LinkTimeOptimization.html
+%%DOCSDIR%%/html/MakefileGuide.html
+%%DOCSDIR%%/html/PTHInternals.html
+%%DOCSDIR%%/html/Passes.html
+%%DOCSDIR%%/html/ProgrammersManual.html
+%%DOCSDIR%%/html/Projects.html
+%%DOCSDIR%%/html/ReleaseNotes.html
+%%DOCSDIR%%/html/SourceLevelDebugging.html
+%%DOCSDIR%%/html/SystemLibrary.html
+%%DOCSDIR%%/html/TableGenFundamentals.html
+%%DOCSDIR%%/html/TestingGuide.html
+%%DOCSDIR%%/html/UsersManual.html
+%%DOCSDIR%%/html/UsingLibraries.html
+%%DOCSDIR%%/html/WritingAnLLVMBackend.html
+%%DOCSDIR%%/html/WritingAnLLVMPass.html
+%%DOCSDIR%%/html/clang/clang.html
+%%DOCSDIR%%/html/clang/manpage.css
+%%DOCSDIR%%/html/doxygen.css
+%%DOCSDIR%%/html/img/Debugging.gif
+%%DOCSDIR%%/html/img/libdeps.gif
+%%DOCSDIR%%/html/img/lines.gif
+%%DOCSDIR%%/html/img/objdeps.gif
+%%DOCSDIR%%/html/img/venusflytrap.jpg
+%%DOCSDIR%%/html/index.html
+%%DOCSDIR%%/html/llvm.css
+%%DOCSDIR%%/html/tutorial/JITTutorial1.html
+%%DOCSDIR%%/html/tutorial/JITTutorial2.html
+%%DOCSDIR%%/html/tutorial/LangImpl1.html
+%%DOCSDIR%%/html/tutorial/LangImpl2.html
+%%DOCSDIR%%/html/tutorial/LangImpl3.html
+%%DOCSDIR%%/html/tutorial/LangImpl4.html
+%%DOCSDIR%%/html/tutorial/LangImpl5.html
+%%DOCSDIR%%/html/tutorial/LangImpl6.html
+%%DOCSDIR%%/html/tutorial/LangImpl7.html
+%%DOCSDIR%%/html/tutorial/LangImpl8.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl1.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl2.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl3.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl4.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
+%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
+%%DOCSDIR%%/html/tutorial/index.html
+%%DOCSDIR%%/ps/bugpoint.ps
+%%DOCSDIR%%/ps/clang.ps
+%%DOCSDIR%%/ps/llc.ps
+%%DOCSDIR%%/ps/lli.ps
+%%DOCSDIR%%/ps/llvm-ar.ps
+%%DOCSDIR%%/ps/llvm-as.ps
+%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
+%%DOCSDIR%%/ps/llvm-config.ps
+%%DOCSDIR%%/ps/llvm-db.ps
+%%DOCSDIR%%/ps/llvm-dis.ps
+%%DOCSDIR%%/ps/llvm-extract.ps
+%%DOCSDIR%%/ps/llvm-ld.ps
+%%DOCSDIR%%/ps/llvm-link.ps
+%%DOCSDIR%%/ps/llvm-nm.ps
+%%DOCSDIR%%/ps/llvm-prof.ps
+%%DOCSDIR%%/ps/llvm-ranlib.ps
+%%DOCSDIR%%/ps/llvmc.ps
+%%DOCSDIR%%/ps/llvmgcc.ps
+%%DOCSDIR%%/ps/llvmgxx.ps
+%%DOCSDIR%%/ps/opt.ps
+%%DOCSDIR%%/ps/tblgen.ps
+@dirrm lib/clang/1.0/include
+@dirrm lib/clang/1.0
+@dirrm lib/clang
+@dirrm include/llvm/Transforms/Utils
+@dirrm include/llvm/Transforms/IPO
+@dirrm include/llvm/Transforms
+@dirrm include/llvm/Target
+@dirrm include/llvm/System
+@dirrm include/llvm/Support
+@dirrm include/llvm/ExecutionEngine
+@dirrm include/llvm/Debugger
+@dirrm include/llvm/Config
+@dirrm include/llvm/CompilerDriver
+@dirrm include/llvm/CodeGen
+@dirrm include/llvm/Bitcode
+@dirrm include/llvm/Assembly
+@dirrm include/llvm/Analysis
+@dirrm include/llvm/ADT
+@dirrm include/llvm-c/Transforms
+@dirrm include/llvm-c
+@dirrm include/llvm
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/ps
+@dirrm %%DOCSDIR%%/html/tutorial
+@dirrm %%DOCSDIR%%/html/img
+@dirrm %%DOCSDIR%%/html/clang
+@dirrm %%DOCSDIR%%/html/CommandGuide
+@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%