aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2010-10-08 14:00:32 +0000
committerBrooks Davis <brooks@FreeBSD.org>2010-10-08 14:00:32 +0000
commit83be75421039cd85a18a9c71bcab1c0e7a52ecba (patch)
tree166150fa1545ff5da77ffef996e97a92ee35740b /devel/llvm
parent5c5b2dc4b75b3f53a7ecffe57c0ae2ab6c4d9db1 (diff)
downloadports-83be75421039cd85a18a9c71bcab1c0e7a52ecba.tar.gz
ports-83be75421039cd85a18a9c71bcab1c0e7a52ecba.zip
Upgrade LLVM, Clang, and llvm-gcc to 2.8 release.
The Clang port has now been updated to avoid building LLVM twice.
Notes
Notes: svn path=/head/; revision=262619
Diffstat (limited to 'devel/llvm')
-rw-r--r--devel/llvm/Makefile16
-rw-r--r--devel/llvm/distinfo9
-rw-r--r--devel/llvm/pkg-plist58
3 files changed, 57 insertions, 26 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index 86cd9f070d22..3935c109024c 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= llvm
-PORTVERSION= 2.7
-PORTREVISION= 1
+PORTVERSION= 2.8
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
EXTRACT_SUFX= .tgz
@@ -49,7 +48,7 @@ DOCSRCDIR= docs
.if !defined(NOPORTDOCS)
MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
- llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 \
+ llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-diff.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 llvmc.1 llvmgcc.1 \
llvmgxx.1 opt.1 tblgen.1
@@ -100,13 +99,13 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/llvm* \
bin/opt \
bin/tblgen \
+ lib/libBugpointPasses.so \
lib/libCompilerDriver.a \
lib/libEnhancedDisassembly.so \
lib/libEnhancedDisassembly.a \
lib/libLTO.* \
lib/libLLVM* \
lib/libUnitTestMain.a \
- lib/libplugin_llvmc* \
lib/libprofile_rt.so
PLIST_DIR_LIST= include/llvm-c \
include/llvm
@@ -115,9 +114,12 @@ build-plist:
cd ${PREFIX} && \
(ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
${SORT} >> ${PLIST}
- ${FIND} ${DATADIR} ${DOCSDIR} -type f | \
- ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
- -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
+# ${FIND} ${DATADIR} ${DOCSDIR} -type f | \
+# ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+# -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
+ ${FIND} ${DOCSDIR} -type f | \
+ ${SED} -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | \
+ ${SORT} >> ${PLIST}
cd ${PREFIX} && \
${FIND} ${PLIST_DIR_LIST} -type d | \
${SORT} -r | ${SED} -e 's|^|@dirrm |' >> ${PLIST}
diff --git a/devel/llvm/distinfo b/devel/llvm/distinfo
index 2ed450d69cff..85b1de036148 100644
--- a/devel/llvm/distinfo
+++ b/devel/llvm/distinfo
@@ -1,6 +1,3 @@
-MD5 (llvm-2.7.tgz) = ac322661f20e7d6c810b1869f886ad9b
-SHA256 (llvm-2.7.tgz) = 99664bdc8503a306038166af33f28eb426d99e297575a59d74a1a0dcbddbbca5
-SIZE (llvm-2.7.tgz) = 8374297
-MD5 (clang-2.7.tgz) = b83260aa8c13494adf8978b5f238bf1b
-SHA256 (clang-2.7.tgz) = fb349471947f155c1cda1c8a4a3bbc7fa437b86f6875d9978f86c915dfed623a
-SIZE (clang-2.7.tgz) = 4953739
+MD5 (llvm-2.8.tgz) = 220d361b4d17051ff4bb21c64abe05ba
+SHA256 (llvm-2.8.tgz) = 25addb742f1c6cc12877ed0ee924dda962d848368ee095be8e48342ae613d43b
+SIZE (llvm-2.8.tgz) = 9112527
diff --git a/devel/llvm/pkg-plist b/devel/llvm/pkg-plist
index f65c8f1a8cd4..8e7c232f3bd2 100644
--- a/devel/llvm/pkg-plist
+++ b/devel/llvm/pkg-plist
@@ -5,10 +5,12 @@ bin/llvm-ar
bin/llvm-as
bin/llvm-bcanalyzer
bin/llvm-config
+bin/llvm-diff
bin/llvm-dis
bin/llvm-extract
bin/llvm-ld
bin/llvm-link
+bin/llvm-mc
bin/llvm-nm
bin/llvm-prof
bin/llvm-ranlib
@@ -31,6 +33,7 @@ include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
+include/llvm/ADT/DAGDeltaAlgorithm.h
include/llvm/ADT/DeltaAlgorithm.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DenseMapInfo.h
@@ -45,6 +48,8 @@ include/llvm/ADT/ImmutableMap.h
include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
+include/llvm/ADT/NullablePtr.h
+include/llvm/ADT/Optional.h
include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PointerIntPair.h
include/llvm/ADT/PointerUnion.h
@@ -81,6 +86,7 @@ include/llvm/Analysis/AliasSetTracker.h
include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/CaptureTracking.h
+include/llvm/Analysis/CodeMetrics.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
include/llvm/Analysis/DOTGraphTraitsPass.h
@@ -98,7 +104,9 @@ include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LazyValueInfo.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
+include/llvm/Analysis/Lint.h
include/llvm/Analysis/LiveValues.h
+include/llvm/Analysis/Loads.h
include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
@@ -111,15 +119,19 @@ include/llvm/Analysis/PostDominators.h
include/llvm/Analysis/ProfileInfo.h
include/llvm/Analysis/ProfileInfoLoader.h
include/llvm/Analysis/ProfileInfoTypes.h
+include/llvm/Analysis/RegionInfo.h
+include/llvm/Analysis/RegionIterator.h
+include/llvm/Analysis/RegionPrinter.h
include/llvm/Analysis/ScalarEvolution.h
include/llvm/Analysis/ScalarEvolutionExpander.h
include/llvm/Analysis/ScalarEvolutionExpressions.h
+include/llvm/Analysis/ScalarEvolutionNormalization.h
include/llvm/Analysis/SparsePropagation.h
include/llvm/Analysis/Trace.h
include/llvm/Analysis/ValueTracking.h
include/llvm/Analysis/Verifier.h
include/llvm/Argument.h
-include/llvm/Assembly/AsmAnnotationWriter.h
+include/llvm/Assembly/AssemblyAnnotationWriter.h
include/llvm/Assembly/Parser.h
include/llvm/Assembly/PrintModulePass.h
include/llvm/Assembly/Writer.h
@@ -135,17 +147,18 @@ include/llvm/Bitcode/ReaderWriter.h
include/llvm/CMakeLists.txt
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
+include/llvm/CodeGen/Analysis.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
-include/llvm/CodeGen/DwarfWriter.h
-include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FastISel.h
+include/llvm/CodeGen/FunctionLoweringInfo.h
include/llvm/CodeGen/GCMetadata.h
include/llvm/CodeGen/GCMetadataPrinter.h
include/llvm/CodeGen/GCStrategy.h
include/llvm/CodeGen/GCs.h
+include/llvm/CodeGen/ISDOpcodes.h
include/llvm/CodeGen/IntrinsicLowering.h
include/llvm/CodeGen/JITCodeEmitter.h
include/llvm/CodeGen/LatencyPriorityQueue.h
@@ -180,6 +193,7 @@ include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/MachineSSAUpdater.h
include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/Passes.h
+include/llvm/CodeGen/PostRAHazardRecognizer.h
include/llvm/CodeGen/ProcessImplicitDefs.h
include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocRegistry.h
@@ -197,14 +211,13 @@ include/llvm/CodeGen/TargetLoweringObjectFileImpl.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/CompilerDriver/Action.h
+include/llvm/CompilerDriver/AutoGenerated.h
include/llvm/CompilerDriver/BuiltinOptions.h
include/llvm/CompilerDriver/Common.td
include/llvm/CompilerDriver/CompilationGraph.h
include/llvm/CompilerDriver/Error.h
-include/llvm/CompilerDriver/ForceLinkage.h
-include/llvm/CompilerDriver/ForceLinkageMacros.h
+include/llvm/CompilerDriver/Main.h
include/llvm/CompilerDriver/Main.inc
-include/llvm/CompilerDriver/Plugin.h
include/llvm/CompilerDriver/Tool.h
include/llvm/Config/AsmParsers.def
include/llvm/Config/AsmPrinters.def
@@ -212,6 +225,8 @@ include/llvm/Config/Disassemblers.def
include/llvm/Config/Targets.def
include/llvm/Config/config.h
include/llvm/Config/config.h.cmake
+include/llvm/Config/llvm-config.h
+include/llvm/Config/llvm-config.h.cmake
include/llvm/Constant.h
include/llvm/Constants.h
include/llvm/DerivedTypes.h
@@ -245,30 +260,41 @@ include/llvm/LLVMContext.h
include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
+include/llvm/MC/EDInstInfo.h
+include/llvm/MC/ELFObjectWriter.h
include/llvm/MC/MCAsmInfo.h
include/llvm/MC/MCAsmInfoCOFF.h
include/llvm/MC/MCAsmInfoDarwin.h
+include/llvm/MC/MCAsmLayout.h
include/llvm/MC/MCAssembler.h
include/llvm/MC/MCCodeEmitter.h
include/llvm/MC/MCContext.h
include/llvm/MC/MCDirectives.h
include/llvm/MC/MCDisassembler.h
+include/llvm/MC/MCDwarf.h
+include/llvm/MC/MCELFSymbolFlags.h
include/llvm/MC/MCExpr.h
include/llvm/MC/MCFixup.h
include/llvm/MC/MCInst.h
include/llvm/MC/MCInstPrinter.h
+include/llvm/MC/MCLabel.h
+include/llvm/MC/MCMachOSymbolFlags.h
+include/llvm/MC/MCObjectStreamer.h
+include/llvm/MC/MCObjectWriter.h
include/llvm/MC/MCParser/AsmCond.h
include/llvm/MC/MCParser/AsmLexer.h
-include/llvm/MC/MCParser/AsmParser.h
include/llvm/MC/MCParser/MCAsmLexer.h
include/llvm/MC/MCParser/MCAsmParser.h
+include/llvm/MC/MCParser/MCAsmParserExtension.h
include/llvm/MC/MCParser/MCParsedAsmOperand.h
include/llvm/MC/MCSection.h
+include/llvm/MC/MCSectionCOFF.h
include/llvm/MC/MCSectionELF.h
include/llvm/MC/MCSectionMachO.h
include/llvm/MC/MCStreamer.h
include/llvm/MC/MCSymbol.h
include/llvm/MC/MCValue.h
+include/llvm/MC/MachObjectWriter.h
include/llvm/MC/SectionKind.h
include/llvm/Metadata.h
include/llvm/Module.h
@@ -278,16 +304,19 @@ include/llvm/Pass.h
include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassManagers.h
+include/llvm/PassRegistry.h
include/llvm/PassSupport.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
include/llvm/Support/CFG.h
+include/llvm/Support/COFF.h
include/llvm/Support/CallSite.h
include/llvm/Support/Casting.h
include/llvm/Support/CommandLine.h
include/llvm/Support/Compiler.h
include/llvm/Support/ConstantFolder.h
include/llvm/Support/ConstantRange.h
+include/llvm/Support/CrashRecoveryContext.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataFlow.h
include/llvm/Support/Debug.h
@@ -326,7 +355,6 @@ include/llvm/Support/Regex.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
include/llvm/Support/SMLoc.h
-include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/SourceMgr.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/StandardPasses.h
@@ -363,12 +391,14 @@ include/llvm/System/Solaris.h
include/llvm/System/ThreadLocal.h
include/llvm/System/Threading.h
include/llvm/System/TimeValue.h
+include/llvm/System/Valgrind.h
include/llvm/Target/Mangler.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
include/llvm/Target/TargetAsmBackend.h
include/llvm/Target/TargetAsmLexer.h
include/llvm/Target/TargetAsmParser.h
+include/llvm/Target/TargetCallingConv.h
include/llvm/Target/TargetCallingConv.td
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
@@ -388,6 +418,7 @@ include/llvm/Target/TargetRegistry.h
include/llvm/Target/TargetSchedule.td
include/llvm/Target/TargetSelect.h
include/llvm/Target/TargetSelectionDAG.td
+include/llvm/Target/TargetSelectionDAGInfo.h
include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/IPO/InlinerPass.h
@@ -403,7 +434,7 @@ include/llvm/Transforms/Utils/FunctionUtils.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/SSAUpdater.h
-include/llvm/Transforms/Utils/SSI.h
+include/llvm/Transforms/Utils/SSAUpdaterImpl.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
@@ -413,12 +444,14 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
+lib/libBugpointPasses.so
lib/libCompilerDriver.a
lib/libEnhancedDisassembly.a
lib/libEnhancedDisassembly.so
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
+lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
lib/libLLVMAlphaAsmPrinter.a
lib/libLLVMAlphaCodeGen.a
@@ -452,9 +485,8 @@ lib/libLLVMMBlazeAsmPrinter.a
lib/libLLVMMBlazeCodeGen.a
lib/libLLVMMBlazeInfo.a
lib/libLLVMMC.a
+lib/libLLVMMCDisassembler.a
lib/libLLVMMCParser.a
-lib/libLLVMMSIL.a
-lib/libLLVMMSILInfo.a
lib/libLLVMMSP430AsmPrinter.a
lib/libLLVMMSP430CodeGen.a
lib/libLLVMMSP430Info.a
@@ -493,8 +525,6 @@ lib/libLLVMpic16passes.a
lib/libLTO.a
lib/libLTO.so
lib/libUnitTestMain.a
-lib/libplugin_llvmc_Base.a
-lib/libplugin_llvmc_Clang.a
lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.html
@@ -514,6 +544,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-as.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-config.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-diff.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ld.html
@@ -593,6 +624,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-as.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-config.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-diff.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-dis.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-extract.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ld.ps