aboutsummaryrefslogtreecommitdiff
path: root/devel/love07
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-12 15:01:45 +0000
commitdaffe00d4a57c0ef6a21947a8121b8d233d8d3a5 (patch)
tree713942325bda393305edb21d46cd7f38d213aebc /devel/love07
parent51498efaebaad1106dcf0d3f70c8feaa14c411ee (diff)
downloadports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.tar.gz
ports-daffe00d4a57c0ef6a21947a8121b8d233d8d3a5.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful - Canonicalize patch names - Fix DOS line endings in patch files
Notes
Notes: svn path=/head/; revision=322840
Diffstat (limited to 'devel/love07')
-rw-r--r--devel/love07/Makefile13
-rw-r--r--devel/love07/files/patch-src-modules-graphics-opengl-GLee.h16
2 files changed, 15 insertions, 14 deletions
diff --git a/devel/love07/Makefile b/devel/love07/Makefile
index 2d77f1bbeff2..c6c0f115baa0 100644
--- a/devel/love07/Makefile
+++ b/devel/love07/Makefile
@@ -12,12 +12,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-linux-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
-LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
- modplug.1:${PORTSDIR}/audio/libmodplug \
- mpg123.0:${PORTSDIR}/audio/mpg123 \
- vorbisfile.6:${PORTSDIR}/audio/libvorbis \
- physfs.1:${PORTSDIR}/devel/physfs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= IL:${PORTSDIR}/graphics/devil \
+ modplug:${PORTSDIR}/audio/libmodplug \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ vorbisfile:${PORTSDIR}/audio/libvorbis \
+ physfs:${PORTSDIR}/devel/physfs \
+ freetype:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LATEST_LINK= ${PORTNAME}07
@@ -36,6 +36,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
--program-suffix=07
WRKSRC= ${WRKDIR}/love-HEAD
+USE_DOS2UNIX= yes
PLIST_FILES= bin/love07
diff --git a/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h b/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h
index ee29f8c1c064..fb28b6582ebe 100644
--- a/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h
+++ b/devel/love07/files/patch-src-modules-graphics-opengl-GLee.h
@@ -1,11 +1,11 @@
--- src/modules/graphics/opengl/GLee.h.orig 2011-05-04 20:00:10.000000000 +0400
+++ src/modules/graphics/opengl/GLee.h 2011-09-20 00:16:46.000000000 +0400
@@ -799,8 +799,6 @@
-
- /* GLX */
-
-- typedef void (*__GLXextFuncPtr)(void);
--
- #ifndef GLX_ARB_get_proc_address
- #define GLX_ARB_get_proc_address 1
- extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);
+
+ /* GLX */
+
+- typedef void (*__GLXextFuncPtr)(void);
+-
+ #ifndef GLX_ARB_get_proc_address
+ #define GLX_ARB_get_proc_address 1
+ extern __GLXextFuncPtr glXGetProcAddressARB (const GLubyte *);