aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-alien/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 09:45:36 +0000
commit4a4ec28d37b64039d4eff0f34ad66b543767d758 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /devel/lua-alien/Makefile
parenta5d24d4bb4a43375b4bbb7f8bc673f8c557f06b4 (diff)
downloadports-4a4ec28d37b64039d4eff0f34ad66b543767d758.tar.gz
ports-4a4ec28d37b64039d4eff0f34ad66b543767d758.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Notes
Notes: svn path=/head/; revision=352986
Diffstat (limited to 'devel/lua-alien/Makefile')
-rw-r--r--devel/lua-alien/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/lua-alien/Makefile b/devel/lua-alien/Makefile
index b5f71290b97a..2ba734803a59 100644
--- a/devel/lua-alien/Makefile
+++ b/devel/lua-alien/Makefile
@@ -36,8 +36,8 @@ CFLAGS+= -fno-stack-protector
# add lua prefix to directories
.for p in data: docs:doc/ examples:examples/
-${p:C/:.*//:U}DIR_REL= share/${p:C/.*://}${LUA_PKGNAMEPREFIX}${PORTNAME}
-${p:C/:.*//:U}DIR= ${PREFIX}/${${p:C/:.*//:U}DIR_REL}
+${p:C/:.*//:tu}DIR_REL= share/${p:C/.*://}${LUA_PKGNAMEPREFIX}${PORTNAME}
+${p:C/:.*//:tu}DIR= ${PREFIX}/${${p:C/:.*//:tu}DIR_REL}
.endfor
OPTIONS_DEFINE= DOCS EXAMPLES