aboutsummaryrefslogtreecommitdiff
path: root/devel/lua50-pty
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-04-17 16:21:41 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-04-17 16:21:41 +0000
commitd4e1e5b071eabc70ad6d7707136c39154d7ce6a8 (patch)
tree4e1a8c92ac4df2c6006496f7c25a8723578caf09 /devel/lua50-pty
parentb70c80936aa967000d1a1a4ecf0176279de12c4a (diff)
downloadports-d4e1e5b071eabc70ad6d7707136c39154d7ce6a8.tar.gz
ports-d4e1e5b071eabc70ad6d7707136c39154d7ce6a8.zip
Add lua50-pty 1.25, pty (pseudo-terminal) bindings for Lua 5.0.x.
PR: ports/95914 Submitted by: Andrew Turner <andrew+ports -at- fubar.geek.nz>
Notes
Notes: svn path=/head/; revision=159806
Diffstat (limited to 'devel/lua50-pty')
-rw-r--r--devel/lua50-pty/Makefile40
-rw-r--r--devel/lua50-pty/distinfo6
-rw-r--r--devel/lua50-pty/files/Makefile11
-rw-r--r--devel/lua50-pty/pkg-descr1
-rw-r--r--devel/lua50-pty/pkg-plist6
5 files changed, 64 insertions, 0 deletions
diff --git a/devel/lua50-pty/Makefile b/devel/lua50-pty/Makefile
new file mode 100644
index 000000000000..fa29708e8764
--- /dev/null
+++ b/devel/lua50-pty/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lua50-pty
+# Date created: 17 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lua50-pty
+PORTVERSION= 1.25
+CATEGORIES= devel
+MASTER_SITES= http://cvs.bsdinstaller.org/cgi-bin/cvsweb.cgi/installer/src/lib/lua/pty/
+DISTFILES= pty.lua?rev=1.2 pty.c?rev=1.25
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= Pty (pseudo-terminal) bindings for Lua 5.0.x
+
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+ ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:extract
+RUN_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua \
+ ${LOCALBASE}/share/lua/5.0/compat-5.1.lua:${PORTSDIR}/devel/lua50-compat51
+
+LIBDIR= ${PREFIX}/lib/lua/5.0
+COMPAT_SRC= `(cd ${PORTSDIR}/devel/lua50-compat51 && make -V WRKSRC)`
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+.for file in ${DISTFILES}
+ @${CP} ${DISTDIR}/${file} ${WRKSRC}/${file:C/\?.*$//}
+.endfor
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%COMPATDIR%%|${COMPAT_SRC}|" ${WRKSRC}/Makefile
+
+pre-install:
+ ${MKDIR} ${LIBDIR}
+ ${MKDIR} ${PREFIX}/share/lua/5.0
+ ${INSTALL_DATA} ${WRKSRC}/pty.lua ${PREFIX}/share/lua/5.0
+
+.include <bsd.port.mk>
diff --git a/devel/lua50-pty/distinfo b/devel/lua50-pty/distinfo
new file mode 100644
index 000000000000..0650f2bdb2ca
--- /dev/null
+++ b/devel/lua50-pty/distinfo
@@ -0,0 +1,6 @@
+MD5 (pty.lua?rev=1.2) = a28e98428f2feabda7465006939eacea
+SHA256 (pty.lua?rev=1.2) = 18f1a623b727a3172b6e16142c057659a76614741a65533a9747034886edcb9a
+SIZE (pty.lua?rev=1.2) = 1077
+MD5 (pty.c?rev=1.25) = ec00d34a5f613b9c55a66345dd6c390d
+SHA256 (pty.c?rev=1.25) = f8ce982883ba917abeab623ca63e07aafb05d2820fe35e5d8563caf579240af1
+SIZE (pty.c?rev=1.25) = 9264
diff --git a/devel/lua50-pty/files/Makefile b/devel/lua50-pty/files/Makefile
new file mode 100644
index 000000000000..94dc3de72bd7
--- /dev/null
+++ b/devel/lua50-pty/files/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+SHLIB= pty
+SHLIB_NAME= lpty.so
+
+SRCS= pty.c %%COMPATDIR%%/compat-5.1.c
+
+CFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -lutil
+
+.include <bsd.lib.mk>
diff --git a/devel/lua50-pty/pkg-descr b/devel/lua50-pty/pkg-descr
new file mode 100644
index 000000000000..d627c7d65c7d
--- /dev/null
+++ b/devel/lua50-pty/pkg-descr
@@ -0,0 +1 @@
+Lua 5.0.x bindings for ptys (pseudo-terminals.)
diff --git a/devel/lua50-pty/pkg-plist b/devel/lua50-pty/pkg-plist
new file mode 100644
index 000000000000..cae43e404215
--- /dev/null
+++ b/devel/lua50-pty/pkg-plist
@@ -0,0 +1,6 @@
+lib/lua/5.0/lpty.so
+share/lua/5.0/pty.lua
+@dirrmtry lib/lua/5.0
+@dirrmtry lib/lua
+@dirrmtry share/lua/5.0
+@dirrmtry share/lua