aboutsummaryrefslogtreecommitdiff
path: root/devel/mime
diff options
context:
space:
mode:
authorJohn-Mark Gurney <jmg@FreeBSD.org>2000-06-19 23:33:44 +0000
committerJohn-Mark Gurney <jmg@FreeBSD.org>2000-06-19 23:33:44 +0000
commit995c4e7f0c02378a3247cf7d8d067caf0dc4d033 (patch)
tree93fe450025b57639d3419c6250a191256947c350 /devel/mime
parent84af95cb8a8f466bc23d0bb917da9dc4a66e84c8 (diff)
downloadports-995c4e7f0c02378a3247cf7d8d067caf0dc4d033.tar.gz
ports-995c4e7f0c02378a3247cf7d8d067caf0dc4d033.zip
add a C library for mime/rfc822 parsing:
This package allows you to decode multipart mime messages. I wrote this so that my cgiparse libary can understand multipart/form-data. I was looking at the various ways of doing it with out designing an entire library. After thinking about the problem, there were to many edge cases, and designing an entire library would be better. This is the results of the work. It definately could use some cleaning up. WWW: http://resnet.uoregon.edu/~gurney_j/jmpc/mime.html
Notes
Notes: svn path=/head/; revision=29692
Diffstat (limited to 'devel/mime')
-rw-r--r--devel/mime/Makefile20
-rw-r--r--devel/mime/distinfo1
-rw-r--r--devel/mime/pkg-comment1
-rw-r--r--devel/mime/pkg-descr8
-rw-r--r--devel/mime/pkg-plist9
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/mime/Makefile b/devel/mime/Makefile
new file mode 100644
index 000000000000..571e8bb32563
--- /dev/null
+++ b/devel/mime/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: mime
+# Date created: 3 June 2000
+# Whom: jmg
+#
+# $FreeBSD$
+#
+
+PORTNAME= mime
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://resnet.uoregon.edu/~gurney_j/jmpc/dist/
+
+MAINTAINER= jmg@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+post-install:
+ @${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/mime/distinfo b/devel/mime/distinfo
new file mode 100644
index 000000000000..5c449bb8c012
--- /dev/null
+++ b/devel/mime/distinfo
@@ -0,0 +1 @@
+MD5 (mime-1.0.tar.gz) = bbc31b2f766f9e74223e4fdf783b77b8
diff --git a/devel/mime/pkg-comment b/devel/mime/pkg-comment
new file mode 100644
index 000000000000..5cfb289ff7bf
--- /dev/null
+++ b/devel/mime/pkg-comment
@@ -0,0 +1 @@
+C library to parse mime data
diff --git a/devel/mime/pkg-descr b/devel/mime/pkg-descr
new file mode 100644
index 000000000000..6acb219ce388
--- /dev/null
+++ b/devel/mime/pkg-descr
@@ -0,0 +1,8 @@
+This package allows you to decode multipart mime messages. I wrote
+this so that my cgiparse libary can understand multipart/form-data.
+I was looking at the various ways of doing it with out designing an
+entire library. After thinking about the problem, there were to many
+edge cases, and designing an entire library would be better. This is
+the results of the work. It definately could use some cleaning up.
+
+WWW: http://resnet.uoregon.edu/~gurney_j/jmpc/mime.html
diff --git a/devel/mime/pkg-plist b/devel/mime/pkg-plist
new file mode 100644
index 000000000000..e4d30c8d753c
--- /dev/null
+++ b/devel/mime/pkg-plist
@@ -0,0 +1,9 @@
+include/ct.h
+include/mime.h
+include/mimemisc.h
+lib/libmime.a
+lib/libmime.so
+lib/libmime.so.1
+lib/libmime_p.a
+@unexec /usr/bin/env /sbin/ldconfig -R
+@exec /usr/bin/env /sbin/ldconfig -m %B