aboutsummaryrefslogtreecommitdiff
path: root/devel/mm-common
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /devel/mm-common
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Presenting GNOME 2.28.1 for FreeBSD. The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ . Officially, this is mostly a polishing release in preparation for GNOME 3.0 due in about a year. On the FreeBSD front, though, a lot went into this release. Major thanks goes to kwm and avl who did a lot of the porting work for this release. In particular, kwm brought in Evolution MAPI support for better Microsoft Exchange integration. Avl made sure that the new gobject introspection repository ports were nicely compartmentalized so that large dependencies aren't brought in wholesale. But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself) contributed to this release. Other major improvements include an updated HAL with better volume probing code, ufsid integration, and support for volume names containing spaces (big thanks to J.R. Oldroyd); a new WebKit; updated AbiWord; an updated Gimp; and a preview of the new GNOME Shell project (thanks to Pawel Worach). The FreeBSD GNOME Team would like to that the following additional contributors to this release whose patches and testing really helped make it a success: Andrius Morkunas Dominique Goncalves Eric L. Chen J.R. Oldroyd Joseph S. Atkinson Li Pawel Worach Romain Tartière Thomas Vogt Yasuda Keisuke Rui Paulo Martin Wilke (and an extra shout out to miwi and pav for pointyhat runs) We would like to send this release out to Alexander Loginov (avl) in hopes that he feels better soon. PR: 136676 136967 138872 (obsolete with new epiphany-webkit) 139160 134737 139941 140097 140838 140929
Notes
Notes: svn path=/head/; revision=244923
Diffstat (limited to 'devel/mm-common')
-rw-r--r--devel/mm-common/Makefile26
-rw-r--r--devel/mm-common/distinfo3
-rw-r--r--devel/mm-common/pkg-descr14
-rw-r--r--devel/mm-common/pkg-plist77
4 files changed, 120 insertions, 0 deletions
diff --git a/devel/mm-common/Makefile b/devel/mm-common/Makefile
new file mode 100644
index 000000000000..f0a1f4f15d88
--- /dev/null
+++ b/devel/mm-common/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mm-common
+# Date Created: 27 Aug 2009
+# Whom: Koop Mast<kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/devel/mm-common/Makefile,v 1.6 2009/09/21 18:58:15 kwm Exp $
+#
+
+PORTNAME= mm-common
+PORTVERSION= 0.8
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Common build infrastructure for the GNOME C++ binding libraries
+
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
+
+USE_GNOME= gnomehack
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN1= mm-common-prepare.1
+
+.include <bsd.port.mk>
diff --git a/devel/mm-common/distinfo b/devel/mm-common/distinfo
new file mode 100644
index 000000000000..5d13a0e23209
--- /dev/null
+++ b/devel/mm-common/distinfo
@@ -0,0 +1,3 @@
+MD5 (mm-common-0.8.tar.bz2) = 2a335530f02c35dec1deea4b3627b725
+SHA256 (mm-common-0.8.tar.bz2) = 604c9b94629a4300e399ba72b497bedf1bf3c92b33ab8e688c32f70afe38e3c8
+SIZE (mm-common-0.8.tar.bz2) = 529592
diff --git a/devel/mm-common/pkg-descr b/devel/mm-common/pkg-descr
new file mode 100644
index 000000000000..ec53b63e0baa
--- /dev/null
+++ b/devel/mm-common/pkg-descr
@@ -0,0 +1,14 @@
+This module is part of the GNOME C++ bindings effort <http://www.gtkmm.org/>.
+
+The mm-common module provides the build infrastructure and utilities
+shared among the GNOME C++ binding libraries. It is only a required
+dependency for building the C++ bindings from the gnome.org version
+control repository. An installation of mm-common is not required for
+building tarball releases, unless configured to use maintainer-mode.
+
+Release archives of mm-common include the Doxygen tag file for the
+GNU C++ Library reference documentation. It is covered by the same
+licence as the source code it was extracted from. More information
+is available at <http://gcc.gnu.org/onlinedocs/libstdc++/>.
+
+WWW: http://www.gtkmm.org
diff --git a/devel/mm-common/pkg-plist b/devel/mm-common/pkg-plist
new file mode 100644
index 000000000000..b5ea4637b363
--- /dev/null
+++ b/devel/mm-common/pkg-plist
@@ -0,0 +1,77 @@
+bin/mm-common-prepare
+share/aclocal/mm-common.m4
+share/aclocal/mm-dietlib.m4
+share/aclocal/mm-doc.m4
+share/aclocal/mm-module.m4
+share/aclocal/mm-pkg.m4
+share/aclocal/mm-warnings.m4
+share/doc/mm-common/README
+share/doc/mm-common/skeletonmm/.gitignore
+share/doc/mm-common/skeletonmm/AUTHORS
+share/doc/mm-common/skeletonmm/COPYING
+share/doc/mm-common/skeletonmm/ChangeLog
+share/doc/mm-common/skeletonmm/Makefile.am
+share/doc/mm-common/skeletonmm/README
+share/doc/mm-common/skeletonmm/autogen.sh
+share/doc/mm-common/skeletonmm/build/.gitignore
+share/doc/mm-common/skeletonmm/codegen/Makefile.am
+share/doc/mm-common/skeletonmm/codegen/extradefs/generate_extra_defs_skeleton.cc
+share/doc/mm-common/skeletonmm/codegen/m4/convert.m4
+share/doc/mm-common/skeletonmm/codegen/m4/convert_skeleton.m4
+share/doc/mm-common/skeletonmm/codegen/m4/filelist.am
+share/doc/mm-common/skeletonmm/configure.ac
+share/doc/mm-common/skeletonmm/doc/Makefile.am
+share/doc/mm-common/skeletonmm/doc/reference/.gitignore
+share/doc/mm-common/skeletonmm/doc/reference/Doxyfile.in
+share/doc/mm-common/skeletonmm/examples/.gitignore
+share/doc/mm-common/skeletonmm/examples/Makefile.am
+share/doc/mm-common/skeletonmm/examples/example/example.cc
+share/doc/mm-common/skeletonmm/skeleton/.gitignore
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm-uninstalled.pc.in
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm.h
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm.pc.in
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm/Makefile.am
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm/filelist.am
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm/private/.gitignore
+share/doc/mm-common/skeletonmm/skeleton/skeletonmm/wrap_init.h
+share/doc/mm-common/skeletonmm/skeleton/skeletonmmconfig.h.in
+share/doc/mm-common/skeletonmm/skeleton/src/Makefile.am
+share/doc/mm-common/skeletonmm/skeleton/src/filelist.am
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton.ccg
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton.defs
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton.hg
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton_docs.xml
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton_docs_override.xml
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton_enum.defs
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton_extra.defs
+share/doc/mm-common/skeletonmm/skeleton/src/skeleton_method.defs
+share/doc/mm-common/skeletonmm/skeletonmm.doap
+share/mm-common/build/compile-binding.am
+share/mm-common/build/dist-changelog.am
+share/mm-common/build/doc-reference.am
+share/mm-common/build/generate-binding.am
+share/mm-common/doctags/libstdc++.tag
+share/mm-common/doctool/doc-install.pl
+share/mm-common/doctool/doc-postprocess.pl
+share/mm-common/doctool/doxygen.css
+share/mm-common/doctool/tagfile-to-devhelp2.xsl
+libdata/pkgconfig/mm-common-libstdc++.pc
+@dirrm share/mm-common/doctool
+@dirrm share/mm-common/doctags
+@dirrm share/mm-common/build
+@dirrm share/mm-common
+@dirrm share/doc/mm-common/skeletonmm/skeleton/src
+@dirrm share/doc/mm-common/skeletonmm/skeleton/skeletonmm/private
+@dirrm share/doc/mm-common/skeletonmm/skeleton/skeletonmm
+@dirrm share/doc/mm-common/skeletonmm/skeleton
+@dirrm share/doc/mm-common/skeletonmm/doc/reference
+@dirrm share/doc/mm-common/skeletonmm/doc
+@dirrm share/doc/mm-common/skeletonmm/examples/example
+@dirrm share/doc/mm-common/skeletonmm/examples
+@dirrm share/doc/mm-common/skeletonmm/build
+@dirrm share/doc/mm-common/skeletonmm/codegen/m4
+@dirrm share/doc/mm-common/skeletonmm/codegen/extradefs
+@dirrm share/doc/mm-common/skeletonmm/codegen
+@dirrm share/doc/mm-common/skeletonmm
+@dirrm share/doc/mm-common
+@dirrmtry share/aclocal