aboutsummaryrefslogtreecommitdiff
path: root/devel/ncurses
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-05 04:16:38 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-05 04:16:38 +0000
commit2f6310c437afb701d831df988865b394285388f5 (patch)
tree8d65c3d9a735226e7f8b8d11557e1df58113d758 /devel/ncurses
parent77416a734f1c2b2d76d8bd28d77797cdac06f8bd (diff)
downloadports-2f6310c437afb701d831df988865b394285388f5.tar.gz
ports-2f6310c437afb701d831df988865b394285388f5.zip
- Enable terminfo again, can be turned off via WITHOUT_TERMINFO [1]
- Partially address bin/71801 - terminfo and termcap are both enabled by default - Additional terminfo should be installed as share/misc/*.terminfo When installing/upgrading ncurses port, these *.terminfo will be taken care automatically. [2] - Remove safe-sprintf, we have vsprintf(3) and vsnprintf(3) - Fix problem on amd64 with ncursesw - Remove our own rpath stuffs, use --enable-rpath instead. - I think we can safely package it now. So, remove MANUAL_PACKAGE_BUILD. Let me know if this causes problem. - Profiling and debug libraries can be built conditionally - By default, profiling libraries is built Thanks to: thierry and Thomas Dickey [1] Submitted by: thierry [2]
Notes
Notes: svn path=/head/; revision=181466
Diffstat (limited to 'devel/ncurses')
-rw-r--r--devel/ncurses/Makefile59
-rw-r--r--devel/ncurses/pkg-plist44
2 files changed, 77 insertions, 26 deletions
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index 676113717eb3..5082fe9a99d5 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ncurses
PORTVERSION= 5.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,12 +18,12 @@ COMMENT= Library for terminal-independent, full-screen output
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT=../configure
CONFIGURE_ARGS= --datadir=${TARGETDIR}/share/misc --disable-overwrite \
- --enable-termcap --disable-database --enable-getcap \
- --enable-colorfgbg --enable-bsdpad --disable-home-terminfo \
+ --enable-termcap --enable-bsdpad --enable-getcap \
+ --enable-colorfgbg --disable-home-terminfo \
--includedir=${TARGETDIR}/include/ncurses \
- --with-profile --with-shared --without-debug \
+ --with-shared \
--without-curses-h --with-termlib --program-prefix= \
- --enable-safe-sprintf --disable-root-environ \
+ --enable-rpath --disable-root-environ \
--with-manpage-format=gzip --srcdir=../
# needed by devel/py-ncurses port
@@ -30,11 +31,7 @@ CONFIGURE_ARGS= --datadir=${TARGETDIR}/share/misc --disable-overwrite \
CONFIGURE_ARGS+= --with-trace
.endif
-LDFLAGS+= -rpath ${TARGETDIR}/lib
-
-CONFIGURE_ENV= gnat_exists="no" \
- ac_cv_path_LDCONFIG="${LDCONFIG} -m ${TARGETDIR}/lib" \
- LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= gnat_exists="no"
USE_LDCONFIG= yes
NO_FILTER_SHLIBS=yes
@@ -81,22 +78,52 @@ EXAMPLES_CPP= Makefile NEWS PROBLEMS README-first cursesapp.cc \
MAN3!= ${CAT} ${FILESDIR}/man3
-.if ${OSVERSION} >= 400000
-MANUAL_PACKAGE_BUILD= conflicts with system ncurses
+.if ${OSVERSION} < 500000
+BROKEN= does not compile
.endif
.if ${OSVERSION} < 503000
WITHOUT_WIDEC= yes
-PLIST_SUB+= WIDEC="@comment "
+.endif
+
+.if !defined(WITHOUT_PROFILE) && !defined(NO_PROFILE) && !defined(NOPROFILE)
+CONFIGURE_ARGS+=--with-profile
+PLIST_SUB+= PROFILE=""
.else
+CONFIGURE_ARGS+=--without-profile
+PLIST_SUB+= PROFILE="@comment "
+.endif
+
+.if !defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--without-debug
+PLIST_SUB+= DEBUG="@comment "
+.else
+CONFIGURE_ARGS+=--with-debug
+PLIST_SUB+= DEBUG=""
+.endif
+
+.if !defined(WITHOUT_TERMINFO)
+CONFIGURE_ARGS+=--with-hashed-db
+PLIST_SUB+= TERMINFO=""
+.else # termcap only, easier for updating ncurses in base
+CONFIGURE_ARGS+=--disable-database
+PLIST_SUB+= TERMINFO="@comment "
+.endif
+
+.if !defined(WITHOUT_WIDEC)
PLIST_SUB+= WIDEC=""
EXAMPLES_TARGETS+= WIDEC
+.else
+PLIST_SUB+= WIDEC="@comment "
.endif
post-extract:
@${MKDIR} ${WIDEC_WRKSRC}
@${MKDIR} ${NOWIDEC_WRKSRC}
+post-patch:
+ @${REINPLACE_CMD} -e 's,$$(INSTALL_PROG) ncurses-config,@INSTALL_SCRIPT@ ncurses-config,' ${WRKSRC}/misc/Makefile.in
+
post-configure:
.if !defined(WITHOUT_WIDEC)
${MAKE} CONFIGURE_WRKSRC=${WIDEC_WRKSRC} \
@@ -120,9 +147,6 @@ post-install:
${MAKE} INSTALL_WRKSRC=${WIDEC_WRKSRC} do-install
.endif
- ${INSTALL_DATA} ${WRKSRC}/misc/terminfo.src \
- ${TARGETDIR}/share/misc/terminfo
-
.for i in ${EXAMPLES_TARGETS}
${MKDIR} ${${i}_EXAMPLESDIR}/c++
.for f in ${EXAMPLES}
@@ -134,6 +158,11 @@ post-install:
.endfor
.endfor
+.if !defined(WITHOUT_TERMINFO)
+ ${FIND} ${PREFIX}/share/misc -name "*.terminfo" -print0 | \
+ ${XARGS} -0 ${PREFIX}/bin/tic
+.endif
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
. for f in ${DOCS}
diff --git a/devel/ncurses/pkg-plist b/devel/ncurses/pkg-plist
index da83bad09b7f..9eb7427159b2 100644
--- a/devel/ncurses/pkg-plist
+++ b/devel/ncurses/pkg-plist
@@ -4,6 +4,12 @@ bin/reset
bin/tack
bin/tput
bin/tset
+%%TERMINFO%%bin/tic
+%%TERMINFO%%bin/toe
+%%TERMINFO%%bin/infotocap
+%%TERMINFO%%bin/captoinfo
+%%TERMINFO%%bin/ncurses5-config
+%%WIDEC%%%%TERMINFO%%bin/ncursesw5-config
include/ncurses/cursesapp.h
include/ncurses/cursesf.h
include/ncurses/cursesm.h
@@ -24,55 +30,69 @@ lib/libform.a
lib/libform.so
lib/libform.so.5
lib/libform.so.%%PORTVERSION%%
-lib/libform_p.a
+%%DEBUG%%lib/libform_g.a
+%%PROFILE%%lib/libform_p.a
lib/libmenu.a
lib/libmenu.so
lib/libmenu.so.5
lib/libmenu.so.%%PORTVERSION%%
-lib/libmenu_p.a
+%%DEBUG%%lib/libmenu_g.a
+%%PROFILE%%lib/libmenu_p.a
lib/libncurses++.a
lib/libncurses.a
lib/libncurses.so
lib/libncurses.so.5
lib/libncurses.so.%%PORTVERSION%%
-lib/libncurses_p.a
+%%DEBUG%%lib/libncurses_g.a
+%%PROFILE%%lib/libncurses_p.a
lib/libpanel.a
lib/libpanel.so
lib/libpanel.so.5
lib/libpanel.so.%%PORTVERSION%%
-lib/libpanel_p.a
+%%DEBUG%%lib/libpanel_g.a
+%%PROFILE%%lib/libpanel_p.a
lib/libtinfo.a
lib/libtinfo.so
lib/libtinfo.so.5
lib/libtinfo.so.%%PORTVERSION%%
-lib/libtinfo_p.a
+%%DEBUG%%lib/libtinfo_g.a
+%%PROFILE%%lib/libtinfo_p.a
%%WIDEC%%lib/libformw.a
%%WIDEC%%lib/libformw.so
%%WIDEC%%lib/libformw.so.5
%%WIDEC%%lib/libformw.so.%%PORTVERSION%%
-%%WIDEC%%lib/libformw_p.a
+%%WIDEC%%%%DEBUG%%lib/libformw_g.a
+%%WIDEC%%%%PROFILE%%lib/libformw_p.a
%%WIDEC%%lib/libmenuw.a
%%WIDEC%%lib/libmenuw.so
%%WIDEC%%lib/libmenuw.so.5
%%WIDEC%%lib/libmenuw.so.%%PORTVERSION%%
-%%WIDEC%%lib/libmenuw_p.a
+%%WIDEC%%%%DEBUG%%lib/libmenuw_g.a
+%%WIDEC%%%%PROFILE%%lib/libmenuw_p.a
%%WIDEC%%lib/libncurses++w.a
%%WIDEC%%lib/libncursesw.a
%%WIDEC%%lib/libncursesw.so
%%WIDEC%%lib/libncursesw.so.5
%%WIDEC%%lib/libncursesw.so.%%PORTVERSION%%
-%%WIDEC%%lib/libncursesw_p.a
+%%WIDEC%%%%DEBUG%%lib/libncursesw_g.a
+%%WIDEC%%%%PROFILE%%lib/libncursesw_p.a
%%WIDEC%%lib/libpanelw.a
%%WIDEC%%lib/libpanelw.so
%%WIDEC%%lib/libpanelw.so.5
%%WIDEC%%lib/libpanelw.so.%%PORTVERSION%%
-%%WIDEC%%lib/libpanelw_p.a
+%%WIDEC%%%%DEBUG%%lib/libpanelw_g.a
+%%WIDEC%%%%PROFILE%%lib/libpanelw_p.a
%%WIDEC%%lib/libtinfow.a
%%WIDEC%%lib/libtinfow.so
%%WIDEC%%lib/libtinfow.so.5
%%WIDEC%%lib/libtinfow.so.%%PORTVERSION%%
-%%WIDEC%%lib/libtinfow_p.a
-share/misc/terminfo
+%%WIDEC%%%%DEBUG%%lib/libtinfow_g.a
+%%WIDEC%%%%PROFILE%%lib/libtinfow_p.a
+%%TERMINFO%%share/misc/tabset/std
+%%TERMINFO%%share/misc/tabset/stdcrt
+%%TERMINFO%%share/misc/tabset/vt100
+%%TERMINFO%%share/misc/tabset/vt300
+%%TERMINFO%%share/misc/terminfo.db
%%WIDEC%%%%WIDEC_EXAMPLESDIR%%/Makefile
%%WIDEC%%%%WIDEC_EXAMPLESDIR%%/README
%%WIDEC%%%%WIDEC_EXAMPLESDIR%%/blue.c
@@ -175,9 +195,11 @@ share/misc/terminfo
%%NOWIDEC_EXAMPLESDIR%%/view.c
%%NOWIDEC_EXAMPLESDIR%%/worm.c
%%NOWIDEC_EXAMPLESDIR%%/xmas.c
+%%TERMINFO%%@exec find %D/share/misc -name "*.terminfo" -print0 | xargs -0 %D/bin/tic
%%WIDEC%%@dirrm %%WIDEC_EXAMPLESDIR%%/c++
%%WIDEC%%@dirrm %%WIDEC_EXAMPLESDIR%%
@dirrm %%NOWIDEC_EXAMPLESDIR%%/c++
@dirrm %%NOWIDEC_EXAMPLESDIR%%
@dirrm %%EXAMPLESDIR%%
+%%TERMINFO%%@dirrmtry share/misc/tabset
@dirrm include/ncurses