aboutsummaryrefslogtreecommitdiff
path: root/devel/ncurses
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-14 04:16:20 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-14 04:16:20 +0000
commit8d7dd7c3d3a2077d3b480845eee18c7bf36fe3b9 (patch)
tree9e357ab9e4dc9db08cfd07d747dbbb21b1c89ec2 /devel/ncurses
parentea3c4663badc9d35ed698a2e8945bb2ac5606bf8 (diff)
downloadports-8d7dd7c3d3a2077d3b480845eee18c7bf36fe3b9.tar.gz
ports-8d7dd7c3d3a2077d3b480845eee18c7bf36fe3b9.zip
- Respect DESTDIR
- s/INSTALLS_SHLIB/USE_LDCONFIG/ PR: ports/101879 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=170534
Diffstat (limited to 'devel/ncurses')
-rw-r--r--devel/ncurses/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index 7643585f9777..240de565de29 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -19,23 +19,25 @@ NO_FILTER_SHLIBS= no
GNU_CONFIGURE= yes
CONFIGURE_SCRIPT=../configure
-CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
+CONFIGURE_ARGS= --datadir=${TARGETDIR}/share/misc --disable-overwrite \
--enable-termcap --disable-database --enable-getcap \
--enable-colorfgbg --enable-bsdpad --disable-home-terminfo \
- --includedir=${PREFIX}/include/ncurses \
+ --includedir=${TARGETDIR}/include/ncurses \
--with-profile --with-shared --without-debug \
--without-curses-h --with-termlib --program-prefix= \
--enable-safe-sprintf --disable-root-environ \
--with-manpage-format=gzip --srcdir=../
+USE_LDCONFIG= yes
+
# needed by devel/py-ncurses port
.if defined(WITH_TRACE)
CONFIGURE_ARGS+= --with-trace
.endif
-LDFLAGS+= -rpath ${PREFIX}/lib
+LDFLAGS+= -rpath ${TARGETDIR}/lib
CONFIGURE_ENV= gnat_exists="no" \
- ac_cv_path_LDCONFIG="${LDCONFIG} -m ${PREFIX}/lib" \
+ ac_cv_path_LDCONFIG="${LDCONFIG} -m ${TARGETDIR}/lib" \
LDFLAGS="${LDFLAGS}"
WIDEC_WRKSRC= ${WRKSRC}/build.widec
@@ -49,10 +51,9 @@ BUILD_WRKSRC= ${NOWIDEC_WRKSRC}
INSTALL_WRKSRC= ${NOWIDEC_WRKSRC}
PLIST_SUB+= PORTVERSION=${PORTVERSION} \
- WIDEC_EXAMPLESDIR=${WIDEC_EXAMPLESDIR:S,${PREFIX}/,,} \
- NOWIDEC_EXAMPLESDIR=${NOWIDEC_EXAMPLESDIR:S,${PREFIX}/,,}
+ WIDEC_EXAMPLESDIR=${WIDEC_EXAMPLESDIR:S,${TARGETDIR}/,,} \
+ NOWIDEC_EXAMPLESDIR=${NOWIDEC_EXAMPLESDIR:S,${TARGETDIR}/,,}
-INSTALLS_SHLIB= yes
MANCOMPRESSED= yes
MAN1= captoinfo.1m clear.1 infocmp.1m infotocap.1m reset.1 tack.1 \
tic.1m toe.1m tput.1 tset.1
@@ -260,7 +261,7 @@ post-install:
.endif
${INSTALL_DATA} ${WRKSRC}/misc/terminfo.src \
- ${PREFIX}/share/misc/terminfo
+ ${TARGETDIR}/share/misc/terminfo
.for i in ${EXAMPLES_TARGETS}
${MKDIR} ${${i}_EXAMPLESDIR}/c++