aboutsummaryrefslogtreecommitdiff
path: root/devel/noweb/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-08-08 08:58:46 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-08-08 08:58:46 +0000
commit61b2ff1192d5e36fd5bc661a96c444ca1157734e (patch)
treedc30ffa95eec79ffa80c886ee971cfd3f929085e /devel/noweb/Makefile
parentdac14898cad2ae6481d4e019c103a3f8150d427d (diff)
downloadports-61b2ff1192d5e36fd5bc661a96c444ca1157734e.tar.gz
ports-61b2ff1192d5e36fd5bc661a96c444ca1157734e.zip
noweb is a simple literate programming tool, says Thomas. I put
it in devel because it's a programmer's tool. Submitted by: Thomas Gellekum <thomas@ghpc8.ihf.rwth-aachen.de>
Notes
Notes: svn path=/head/; revision=2035
Diffstat (limited to 'devel/noweb/Makefile')
-rw-r--r--devel/noweb/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/noweb/Makefile b/devel/noweb/Makefile
new file mode 100644
index 000000000000..b1e9106091ff
--- /dev/null
+++ b/devel/noweb/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: noweb
+# Version required: noweb-2.7a
+# Date created: 29 July 1995
+# Whom: thomas@ghpc8.ihf.rwth-aachen.de
+#
+# $Id$
+#
+
+DISTNAME= noweb-2.7a
+CATEGORIES+= development documentation
+KEYWORDS+= development documentation "literate programming"
+MASTER_SITES= ftp://bellcore.com/pub/norman/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= thomas@ghpc8.ihf.rwth-aachen.de
+
+EXEC_DEPENDS= icont:${PORTSDIR}/lang/icon
+
+WRKSRC= ${WRKDIR}/src
+
+.if !defined(NOMANCOMPRESS)
+post-install:
+ for i in nodefs noindex noroots notangle noweb cpif sl2h nowebstyle nuweb2noweb nowebfilters; \
+ do \
+ gzip -9nf ${PREFIX}/man/man1/$$i.1; \
+ done
+ @rm ${PREFIX}/man/man1/noweave.1*
+ @rm ${PREFIX}/man/man1/nountangle.1*
+ ln ${PREFIX}/man/man1/notangle.1.gz ${PREFIX}/man/man1/noweave.1.gz
+ ln ${PREFIX}/man/man1/notangle.1.gz ${PREFIX}/man/man1/nountangle.1.gz
+.endif
+
+.include <bsd.port.mk>
+