aboutsummaryrefslogtreecommitdiff
path: root/devel/omniNotify
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-23 00:08:11 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-23 00:08:11 +0000
commit9deff97eee7ada9c8381db9703cdb48f54c138a6 (patch)
treed669d38b7e4a4de4502d9befbd38fd7226813d0d /devel/omniNotify
parentaf91915a4d311177c364032ef7a3a3f36726196a (diff)
downloadports-9deff97eee7ada9c8381db9703cdb48f54c138a6.tar.gz
ports-9deff97eee7ada9c8381db9703cdb48f54c138a6.zip
CORBA Notification Service for omniORB
Notes
Notes: svn path=/head/; revision=122184
Diffstat (limited to 'devel/omniNotify')
-rw-r--r--devel/omniNotify/Makefile57
-rw-r--r--devel/omniNotify/distinfo2
-rw-r--r--devel/omniNotify/files/patch-configure10
-rw-r--r--devel/omniNotify/pkg-descr19
-rw-r--r--devel/omniNotify/pkg-plist227
5 files changed, 315 insertions, 0 deletions
diff --git a/devel/omniNotify/Makefile b/devel/omniNotify/Makefile
new file mode 100644
index 000000000000..a88e9b2588ce
--- /dev/null
+++ b/devel/omniNotify/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: omniNotify
+# Date created: 23 November 2004
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= omniNotify
+PORTVERSION= 2.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= CORBA Notification Service (CosNotification) for omniORB
+
+LIB_DEPENDS= omniORB4.0:${PORTSDIR}/devel/omniORB
+RUN_DEPENDS= omniidl:${PORTSDIR}/devel/omniORB
+# parts of omniORB4 source tree is required to build
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/omniORB:patch
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+CONFIGURE_WRKSRC= ${WRKSRC}/build
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+OMNIORB_WRKSRC!= cd ${.CURDIR}/../omniORB && ${MAKE} -V WRKSRC
+
+USE_PYTHON= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKEFILE= GNUmakefile
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+USE_REINPLACE= yes
+
+CONFIGURE_SCRIPT= ../configure
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CC=${CC} CFLAGS="${CFLAGS}" CXX=${CXX} CXXFLAGS="${CXXFLAGS}" \
+ CPP=${CPP} PYTHON=${PYTHON_CMD}
+CONFIGURE_ARGS= --with-omniorb=${LOCALBASE}
+
+pre-configure:
+ @${MKDIR} ${CONFIGURE_WRKSRC}
+ @cd ${OMNIORB_WRKSRC} && ${FIND} idl | ${CPIO} --quiet -pdum ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's#-pthread|-lc_r#${PTHREAD_LIBS}#' \
+ ${WRKSRC}/mk/beforeauto.mk.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${FIND} . -not -name .cvsignore \
+ | ${CPIO} --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/omniNotify/distinfo b/devel/omniNotify/distinfo
new file mode 100644
index 000000000000..aec0e65b671e
--- /dev/null
+++ b/devel/omniNotify/distinfo
@@ -0,0 +1,2 @@
+MD5 (omniNotify-2.1.tar.gz) = 6f5655e4f1cfff4d4dc21688ca4c9e8b
+SIZE (omniNotify-2.1.tar.gz) = 539019
diff --git a/devel/omniNotify/files/patch-configure b/devel/omniNotify/files/patch-configure
new file mode 100644
index 000000000000..da6b17a468b0
--- /dev/null
+++ b/devel/omniNotify/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Oct 12 22:51:19 2003
++++ configure Tue Nov 23 00:49:16 2004
+@@ -2955,6 +2955,7 @@
+ *-*-freebsd3*) platform_name="FreeBSD"; os_version="3";;
+ *-*-freebsd4*) platform_name="FreeBSD"; os_version="4";;
+ *-*-freebsd5*) platform_name="FreeBSD"; os_version="5";;
++ *-*-freebsd6*) platform_name="FreeBSD"; os_version="6";;
+ *-*-sco*) platform_name="OSR5"; os_version="5";;
+ esac
+
diff --git a/devel/omniNotify/pkg-descr b/devel/omniNotify/pkg-descr
new file mode 100644
index 000000000000..9c5c14b17976
--- /dev/null
+++ b/devel/omniNotify/pkg-descr
@@ -0,0 +1,19 @@
+omniNotify is a multi-threaded implementation of the CORBA
+Notification Service (CosNotification), a feature-enriched
+version of the CORBA Event Service (CosEvents).
+omniNotify offers asynchronous, decoupled, event-based communication
+between distributed and heterogeneous applications.
+
+The main features of omniNotify are:
+
+* Implemented in C++.
+* Scalable filter evaluation and event dispatching architecture.
+* Support for push-based and pull-based event suppliers and consumers.
+* Support variants of suppliers/consumers that transmit (per push/pull):
+ o a CORBA::Any (a single arbitrary value);
+ o a CosNotification::StructuredEvent (a single structured event);
+ o a CosNotification::EventBatch (a sequence of structured events).
+* Administrative and Notification QoS properties.
+* Backward compatible with CosEvents.
+
+WWW: http://omninotify.sourceforge.net/
diff --git a/devel/omniNotify/pkg-plist b/devel/omniNotify/pkg-plist
new file mode 100644
index 000000000000..c64601f3c47b
--- /dev/null
+++ b/devel/omniNotify/pkg-plist
@@ -0,0 +1,227 @@
+bin/notifd
+include/COS/ATTN_sysdep.h
+include/COS/AttNotification.hh
+include/omniNotify/CosEventChannelAdmin_i.h
+include/omniNotify/CosNfyUtils.h
+include/omniNotify/CosNotification_i.h
+include/omniNotify/CosNotifyChannelAdmin_i.h
+include/omniNotify/CosNotifyFilter_i.h
+include/omniNotify/CosNotifyShorthands.h
+include/omniNotify/ModFlexLexer.h
+include/omniNotify/RDI.h
+include/omniNotify/RDIBitmap.h
+include/omniNotify/RDICatchMacros.h
+include/omniNotify/RDIChannelUtil.h
+include/omniNotify/RDIConfig.h
+include/omniNotify/RDIConstraint.h
+include/omniNotify/RDIDynamicEvalDefs.h
+include/omniNotify/RDIEvalDefs.h
+include/omniNotify/RDIEvent.h
+include/omniNotify/RDIEventQueue.h
+include/omniNotify/RDIHash.h
+include/omniNotify/RDIHashFuncs.h
+include/omniNotify/RDIInteractive.h
+include/omniNotify/RDIInteractiveMode.h
+include/omniNotify/RDILimits.h
+include/omniNotify/RDIList.h
+include/omniNotify/RDIMutex.h
+include/omniNotify/RDINotifQueue.h
+include/omniNotify/RDINotifServer.h
+include/omniNotify/RDIOSWrappers.h
+include/omniNotify/RDIOplocks.h
+include/omniNotify/RDIOplocksMacros.h
+include/omniNotify/RDIRVMPool.h
+include/omniNotify/RDIStaticEvalDefs.h
+include/omniNotify/RDIStringDefs.h
+include/omniNotify/RDIThreadPriority.h
+include/omniNotify/RDITimeWrappers.h
+include/omniNotify/RDITypeMap.h
+include/omniNotify/RDIUtil.h
+include/omniNotify/RDIstrstream.h
+include/omniNotify/RDIsysdep.h
+include/omniNotify/corba_wrappers.h
+include/omniNotify/corba_wrappers_impl.h
+include/omniNotify/omniNotify.h
+include/omniNotify/omniorb_boa_wrappers.h
+include/omniNotify/omniorb_boa_wrappers_impl.h
+include/omniNotify/omniorb_common_wrappers.h
+include/omniNotify/omniorb_poa_wrappers.h
+include/omniNotify/omniorb_poa_wrappers_impl.h
+include/omniNotify/omnithread_thread_wrappers.h
+include/omniNotify/thread_wrappers.h
+include/omniNotify/timebase.h
+lib/libAttNotification4.so
+lib/libAttNotification4.so.0
+lib/libAttNotification4.so.0.1
+lib/libAttNotificationDynamic4.so
+lib/libAttNotificationDynamic4.so.0
+lib/libAttNotificationDynamic4.so.0.1
+lib/libCOSNotify4.a
+lib/libCOSNotify4.so
+lib/libCOSNotify4.so.0
+lib/libCOSNotify4.so.0.1
+%%EXAMPLESDIR%%/GNUmakefile
+%%EXAMPLESDIR%%/GNUmakefile.in
+%%EXAMPLESDIR%%/READING_THE_CODE
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/all_cosnotify_clients.cc
+%%EXAMPLESDIR%%/any_pull_consumer.cc
+%%EXAMPLESDIR%%/any_pull_supplier.cc
+%%EXAMPLESDIR%%/any_push_consumer.cc
+%%EXAMPLESDIR%%/any_push_supplier.cc
+%%EXAMPLESDIR%%/batch_pull_consumer.cc
+%%EXAMPLESDIR%%/batch_pull_supplier.cc
+%%EXAMPLESDIR%%/batch_push_consumer.cc
+%%EXAMPLESDIR%%/batch_push_supplier.cc
+%%EXAMPLESDIR%%/cosnotify_tests/COPYING
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/AnyPullCon.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/AnyPullSup.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/AnyPushCon.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/AnyPushSup.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/BatchPullCon.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/BatchPullSup.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/BatchPushCon.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/BatchPushSup.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/CliMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/ConMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/NOTES
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/PingCliMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/PullConMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/PullSupMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/PushSupMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/StructPullCon.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/StructPullSup.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/StructPushCon.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/StructPushSup.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/SupMixin.py
+%%EXAMPLESDIR%%/cosnotify_tests/Clients/__init__.py
+%%EXAMPLESDIR%%/cosnotify_tests/Config/InterFilterCases.py
+%%EXAMPLESDIR%%/cosnotify_tests/Config/StandAloneCases.py
+%%EXAMPLESDIR%%/cosnotify_tests/Config/SupConCases.py
+%%EXAMPLESDIR%%/cosnotify_tests/Config/TopConf.py
+%%EXAMPLESDIR%%/cosnotify_tests/Config/__init__.py
+%%EXAMPLESDIR%%/cosnotify_tests/CorbaLocTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/DestroyServer.py
+%%EXAMPLESDIR%%/cosnotify_tests/DoCommandTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/FilterIDTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/FooTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numaddeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numdiveq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numge.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numgt.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numle.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numlt.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_nummuleq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numne.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_Double_numsubeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MySt.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_dotid_longeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_dotid_streq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagdef_boolneq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagid_index_streq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagid_longeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_LENGTH.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_index_EXIST.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_index_IN.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_index_streq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_index_streq_AND.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_index_streq_NOT.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_index_streq_OR.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_longeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_shorteq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_MyUnType_tagnum_streq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_divbyzero.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numaddeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numdiveq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numge.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numgt.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numle.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numlt.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_nummuleq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numne.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_numsubeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_streq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_strne.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_Any_substr.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_StockBondTicker_dnameeq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_StockBondTicker_fieldstreq.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Con_ULEvent.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/ConstraintCheck.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/GetConstraintsCheck.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/GrammarCheck.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/NOTES
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_Double.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_Float.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_Long.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_MySt.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_MyUnType.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_String.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_Any_ULong.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_StockBondTicker.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/Sup_ULEvent.py
+%%EXAMPLESDIR%%/cosnotify_tests/Helpers/__init__.py
+%%EXAMPLESDIR%%/cosnotify_tests/README
+%%EXAMPLESDIR%%/cosnotify_tests/RunTests.py
+%%EXAMPLESDIR%%/cosnotify_tests/Stubs/__init__.py
+%%EXAMPLESDIR%%/cosnotify_tests/Stubs/mkall.py
+%%EXAMPLESDIR%%/cosnotify_tests/Stubs/mkattstubs.py
+%%EXAMPLESDIR%%/cosnotify_tests/Stubs/mkcosstubs.py
+%%EXAMPLESDIR%%/cosnotify_tests/Stubs/mkstubs.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/ChanUtils.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/CliUtils.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/DummyEvent.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/InterFilterTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/NumUtils.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/PropUtils.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/StandAloneTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/StockBondUtils.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/SupConTest.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/TestStats.py
+%%EXAMPLESDIR%%/cosnotify_tests/Utils/__init__.py
+%%EXAMPLESDIR%%/cosnotify_tests/idl/AttNotification.idl
+%%EXAMPLESDIR%%/cosnotify_tests/idl/MyPushTest.idl
+%%EXAMPLESDIR%%/cosnotify_tests/idl/MyStTest.idl
+%%EXAMPLESDIR%%/cosnotify_tests/idl/MyUnTest.idl
+%%EXAMPLESDIR%%/cosnotify_tests/run10.py
+%%EXAMPLESDIR%%/cosnotify_tests/run_range.py
+%%EXAMPLESDIR%%/cosnotify_tests/run_tests.py
+%%EXAMPLESDIR%%/cosnotify_tests/sanity_check.py
+%%EXAMPLESDIR%%/demo_add_filter.cc
+%%EXAMPLESDIR%%/demo_offer_change.cc
+%%EXAMPLESDIR%%/demo_subscription_change.cc
+%%EXAMPLESDIR%%/dir.mk
+%%EXAMPLESDIR%%/get_channel.h
+%%EXAMPLESDIR%%/getopt_impl.h
+%%EXAMPLESDIR%%/legacy_clients.cc
+%%EXAMPLESDIR%%/legacy_clients.h
+%%EXAMPLESDIR%%/legacy_pull_consumer.cc
+%%EXAMPLESDIR%%/legacy_pull_supplier.cc
+%%EXAMPLESDIR%%/legacy_push_consumer.cc
+%%EXAMPLESDIR%%/legacy_push_supplier.cc
+%%EXAMPLESDIR%%/main_program.h
+%%EXAMPLESDIR%%/ndadmin.cc
+%%EXAMPLESDIR%%/orb_init_name.h
+%%EXAMPLESDIR%%/parse_cmd_line.h
+%%EXAMPLESDIR%%/s512_push_consumer.cc
+%%EXAMPLESDIR%%/s512_push_supplier.cc
+%%EXAMPLESDIR%%/sample_clients.cc
+%%EXAMPLESDIR%%/sample_clients.h
+%%EXAMPLESDIR%%/sample_functions.cc
+%%EXAMPLESDIR%%/sample_functions.h
+%%EXAMPLESDIR%%/some_notify_clients.cc
+%%EXAMPLESDIR%%/struct_pull_consumer.cc
+%%EXAMPLESDIR%%/struct_pull_supplier.cc
+%%EXAMPLESDIR%%/struct_push_consumer.cc
+%%EXAMPLESDIR%%/struct_push_supplier.cc
+%%EXAMPLESDIR%%/ten_any_pull_consumers.cc
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests/idl
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests/Utils
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests/Stubs
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests/Helpers
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests/Config
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests/Clients
+@dirrm %%EXAMPLESDIR%%/cosnotify_tests
+@dirrm %%EXAMPLESDIR%%
+@dirrm include/omniNotify