aboutsummaryrefslogtreecommitdiff
path: root/devel/oniguruma/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-01-31 13:03:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-01-31 13:03:50 +0000
commit9227ab842391dbe4043bd3aaf6c2a487d608ac8c (patch)
treef22449e88d54f69c2b1261e6be7e30d0bf6ad9dc /devel/oniguruma/Makefile
parent1cb56f69b9aa747d03b041e25344685995557065 (diff)
downloadports-9227ab842391dbe4043bd3aaf6c2a487d608ac8c.tar.gz
ports-9227ab842391dbe4043bd3aaf6c2a487d608ac8c.zip
Add devel/oniguruma.
Oniguruma is a BSDL Regular Expression library written for ruby-m17n, which implements all of Perl extensions plus more. It has multiple APIs; GNU regex, POSIX regex and its own interface. This library is fundamentally multilingualized and can have one encoding for each object. Currently supported character encodings are ASCII, UTF-8, EUC-JP and Shift_JIS. Author: K.Kosako <kosako@sofnec.co.jp> WWW: http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/oniguruma/
Notes
Notes: svn path=/head/; revision=74351
Diffstat (limited to 'devel/oniguruma/Makefile')
-rw-r--r--devel/oniguruma/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/oniguruma/Makefile b/devel/oniguruma/Makefile
new file mode 100644
index 000000000000..8d37fd530b1c
--- /dev/null
+++ b/devel/oniguruma/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Oniguruma
+# Date created: 31 January 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oniguruma
+PORTVERSION= 1.6
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_RUBY}
+MASTER_SITE_SUBDIR= contrib
+DISTNAME= onigd20030121
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+MAKEFILE= BSDmakefile
+MAKE_ARGS= NOPROFILE=true
+INSTALLS_SHLIB= yes
+
+pre-build:
+ ${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>