aboutsummaryrefslogtreecommitdiff
path: root/devel/oniguruma
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-04 09:39:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-04 09:39:50 +0000
commitf0631c9279ddbcc586ba8604660283793a4dddfd (patch)
tree01db34399d3f2c4bdde28d0461a7f4600e76d8b1 /devel/oniguruma
parentf0d4fe16f52555ae00686c95e84c62fc067f2632 (diff)
downloadports-f0631c9279ddbcc586ba8604660283793a4dddfd.tar.gz
ports-f0631c9279ddbcc586ba8604660283793a4dddfd.zip
Update to 1.7 (20030204), with improved performance.
According to the author's post on a mailing list, a simple benchmark shows that Oniguruma is 10-20% faster than PCRE 3.9 under the ASCII (single byte) encoding.
Notes
Notes: svn path=/head/; revision=74633
Diffstat (limited to 'devel/oniguruma')
-rw-r--r--devel/oniguruma/Makefile10
-rw-r--r--devel/oniguruma/distinfo2
-rw-r--r--devel/oniguruma/files/BSDmakefile2
-rw-r--r--devel/oniguruma/pkg-plist1
4 files changed, 10 insertions, 5 deletions
diff --git a/devel/oniguruma/Makefile b/devel/oniguruma/Makefile
index 8d37fd530b1c..74751a0adf78 100644
--- a/devel/oniguruma/Makefile
+++ b/devel/oniguruma/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= oniguruma
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= contrib
-DISTNAME= onigd20030121
+DISTNAME= onigd20030204
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@@ -21,6 +21,8 @@ MAKEFILE= BSDmakefile
MAKE_ARGS= NOPROFILE=true
INSTALLS_SHLIB= yes
+DOCS= README doc/*
+
pre-build:
${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}/
@@ -29,7 +31,9 @@ post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/devel/oniguruma/distinfo b/devel/oniguruma/distinfo
index aa8d9c6fd003..c838536c73f2 100644
--- a/devel/oniguruma/distinfo
+++ b/devel/oniguruma/distinfo
@@ -1 +1 @@
-MD5 (ruby/onigd20030121.tar.gz) = 92ba124a64e0852e067f3aaeecf11f87
+MD5 (ruby/onigd20030204.tar.gz) = aec4bb39e1211dde6cdc4a920be99a45
diff --git a/devel/oniguruma/files/BSDmakefile b/devel/oniguruma/files/BSDmakefile
index 6d09167981f1..43333010bf08 100644
--- a/devel/oniguruma/files/BSDmakefile
+++ b/devel/oniguruma/files/BSDmakefile
@@ -3,7 +3,7 @@
LIB= onig
SHLIB_MAJOR?= 0
SHLIB_MINOR?= 0
-CFLAGS+= -DHAVE_CONFIG_H
+CFLAGS+= -DHAVE_CONFIG_H -DNOT_RUBY
SRCS= regerror.o regcomp.o regexec.o reggnu.o \
regposix.o regposerr.o
INCS= regex.h \
diff --git a/devel/oniguruma/pkg-plist b/devel/oniguruma/pkg-plist
index 55e2976ae843..a2462187b216 100644
--- a/devel/oniguruma/pkg-plist
+++ b/devel/oniguruma/pkg-plist
@@ -4,6 +4,7 @@ include/onig/regex.h
lib/libonig.a
lib/libonig.so
lib/libonig.so.0
+%%PORTDOCS%%%%DOCSDIR%%/API
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%%%EXAMPLESDIR%%/simple.c