aboutsummaryrefslogtreecommitdiff
path: root/devel/orc/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-05-14 13:02:32 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-05-14 13:02:32 +0000
commitbd14ded547fc4303f0a6541009830907d95d01a1 (patch)
tree77761dce13ac51904b42da0f895577f9790015cf /devel/orc/Makefile
parent576dcaed69959a0033ae41f328188d0c30939bc8 (diff)
downloadports-bd14ded547fc4303f0a6541009830907d95d01a1.tar.gz
ports-bd14ded547fc4303f0a6541009830907d95d01a1.zip
Fix pkg-plist for WITH_DOCS and WITH_EXAMPLES.
PR: ports/156440 Submitted by: Arseny Nasokin <eirnym@gmail.com>
Notes
Notes: svn path=/head/; revision=274096
Diffstat (limited to 'devel/orc/Makefile')
-rw-r--r--devel/orc/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/devel/orc/Makefile b/devel/orc/Makefile
index d3428ed65325..030c33692308 100644
--- a/devel/orc/Makefile
+++ b/devel/orc/Makefile
@@ -6,6 +6,7 @@
PORTNAME= orc
PORTVERSION= 0.4.14
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://code.entropywave.com/download/orc/
@@ -24,6 +25,10 @@ CONFIGURE_ARGS+= --disable-gtk-doc
SUBDIRS= orc orc-test tools
+EXAMPLES_DATA= example1orc.orc example2orc.orc example3orc.orc \
+ mt19937arorc.orc
+EXAMPLES_EXEC= example1 example2 example3 mt19937ar volscale
+
OPTIONS= DOCS "Include gtk-doc documentation" off \
EXAMPLES "Install example files" off
@@ -49,4 +54,15 @@ post-patch:
-e 's|pkgconfigdir=.*|pkgconfigdir=\"\\$$(prefix)/libdata/pkgconfig\"|g' \
${WRKSRC}/configure
+post-install:
+.if defined(WITH_EXAMPLES) && !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for FILE in ${EXAMPLES_DATA}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${FILE} ${EXAMPLESDIR}/${FILE}
+.endfor
+.for FILE in ${EXAMPLES_EXEC}
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/${FILE} ${EXAMPLESDIR}/${FILE}
+.endfor
+.endif
+
.include <bsd.port.post.mk>