aboutsummaryrefslogtreecommitdiff
path: root/devel/ossp-ex
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-31 20:21:24 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-31 20:21:24 +0000
commitbeb35905c473b0c75318e13e119b381c6fb8be5f (patch)
tree7991169ee0f7b85b195ed7eafa4042b556eb627a /devel/ossp-ex
parent819c5fb11cc8ae22eb8c9885e25005037b9c069f (diff)
downloadports-beb35905c473b0c75318e13e119b381c6fb8be5f.tar.gz
ports-beb35905c473b0c75318e13e119b381c6fb8be5f.zip
OSSP ex is a small ISO-C++ style exception handling library for use in the
ISO-C language. It allows you to use the paradigm of throwing and catching exceptions in order to reduce the amount of error handling code without making your program less robust. By Ralf Engelschall. His s***'s not ****ed up.
Notes
Notes: svn path=/head/; revision=74374
Diffstat (limited to 'devel/ossp-ex')
-rw-r--r--devel/ossp-ex/Makefile27
-rw-r--r--devel/ossp-ex/distinfo1
-rw-r--r--devel/ossp-ex/files/manpages.mk1
-rw-r--r--devel/ossp-ex/pkg-comment1
-rw-r--r--devel/ossp-ex/pkg-descr8
-rw-r--r--devel/ossp-ex/pkg-plist6
6 files changed, 44 insertions, 0 deletions
diff --git a/devel/ossp-ex/Makefile b/devel/ossp-ex/Makefile
new file mode 100644
index 000000000000..3598a3393e1b
--- /dev/null
+++ b/devel/ossp-ex/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: ossp-mm
+# Date created: 2003-01-31
+# Whom: Alan Eldridge <alane@geeksrus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ex
+PORTVERSION= 1.0.2
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/ex/
+PKGNAMEPREFIX= ossp-
+
+MAINTAINER= alane@FreeBSD.org
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
+
+#EOF
diff --git a/devel/ossp-ex/distinfo b/devel/ossp-ex/distinfo
new file mode 100644
index 000000000000..28164891fe4c
--- /dev/null
+++ b/devel/ossp-ex/distinfo
@@ -0,0 +1 @@
+MD5 (ex-1.0.2.tar.gz) = 5fa7e0f173fc51ca1cd2fae1df81c820
diff --git a/devel/ossp-ex/files/manpages.mk b/devel/ossp-ex/files/manpages.mk
new file mode 100644
index 000000000000..fe3c7d6a8a21
--- /dev/null
+++ b/devel/ossp-ex/files/manpages.mk
@@ -0,0 +1 @@
+MAN3+= ex.3
diff --git a/devel/ossp-ex/pkg-comment b/devel/ossp-ex/pkg-comment
new file mode 100644
index 000000000000..f0a03123ae1d
--- /dev/null
+++ b/devel/ossp-ex/pkg-comment
@@ -0,0 +1 @@
+OSSP ex is a small exception handling library for use in C
diff --git a/devel/ossp-ex/pkg-descr b/devel/ossp-ex/pkg-descr
new file mode 100644
index 000000000000..4e2cd3b37295
--- /dev/null
+++ b/devel/ossp-ex/pkg-descr
@@ -0,0 +1,8 @@
+OSSP ex is a small ISO-C++ style exception handling library for use in the
+ISO-C language. It allows you to use the paradigm of throwing and catching
+exceptions in order to reduce the amount of error handling code without
+making your program less robust.
+
+WWW: http://www.ossp.org/pkg/lib/ex/
+
+-- AlanE@FreeBSD.org
diff --git a/devel/ossp-ex/pkg-plist b/devel/ossp-ex/pkg-plist
new file mode 100644
index 000000000000..295b087cc41f
--- /dev/null
+++ b/devel/ossp-ex/pkg-plist
@@ -0,0 +1,6 @@
+bin/ex-config
+include/ex.h
+lib/libex.a
+lib/libex.la
+lib/libex.so
+lib/libex.so.10