aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-Evolutionary
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-07-28 14:30:50 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-07-28 14:30:50 +0000
commit88207e1d6fdec8448fe22818c00cc43dde406f6e (patch)
tree00cbe961a4abda7ac2ad9a5bf66767e2b4051d87 /devel/p5-Algorithm-Evolutionary
parent85947c6fe2fa064e66f3fd630dab0334a487f49f (diff)
downloadports-88207e1d6fdec8448fe22818c00cc43dde406f6e.tar.gz
ports-88207e1d6fdec8448fe22818c00cc43dde406f6e.zip
Update to 0.70.
Notes
Notes: svn path=/head/; revision=238518
Diffstat (limited to 'devel/p5-Algorithm-Evolutionary')
-rw-r--r--devel/p5-Algorithm-Evolutionary/Makefile34
-rw-r--r--devel/p5-Algorithm-Evolutionary/distinfo6
-rw-r--r--devel/p5-Algorithm-Evolutionary/pkg-plist18
3 files changed, 43 insertions, 15 deletions
diff --git a/devel/p5-Algorithm-Evolutionary/Makefile b/devel/p5-Algorithm-Evolutionary/Makefile
index 90677812ac2e..520d8ce13ce7 100644
--- a/devel/p5-Algorithm-Evolutionary/Makefile
+++ b/devel/p5-Algorithm-Evolutionary/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Algorithm-Evolutionary
-PORTVERSION= 0.67
+PORTVERSION= 0.70
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,15 +15,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A library for doing evolutionary computation in Perl
-BUILD_DEPENDS= p5-XML-LibXML>=1.5:${PORTSDIR}/textproc/p5-XML-LibXML
-RUN_DEPENDS= p5-Algorithm-Permute>=0.01:${PORTSDIR}/devel/p5-Algorithm-Permute \
- p5-Clone-Fast>=0:${PORTSDIR}/devel/p5-Clone-Fast \
+COMMON_DEPENDS= p5-XML-LibXML>=1.5:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-Algorithm-Permute>=0.01:${PORTSDIR}/devel/p5-Algorithm-Permute \
+ p5-Bit-Vector>0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-Clone-Fast>0:${PORTSDIR}/devel/p5-Clone-Fast \
+ p5-GD>=2.17:${PORTSDIR}/graphics/p5-GD \
p5-Math-Random>=0.63:${PORTSDIR}/math/p5-Math-Random \
- p5-String-Random>=0:${PORTSDIR}/devel/p5-String-Random \
+ p5-Statistics-Basic>=1.6:${PORTSDIR}/math/p5-Statistics-Basic \
+ p5-String-Random>0:${PORTSDIR}/devel/p5-String-Random \
+ p5-Object-Array>0:${PORTSDIR}/devel/p5-Object-Array \
p5-Tree-DAG_Node>=1.04:${PORTSDIR}/devel/p5-Tree-DAG_Node \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
- p5-XML-Parser-EasyTree>=0.01:${PORTSDIR}/textproc/p5-XML-Parser-EasyTree \
- p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
+ p5-XML-Parser>0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Parser-Style-EasyTree>=0.01:${PORTSDIR}/textproc/p5-XML-Parser-Style-EasyTree \
+ p5-YAML>0:${PORTSDIR}/textproc/p5-YAML \
+ p5-version>0:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= ${COMMON_DEPENDS}
+RUN_DEPENDS= ${COMMON_DEPENDS}
+BUILD_DEPENDS+= p5-Test-Pod>0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Pod-Escapes>0:${PORTSDIR}/textproc/p5-Pod-Escapes
PERL_CONFIGURE= yes
@@ -31,6 +40,7 @@ MAN1= tide_bitstring.pl.1 tide_float.pl.1 \
canonical-genetic-algorithm.pl.1
MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Experiment.3 \
+ Algorithm::Evolutionary::Fitness::Any.3 \
Algorithm::Evolutionary::Fitness::Base.3 \
Algorithm::Evolutionary::Fitness::ECC.3 \
Algorithm::Evolutionary::Fitness::Knapsack.3 \
@@ -39,6 +49,8 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Fitness::P_Peaks.3 \
Algorithm::Evolutionary::Fitness::Royal_Road.3 \
Algorithm::Evolutionary::Fitness::String.3 \
+ Algorithm::Evolutionary::Fitness::Trap.3 \
+ Algorithm::Evolutionary::Fitness::ZDT1.3 \
Algorithm::Evolutionary::Fitness::wP_Peaks.3 \
Algorithm::Evolutionary::Individual::Any.3 \
Algorithm::Evolutionary::Individual::Base.3 \
@@ -47,6 +59,7 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Individual::String.3 \
Algorithm::Evolutionary::Individual::Tree.3 \
Algorithm::Evolutionary::Individual::Vector.3 \
+ Algorithm::Evolutionary::Op::Animated_GIF_Output.3 \
Algorithm::Evolutionary::Op::ArithCrossover.3 \
Algorithm::Evolutionary::Op::Base.3 \
Algorithm::Evolutionary::Op::Bitflip.3 \
@@ -58,6 +71,9 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Op::Crossover.3 \
Algorithm::Evolutionary::Op::DeltaTerm.3 \
Algorithm::Evolutionary::Op::Easy.3 \
+ Algorithm::Evolutionary::Op::Easy_MO.3 \
+ Algorithm::Evolutionary::Op::Eval::General.3 \
+ Algorithm::Evolutionary::Op::Eval::MO_Rank.3 \
Algorithm::Evolutionary::Op::FullAlgorithm.3 \
Algorithm::Evolutionary::Op::GaussianMutation.3 \
Algorithm::Evolutionary::Op::Gene_Boundary_Crossover.3 \
@@ -71,12 +87,14 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Op::NoChangeTerm.3 \
Algorithm::Evolutionary::Op::Novelty_Mutation.3 \
Algorithm::Evolutionary::Op::Permutation.3 \
+ Algorithm::Evolutionary::Op::Population_Output.3 \
Algorithm::Evolutionary::Op::QuadXOver.3 \
Algorithm::Evolutionary::Op::Replace_Worst.3 \
Algorithm::Evolutionary::Op::RouletteWheel.3 \
Algorithm::Evolutionary::Op::Selector.3 \
Algorithm::Evolutionary::Op::SimulatedAnnealing.3 \
Algorithm::Evolutionary::Op::Storing.3 \
+ Algorithm::Evolutionary::Op::StringRand.3 \
Algorithm::Evolutionary::Op::TournamentSelect.3 \
Algorithm::Evolutionary::Op::TreeMutation.3 \
Algorithm::Evolutionary::Op::Uniform_Crossover.3 \
diff --git a/devel/p5-Algorithm-Evolutionary/distinfo b/devel/p5-Algorithm-Evolutionary/distinfo
index 3e5f0b39db01..dfacc36c2e7d 100644
--- a/devel/p5-Algorithm-Evolutionary/distinfo
+++ b/devel/p5-Algorithm-Evolutionary/distinfo
@@ -1,3 +1,3 @@
-MD5 (Algorithm-Evolutionary-0.67.tar.gz) = 428c5c1e05468f7059a81ab5b574a5b0
-SHA256 (Algorithm-Evolutionary-0.67.tar.gz) = 69329c5129654e98af21ce2a1fb85cdbf2354bacb3468694bcdcbe16cff0734e
-SIZE (Algorithm-Evolutionary-0.67.tar.gz) = 79724
+MD5 (Algorithm-Evolutionary-0.70.tar.gz) = 8c7513e7c4d1ea2b17616871754ed4b1
+SHA256 (Algorithm-Evolutionary-0.70.tar.gz) = 947ee8c316cacbb67971f5dc545fa045265e31e73fe6f409273fb1ef281869ad
+SIZE (Algorithm-Evolutionary-0.70.tar.gz) = 94035
diff --git a/devel/p5-Algorithm-Evolutionary/pkg-plist b/devel/p5-Algorithm-Evolutionary/pkg-plist
index 0ee1569134bb..a588361e9834 100644
--- a/devel/p5-Algorithm-Evolutionary/pkg-plist
+++ b/devel/p5-Algorithm-Evolutionary/pkg-plist
@@ -2,8 +2,10 @@
bin/canonical-genetic-algorithm.pl
bin/tide_bitstring.pl
bin/tide_float.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary/.packlist
%%SITE_PERL%%/Algorithm/Evolutionary.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Experiment.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Any.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Base.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/ECC.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Knapsack.pm
@@ -12,6 +14,8 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/P_Peaks.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Royal_Road.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/String.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Trap.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/ZDT1.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/wP_Peaks.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Any.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Base.pm
@@ -20,6 +24,7 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/String.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Tree.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Vector.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/Animated_GIF_Output.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/ArithCrossover.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Base.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Bitflip.pm
@@ -31,6 +36,9 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Crossover.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/DeltaTerm.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Easy.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/Easy_MO.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/Eval/General.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/Eval/MO_Rank.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/FullAlgorithm.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/GaussianMutation.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Gene_Boundary_Crossover.pm
@@ -44,12 +52,14 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Op/NoChangeTerm.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Novelty_Mutation.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Permutation.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/Population_Output.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/QuadXOver.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Replace_Worst.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/RouletteWheel.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Selector.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/SimulatedAnnealing.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Storing.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/StringRand.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/TournamentSelect.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/TreeMutation.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Uniform_Crossover.pm
@@ -58,12 +68,12 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Utils.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Wheel.pm
%%SITE_PERL%%/Algorithm/Evolutionary/XML.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Op/Eval
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Op
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Individual
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Fitness
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary
@dirrmtry %%SITE_PERL%%/Algorithm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto