aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Attribute-Persistent
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-01-05 15:30:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-01-05 15:30:41 +0000
commite1ab1b7efb833d1769ae33dd9644d51cf18926a2 (patch)
tree0dd8384b8418b861121ef96a168e876c8732d509 /devel/p5-Attribute-Persistent
parenta9c91c280d25a62fb60f52b5a60dc32bc77538b2 (diff)
downloadports-e1ab1b7efb833d1769ae33dd9644d51cf18926a2.tar.gz
ports-e1ab1b7efb833d1769ae33dd9644d51cf18926a2.zip
Add p5-Attribute-Persistent 1.0
Attribute::Persistent - Really lazy persistence.
Notes
Notes: svn path=/head/; revision=97354
Diffstat (limited to 'devel/p5-Attribute-Persistent')
-rw-r--r--devel/p5-Attribute-Persistent/Makefile32
-rw-r--r--devel/p5-Attribute-Persistent/distinfo1
-rw-r--r--devel/p5-Attribute-Persistent/pkg-descr12
-rw-r--r--devel/p5-Attribute-Persistent/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-Attribute-Persistent/Makefile b/devel/p5-Attribute-Persistent/Makefile
new file mode 100644
index 000000000000..b6f8cb5bf7b1
--- /dev/null
+++ b/devel/p5-Attribute-Persistent/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Attribute-Persistent
+# Date created: 5 Jan 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Attribute-Persistent
+PORTVERSION= 1.0
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Attribute
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Attribute::Persistent - Really lazy persistence
+
+BUILD_DEPENDS= ${SITE_PERL}/Attribute/Handlers/Prospective.pm:${PORTSDIR}/devel/p5-Attribute-Handlers-Prospective \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM
+
+PERL_CONFIGURE= yes
+
+MAN3= Attribute::Persistent.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= Need perl 5.6.1, try installing lang/perl5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Attribute-Persistent/distinfo b/devel/p5-Attribute-Persistent/distinfo
new file mode 100644
index 000000000000..72c3b32bf906
--- /dev/null
+++ b/devel/p5-Attribute-Persistent/distinfo
@@ -0,0 +1 @@
+MD5 (Attribute-Persistent-1.0.tar.gz) = 04253a2788a686d26cb2b428a92071b1
diff --git a/devel/p5-Attribute-Persistent/pkg-descr b/devel/p5-Attribute-Persistent/pkg-descr
new file mode 100644
index 000000000000..c23c839aad6b
--- /dev/null
+++ b/devel/p5-Attribute-Persistent/pkg-descr
@@ -0,0 +1,12 @@
+This module provides a way of abstracting away persistence of array and hash
+variables.
+
+It's useful for quick hacks when you don't care about pulling in the right DBM
+library and calling tie and so on. Its job is to reduce fuss for the lazy
+programmer at the cost of flexibility.
+
+It uses MLDBM, so you can use complex data structures in your arrays and
+hashes. It uses AnyDBM_File, so if you really care about which DBM you get, you
+can modify AnyDBM_File::ISA in a BEGIN block after loading this module.
+
+WWW: http://search.cpan.org/dist/Attribute-Persistent/
diff --git a/devel/p5-Attribute-Persistent/pkg-plist b/devel/p5-Attribute-Persistent/pkg-plist
new file mode 100644
index 000000000000..b4f7a9f9fb0e
--- /dev/null
+++ b/devel/p5-Attribute-Persistent/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Attribute/Persistent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Attribute/Persistent/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Attribute/Persistent
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Attribute 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Attribute 2>/dev/null || true