aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Carp-Assert-More
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-14 04:57:35 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-14 04:57:35 +0000
commitaddbc6f7790d9accc915184ccb044e20ff7f417e (patch)
treee6ad935de17722840c55b885076d3a286e56483c /devel/p5-Carp-Assert-More
parent6c1d55ba97609d5463b770e2c2c0ed184e24d571 (diff)
downloadports-addbc6f7790d9accc915184ccb044e20ff7f417e.tar.gz
ports-addbc6f7790d9accc915184ccb044e20ff7f417e.zip
Adding port devel/p5-Carp-Assert-More, Convenience wrappers around
Carp::Assert. Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=165366
Diffstat (limited to 'devel/p5-Carp-Assert-More')
-rw-r--r--devel/p5-Carp-Assert-More/Makefile34
-rw-r--r--devel/p5-Carp-Assert-More/distinfo3
-rw-r--r--devel/p5-Carp-Assert-More/pkg-descr20
-rw-r--r--devel/p5-Carp-Assert-More/pkg-plist7
4 files changed, 64 insertions, 0 deletions
diff --git a/devel/p5-Carp-Assert-More/Makefile b/devel/p5-Carp-Assert-More/Makefile
new file mode 100644
index 000000000000..200e52803bf8
--- /dev/null
+++ b/devel/p5-Carp-Assert-More/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Carp-Assert-More
+# Date created: 13 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Carp-Assert-More
+PORTVERSION= 1.12
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Carp
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Convenience wrappers around Carp::Assert
+
+BUILD_DEPENDS= ${SITE_PERL}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Carp::Assert::More.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from devel/p5-Test-Exception
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Carp-Assert-More/distinfo b/devel/p5-Carp-Assert-More/distinfo
new file mode 100644
index 000000000000..bf01fb0575f5
--- /dev/null
+++ b/devel/p5-Carp-Assert-More/distinfo
@@ -0,0 +1,3 @@
+MD5 (Carp-Assert-More-1.12.tar.gz) = dbd6a0fcbff5f00d2e39b77322036d3f
+SHA256 (Carp-Assert-More-1.12.tar.gz) = d9d3312aa99f036eab24a5e195ea6796a24c5a8135310b451f408350c13733d5
+SIZE (Carp-Assert-More-1.12.tar.gz) = 8371
diff --git a/devel/p5-Carp-Assert-More/pkg-descr b/devel/p5-Carp-Assert-More/pkg-descr
new file mode 100644
index 000000000000..d9b5c0869cd7
--- /dev/null
+++ b/devel/p5-Carp-Assert-More/pkg-descr
@@ -0,0 +1,20 @@
+Carp::Assert::More is a set of wrappers around the Carp::Assert functions
+to make the habit of writing assertions even easier.
+
+Everything in here is effectively syntactic sugar. There's no technical
+reason to use
+
+ assert_isa( $foo, 'HTML::Lint' );
+
+instead of
+
+ assert( defined $foo );
+ assert( ref($foo) eq 'HTML::Lint' );
+
+other than readability and simplicity of the code.
+
+My intent here is to make common assertions easy so that we as programmers
+have no excuse to not use them.
+
+WWW: http://search.cpan.org/dist/Carp-Assert-More
+Author: Andy Lester
diff --git a/devel/p5-Carp-Assert-More/pkg-plist b/devel/p5-Carp-Assert-More/pkg-plist
new file mode 100644
index 000000000000..09418f4ddab1
--- /dev/null
+++ b/devel/p5-Carp-Assert-More/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Carp/Assert/More.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Assert/More/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Assert/More
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp/Assert
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Carp
+@dirrmtry %%SITE_PERL%%/Carp/Assert
+@dirrmtry %%SITE_PERL%%/Carp