aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Container/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-02-20 16:33:26 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-02-20 16:33:26 +0000
commit628b215647a7f7c1e3232ad55bb67fd7cbdb9f14 (patch)
tree9dee99152b7b92fefea393e2a79a64b07ab74dff /devel/p5-Class-Container/Makefile
parent029b209d330e5082cbae2c7100c55eed692fafd2 (diff)
downloadports-628b215647a7f7c1e3232ad55bb67fd7cbdb9f14.tar.gz
ports-628b215647a7f7c1e3232ad55bb67fd7cbdb9f14.zip
Conditionalise several dependencies on PERL_LEVEL to make those ports more
friendly for perl-5.8.0, which has those dependencies included into the base distribution. Sponsired by: Porta Software Ltd
Notes
Notes: svn path=/head/; revision=75949
Diffstat (limited to 'devel/p5-Class-Container/Makefile')
-rw-r--r--devel/p5-Class-Container/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/p5-Class-Container/Makefile b/devel/p5-Class-Container/Makefile
index 1dc04220e20d..1b5d1ef99249 100644
--- a/devel/p5-Class-Container/Makefile
+++ b/devel/p5-Class-Container/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dsh@vlink.ru
-BUILD_DEPENDS= ${SITE_PERL}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+BUILD_DEPENDS= ${SITE_PERL}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -24,4 +23,10 @@ MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Class::Container.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>