aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Tom
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-01 09:32:01 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-01 09:32:01 +0000
commit4595cbf4682065d5406c765cb08195ad23cf24f8 (patch)
tree581e1012b3371227d5ac83010277c740cb756877 /devel/p5-Class-Tom
parent6e7bc489adf94def9b9659a0e0725e50cce75857 (diff)
downloadports-4595cbf4682065d5406c765cb08195ad23cf24f8.tar.gz
ports-4595cbf4682065d5406c765cb08195ad23cf24f8.zip
Add p5-Class-Tom 3.02, a perl module to transport objects from one system to
another.
Notes
Notes: svn path=/head/; revision=36561
Diffstat (limited to 'devel/p5-Class-Tom')
-rw-r--r--devel/p5-Class-Tom/Makefile29
-rw-r--r--devel/p5-Class-Tom/distinfo1
-rw-r--r--devel/p5-Class-Tom/pkg-comment1
-rw-r--r--devel/p5-Class-Tom/pkg-descr7
-rw-r--r--devel/p5-Class-Tom/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-Class-Tom/Makefile b/devel/p5-Class-Tom/Makefile
new file mode 100644
index 000000000000..9f31b84ed559
--- /dev/null
+++ b/devel/p5-Class-Tom/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Class::Tom
+# Date created: 04 Nov 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Tom
+PORTVERSION= 3.02
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
+ ${SITE_PERL}/${PERL_ARCH}/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+
+SITE_PERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/
+USE_PERL5= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Tom/distinfo b/devel/p5-Class-Tom/distinfo
new file mode 100644
index 000000000000..456e3cfc3064
--- /dev/null
+++ b/devel/p5-Class-Tom/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Tom-3.02.tar.gz) = aca8186d708b94786bb4cdf2757c94e5
diff --git a/devel/p5-Class-Tom/pkg-comment b/devel/p5-Class-Tom/pkg-comment
new file mode 100644
index 000000000000..0874063a02b8
--- /dev/null
+++ b/devel/p5-Class-Tom/pkg-comment
@@ -0,0 +1 @@
+A perl module to transport objects from one system to another
diff --git a/devel/p5-Class-Tom/pkg-descr b/devel/p5-Class-Tom/pkg-descr
new file mode 100644
index 000000000000..ebab88c84db5
--- /dev/null
+++ b/devel/p5-Class-Tom/pkg-descr
@@ -0,0 +1,7 @@
+Class::Tom is a perl module that allows you to transport objects from
+one system to another without requiring that the packages the object
+relies on actually exist on the other machine.
+
+Author: James A. Duncan <j@mesduncan.co.uk>
+
+--will
diff --git a/devel/p5-Class-Tom/pkg-plist b/devel/p5-Class-Tom/pkg-plist
new file mode 100644
index 000000000000..92329d9ec3fa
--- /dev/null
+++ b/devel/p5-Class-Tom/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Class/Tom/Encode.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Tom/Encode/Base64.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Tom/Code.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Tom.pm
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/Class/Tom/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class/Tom/Encode
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class/Tom
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class