aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Clone/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-06-05 21:51:26 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-06-05 21:51:26 +0000
commit21cc81d968c53cb3e94b011f98c8c89fecba1a85 (patch)
tree594d16f62383ea67a1ef942c73628f2a583e7986 /devel/p5-Clone/Makefile
parent8520c5964fc4c8a2ede8f78bea2d900168507944 (diff)
downloadports-21cc81d968c53cb3e94b011f98c8c89fecba1a85.tar.gz
ports-21cc81d968c53cb3e94b011f98c8c89fecba1a85.zip
Add p5-Clone, a perl module to recursively copy Perl datatypes.
Notes
Notes: svn path=/head/; revision=60665
Diffstat (limited to 'devel/p5-Clone/Makefile')
-rw-r--r--devel/p5-Clone/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Clone/Makefile b/devel/p5-Clone/Makefile
new file mode 100644
index 000000000000..d9d91a51fa39
--- /dev/null
+++ b/devel/p5-Clone/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Clone
+# Date created: 05 June 2002
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Clone
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Clone
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Clone.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ ${PERL} -pi -e 'm.OPTIMIZE.&&s,.,,sg' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>