aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Coro/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-11 13:17:31 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-11 13:17:31 +0000
commitd92f8ffc2f4a0304fa853e88dfb6a63a065ccf3e (patch)
tree3a7cebe3ea561c5e91f937e3665ab28eb86c360e /devel/p5-Coro/Makefile
parent1f1a3ea8d04d5ff03590e0e001ad31993b9a08ee (diff)
downloadports-d92f8ffc2f4a0304fa853e88dfb6a63a065ccf3e.tar.gz
ports-d92f8ffc2f4a0304fa853e88dfb6a63a065ccf3e.zip
Update to 1.7 (which is >1.11, strangely enough, so PORTEPOCH++).
Notes
Notes: svn path=/head/; revision=153261
Diffstat (limited to 'devel/p5-Coro/Makefile')
-rw-r--r--devel/p5-Coro/Makefile40
1 files changed, 21 insertions, 19 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index 97eb0836b40d..3c712af27d72 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= Coro
-PORTVERSION= 1.11
+PORTVERSION= 1.7
+PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Coro
@@ -15,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Coro - coroutine process abstraction for perl
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
+BUILD_DEPENDS= p5-Event>=0.89:${PORTSDIR}/devel/p5-Event \
${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -37,24 +38,25 @@ post-install:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= "This port requires perl 5.6 or newer"
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
.endif
-MAN3= Coro.3 \
- Coro::Channel.3 \
- Coro::Cont.3 \
- Coro::Event.3 \
- Coro::Handle.3 \
- Coro::MakeMaker.3 \
- Coro::RWLock.3 \
- Coro::Select.3 \
- Coro::Semaphore.3 \
- Coro::SemaphoreSet.3 \
- Coro::Signal.3 \
- Coro::Socket.3 \
- Coro::Specific.3 \
- Coro::State.3 \
- Coro::Timer.3 \
- Coro::Util.3
+MAN3= Coro.3 \
+ Coro::AIO.3 \
+ Coro::Channel.3 \
+ Coro::Cont.3 \
+ Coro::Event.3 \
+ Coro::Handle.3 \
+ Coro::MakeMaker.3 \
+ Coro::RWLock.3 \
+ Coro::Select.3 \
+ Coro::Semaphore.3 \
+ Coro::SemaphoreSet.3 \
+ Coro::Signal.3 \
+ Coro::Socket.3 \
+ Coro::Specific.3 \
+ Coro::State.3 \
+ Coro::Timer.3 \
+ Coro::Util.3
.include <bsd.port.post.mk>