aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DB_File-Lock/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-08-16 02:05:51 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-08-16 02:05:51 +0000
commit54b5ff2c6a75a05566dba4064383d8732dccd782 (patch)
tree45d3642433fadbb48868a0360409e2f3e002e216 /devel/p5-DB_File-Lock/Makefile
parent6b10ccc38e6a098ea4fe5ae607c268c5b258e31d (diff)
downloadports-54b5ff2c6a75a05566dba4064383d8732dccd782.tar.gz
ports-54b5ff2c6a75a05566dba4064383d8732dccd782.zip
Add devel/p5-DB_File-Lock, a wrapper for the DB_File module, adding
locking, extremely lightweight. This module provides the similar functionality to Tie::DB_LockFile, but also supports DB_RECNO. Reviewed by: knu (mentor) Approved by: knu (mentor)
Notes
Notes: svn path=/head/; revision=64561
Diffstat (limited to 'devel/p5-DB_File-Lock/Makefile')
-rw-r--r--devel/p5-DB_File-Lock/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/p5-DB_File-Lock/Makefile b/devel/p5-DB_File-Lock/Makefile
new file mode 100644
index 000000000000..6dee99dfc20a
--- /dev/null
+++ b/devel/p5-DB_File-Lock/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-DB_File-Lock
+# Date created: 2002/08/15
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= DB_File-Lock
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DB_File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= DB_File::Lock.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>