aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Throttler
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 13:15:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 13:15:58 +0000
commit1ee8bb104aedf8b6d4fc985f1713a001daf7c7a2 (patch)
treec97cff1ea2e409708a174b6dcaf8aaf447c03d6c /devel/p5-Data-Throttler
parent5d703fb5bc292c3f64179abd0bfc7744f91baaaf (diff)
downloadports-1ee8bb104aedf8b6d4fc985f1713a001daf7c7a2.tar.gz
ports-1ee8bb104aedf8b6d4fc985f1713a001daf7c7a2.zip
Data::Throttler helps solving throttling tasks like "allow a single IP
only to send 100 emails per hour". It provides an optionally persistent data store to keep track of what happened before and offers a simple yes/no interface to an application, which can then focus on performing the actual task (like sending email) or suppressing/postponing it. WWW: http://search.cpan.org/dist/Data-Throttler/ PR: ports/120156 Submitted by: Masahiro Teramoto <markun at onohara.to>
Notes
Notes: svn path=/head/; revision=207317
Diffstat (limited to 'devel/p5-Data-Throttler')
-rw-r--r--devel/p5-Data-Throttler/Makefile30
-rw-r--r--devel/p5-Data-Throttler/distinfo3
-rw-r--r--devel/p5-Data-Throttler/pkg-descr9
-rw-r--r--devel/p5-Data-Throttler/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Data-Throttler/Makefile b/devel/p5-Data-Throttler/Makefile
new file mode 100644
index 000000000000..163bacb189a2
--- /dev/null
+++ b/devel/p5-Data-Throttler/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Data-Throttler
+# Date created: 2008-01-30
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Throttler
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= Limit data throughput
+
+BUILD_DEPENDS= p5-DBM-Deep>=1.0001:${PORTSDIR}/databases/p5-DBM-Deep \
+ p5-Log-Log4perl>=1:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Set-IntSpan>=0:${PORTSDIR}/math/p5-Set-IntSpan \
+ p5-Text-ASCIITable>=0:${PORTSDIR}/textproc/p5-Text-ASCIITable
+RUN_DEPENDS= p5-DBM-Deep>=1.0001:${PORTSDIR}/databases/p5-DBM-Deep \
+ p5-Log-Log4perl>=1:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Set-IntSpan>=0:${PORTSDIR}/math/p5-Set-IntSpan \
+ p5-Text-ASCIITable>=0:${PORTSDIR}/textproc/p5-Text-ASCIITable
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Throttler.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Throttler/distinfo b/devel/p5-Data-Throttler/distinfo
new file mode 100644
index 000000000000..50752bddd930
--- /dev/null
+++ b/devel/p5-Data-Throttler/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Throttler-0.01.tar.gz) = 393a796a37c5613ee8878dc95c4d7a79
+SHA256 (Data-Throttler-0.01.tar.gz) = 6968bd5f01b2ffdad3cf0b5addbcc399aa7441b0dde95f30443d36390001d525
+SIZE (Data-Throttler-0.01.tar.gz) = 6723
diff --git a/devel/p5-Data-Throttler/pkg-descr b/devel/p5-Data-Throttler/pkg-descr
new file mode 100644
index 000000000000..06b5bdbbbfd2
--- /dev/null
+++ b/devel/p5-Data-Throttler/pkg-descr
@@ -0,0 +1,9 @@
+Data::Throttler helps solving throttling tasks like "allow a single IP
+only to send 100 emails per hour".
+
+It provides an optionally persistent data store to keep track of
+what happened before and offers a simple yes/no interface to an application,
+which can then focus on performing the actual task (like sending email)
+or suppressing/postponing it.
+
+WWW: http://search.cpan.org/dist/Data-Throttler/
diff --git a/devel/p5-Data-Throttler/pkg-plist b/devel/p5-Data-Throttler/pkg-plist
new file mode 100644
index 000000000000..aa49f752d272
--- /dev/null
+++ b/devel/p5-Data-Throttler/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Throttler/.packlist
+%%SITE_PERL%%/Data/Throttler.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Throttler
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data