aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Eval-WithLexicals/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2013-05-26 07:15:17 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2013-05-26 07:15:17 +0000
commita32f8fde3ce7adefa8456bbefc01b82aed16bd65 (patch)
tree4f740c95a92783c8abadea6c1a7109c05aafe1b7 /devel/p5-Eval-WithLexicals/Makefile
parentb53a0fc556dedacd138d2f068d00b8cc1891fe06 (diff)
downloadports-a32f8fde3ce7adefa8456bbefc01b82aed16bd65.tar.gz
ports-a32f8fde3ce7adefa8456bbefc01b82aed16bd65.zip
Pure perl eval with persistent lexical variables.
Notes
Notes: svn path=/head/; revision=319094
Diffstat (limited to 'devel/p5-Eval-WithLexicals/Makefile')
-rw-r--r--devel/p5-Eval-WithLexicals/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/p5-Eval-WithLexicals/Makefile b/devel/p5-Eval-WithLexicals/Makefile
new file mode 100644
index 000000000000..f46fd4b426f0
--- /dev/null
+++ b/devel/p5-Eval-WithLexicals/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= Eval-WithLexicals
+PORTVERSION= 1.002000
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DGL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for pure perl eval with persistent lexical variables
+
+RUN_DEPENDS= \
+ p5-Moo>=0.009006:${PORTSDIR}/devel/p5-Moo
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Eval::WithLexicals.3 \
+ Eval::WithLexicals::WithHintPersistence.3
+
+.include <bsd.port.mk>