aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Every/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2008-09-05 09:24:52 +0000
committerAnton Berezin <tobez@FreeBSD.org>2008-09-05 09:24:52 +0000
commitc1726e1be2cef861cd620279727729afec090728 (patch)
tree45e49453ee3ed6ba7ee13abdfb1cda0a02ded975 /devel/p5-Every/Makefile
parentcad2a657d9b955458da54940f0e015da1ff74974 (diff)
downloadports-c1726e1be2cef861cd620279727729afec090728.tar.gz
ports-c1726e1be2cef861cd620279727729afec090728.zip
Add devel/p5-Every, a Perl module that provides a function that returns
true every N cycles or S seconds.
Notes
Notes: svn path=/head/; revision=219890
Diffstat (limited to 'devel/p5-Every/Makefile')
-rw-r--r--devel/p5-Every/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-Every/Makefile b/devel/p5-Every/Makefile
new file mode 100644
index 000000000000..3ae553887e40
--- /dev/null
+++ b/devel/p5-Every/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: devel/p5-Every
+# Date created: 05 September 2008
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Every
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/T/TE/TEODOR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Return true every N cycles or S seconds
+
+BUILD_DEPENDS= p5-Devel-Callsite>0:${PORTSDIR}/devel/p5-Devel-Callsite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Every.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>