aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-BaseDir
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-08-22 11:28:39 +0000
committerLars Thegler <lth@FreeBSD.org>2004-08-22 11:28:39 +0000
commit624119f5e548790080a3c9bb1489bc31b413d04a (patch)
tree7b196a7ca040b15ee51e5f81aefa517e06b06ab7 /devel/p5-File-BaseDir
parente59fb64cbf9731733d1fa5583f48b8a02d43f298 (diff)
downloadports-624119f5e548790080a3c9bb1489bc31b413d04a.tar.gz
ports-624119f5e548790080a3c9bb1489bc31b413d04a.zip
Add p5-File-BaseDir 0.02, use the freedesktop basedir spec.
PR: 70768 Submitted by: Rong-En Fan <rafan@infor.org>
Notes
Notes: svn path=/head/; revision=117015
Diffstat (limited to 'devel/p5-File-BaseDir')
-rw-r--r--devel/p5-File-BaseDir/Makefile26
-rw-r--r--devel/p5-File-BaseDir/distinfo2
-rw-r--r--devel/p5-File-BaseDir/files/500503-BaseDir.pm39
-rw-r--r--devel/p5-File-BaseDir/pkg-descr10
-rw-r--r--devel/p5-File-BaseDir/pkg-plist5
5 files changed, 82 insertions, 0 deletions
diff --git a/devel/p5-File-BaseDir/Makefile b/devel/p5-File-BaseDir/Makefile
new file mode 100644
index 000000000000..7e5bda2d3572
--- /dev/null
+++ b/devel/p5-File-BaseDir/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-File-BaseDir
+# Date created: Aug 21 2004
+# Whom: Rong-En Fan <rafan@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-BaseDir
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/P/PA/PARDUS/${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@infor.org
+COMMENT= Use the freedesktop basedir spec
+
+PERL_CONFIGURE= yes
+
+MAN3= File::BaseDir.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+EXTRA_PATCHES= ${PATCHDIR}/500503-*
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-BaseDir/distinfo b/devel/p5-File-BaseDir/distinfo
new file mode 100644
index 000000000000..f8283baea626
--- /dev/null
+++ b/devel/p5-File-BaseDir/distinfo
@@ -0,0 +1,2 @@
+MD5 (File-BaseDir-0.02.tar.gz) = 00e2729f364d430350355250cb9007e0
+SIZE (File-BaseDir-0.02.tar.gz) = 2462
diff --git a/devel/p5-File-BaseDir/files/500503-BaseDir.pm b/devel/p5-File-BaseDir/files/500503-BaseDir.pm
new file mode 100644
index 000000000000..53fea3885f2f
--- /dev/null
+++ b/devel/p5-File-BaseDir/files/500503-BaseDir.pm
@@ -0,0 +1,39 @@
+--- BaseDir.pm.orig Sun Aug 22 11:18:29 2004
++++ BaseDir.pm Sun Aug 22 11:20:04 2004
+@@ -5,26 +5,28 @@
+ require File::Spec;
+ require Exporter;
+
+-our @ISA = qw(Exporter);
+-our @EXPORT_OK = qw(
++use vars qw(@ISA @EXPORT_OK $VERSION);
++@ISA = qw(Exporter);
++@EXPORT_OK = qw(
+ xdg_data_home xdg_data_dirs xdg_data_files
+ xdg_config_home xdg_config_dirs xdg_config_files
+ xdg_cache_home
+ );
+-our $VERSION = 0.02;
++$VERSION = 0.02;
+
+ my $rootdir = File::Spec->rootdir();
+
+-our $xdg_data_home = File::Spec->catdir($ENV{HOME}, qw/.local share/);
+-our @xdg_data_dirs = (
++use vars qw($xdg_data_home @xdg_data_dirs $xdg_config_home @xdg_config_dirs $xdg_cache_home);
++$xdg_data_home = File::Spec->catdir($ENV{HOME}, qw/.local share/);
++@xdg_data_dirs = (
+ File::Spec->catdir($rootdir, qw/usr local share/),
+ File::Spec->catdir($rootdir, qw/usr share/),
+ );
+
+-our $xdg_config_home = File::Spec->catdir($ENV{HOME}, '.config');
+-our @xdg_config_dirs = ( File::Spec->catdir($rootdir, qw/etc xdg/) );
++$xdg_config_home = File::Spec->catdir($ENV{HOME}, '.config');
++@xdg_config_dirs = ( File::Spec->catdir($rootdir, qw/etc xdg/) );
+
+-our $xdg_cache_home = File::Spec->catdir($ENV{HOME}, '.cache');
++$xdg_cache_home = File::Spec->catdir($ENV{HOME}, '.cache');
+
+ sub new { bless \$VERSION, shift } # what else is there to bless ?
+
diff --git a/devel/p5-File-BaseDir/pkg-descr b/devel/p5-File-BaseDir/pkg-descr
new file mode 100644
index 000000000000..dd1ef703bb5f
--- /dev/null
+++ b/devel/p5-File-BaseDir/pkg-descr
@@ -0,0 +1,10 @@
+This module can be used to find directories and files as
+specified by the XDG Base Directory Specification. It takes
+care of defaults and uses File::Spec to make the output
+platform specific.
+
+This module forked from File::MimeInfo.
+
+For this module the XDG basedir specification 0.6 was used.
+
+WWW: http://search.cpan.org/dist/File-BaseDir/
diff --git a/devel/p5-File-BaseDir/pkg-plist b/devel/p5-File-BaseDir/pkg-plist
new file mode 100644
index 000000000000..5ad86709737c
--- /dev/null
+++ b/devel/p5-File-BaseDir/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/BaseDir.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/BaseDir/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/BaseDir 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true