aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-HStore
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2008-06-03 15:27:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2008-06-03 15:27:48 +0000
commit0781048dbf4081cb0fe37058e921d62ab010a9f4 (patch)
tree654c6c814a75da0763f9e957733175d05304a443 /devel/p5-File-HStore
parent9fa7bac19c53ca836b99c6f871c314df3aeb6c94 (diff)
downloadports-0781048dbf4081cb0fe37058e921d62ab010a9f4.tar.gz
ports-0781048dbf4081cb0fe37058e921d62ab010a9f4.zip
Update to 0.10
Notes
Notes: svn path=/head/; revision=214259
Diffstat (limited to 'devel/p5-File-HStore')
-rw-r--r--devel/p5-File-HStore/Makefile6
-rw-r--r--devel/p5-File-HStore/distinfo6
-rw-r--r--devel/p5-File-HStore/files/patch-HStore.pm61
-rw-r--r--devel/p5-File-HStore/files/patch-Makefile.PL12
4 files changed, 4 insertions, 81 deletions
diff --git a/devel/p5-File-HStore/Makefile b/devel/p5-File-HStore/Makefile
index 1486d59500d4..acdc030a666f 100644
--- a/devel/p5-File-HStore/Makefile
+++ b/devel/p5-File-HStore/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= File-HStore
-PORTVERSION= 0.09
-PORTREVISION= 1
+PORTVERSION= 0.10
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -21,7 +20,4 @@ PERL_CONFIGURE= yes
MAN3= File::HStore.3
-post-patch:
- @${RM} ${WRKSRC}/lib/File/HStore.pm.orig
-
.include <bsd.port.mk>
diff --git a/devel/p5-File-HStore/distinfo b/devel/p5-File-HStore/distinfo
index b234fbceddd4..54b26cb86e2e 100644
--- a/devel/p5-File-HStore/distinfo
+++ b/devel/p5-File-HStore/distinfo
@@ -1,3 +1,3 @@
-MD5 (File-HStore-0.09.tar.gz) = 271f3f2dfc0fa4e237bd82bbbd68ee49
-SHA256 (File-HStore-0.09.tar.gz) = 5fff377d1506b05020793b54cfb52a87dff0bc9155e564fdb1e7af8a05ca645f
-SIZE (File-HStore-0.09.tar.gz) = 5164
+MD5 (File-HStore-0.10.tar.gz) = e8520b06a07df9242d0da630cb7279eb
+SHA256 (File-HStore-0.10.tar.gz) = c2fd592290fb2c593600427453287dd04fd350fa3a1b375a789945ae75ade1e7
+SIZE (File-HStore-0.10.tar.gz) = 5526
diff --git a/devel/p5-File-HStore/files/patch-HStore.pm b/devel/p5-File-HStore/files/patch-HStore.pm
deleted file mode 100644
index 91c65aa7eb92..000000000000
--- a/devel/p5-File-HStore/files/patch-HStore.pm
+++ /dev/null
@@ -1,61 +0,0 @@
---- ../File-HStore-0.09-original/lib/File/HStore.pm Sun Nov 26 11:43:50 2006
-+++ lib/File/HStore.pm Tue Jul 17 18:24:13 2007
-@@ -2,8 +2,7 @@
-
- use strict;
- use warnings;
--use Digest::SHA1;
--use Digest::SHA2;
-+use Digest::SHA;
- use File::Copy;
- use File::Path;
-
-@@ -69,7 +68,7 @@
- my $lSubmitDate;
-
- if ( $self->{digest} eq "FAT" ) {
-- $ldigest = "SHA2";
-+ $ldigest = "sha256";
- }
- else {
- $ldigest = $self->{digest};
-@@ -191,10 +190,10 @@
- my $sha;
- open( FILED, "$file" ) or die "Unable to open file $file";
- if ( $digestdef eq "SHA1" ) {
-- $sha = Digest::SHA1->new;
-+ $sha = Digest::SHA->new("sha1");
- }
- elsif ( $digestdef eq "SHA2" ) {
-- $sha = Digest::SHA2->new;
-+ $sha = Digest::SHA->new("sha256");
- }
- else {
- print "unknown digest method";
-@@ -242,7 +241,7 @@
-
- use File::HStore;
- my $store = File::HStore ("/tmp/.mystore");
--
-+
- # Add a file in the store
- my $id = $store->add("/foo/bar.txt");
-
-@@ -272,7 +271,7 @@
- =head1 METHODS
-
- The object oriented interface to C<File::HFile> is described in this
--section.
-+section.
-
- The following methods are provided:
-
-@@ -302,7 +301,7 @@
-
- =item $store->remove($hashvalue)
-
--The $hashvalue is the file to be removed from the store.
-+The $hashvalue is the file to be removed from the store.
-
- Return false on success and undef on error.
-
diff --git a/devel/p5-File-HStore/files/patch-Makefile.PL b/devel/p5-File-HStore/files/patch-Makefile.PL
deleted file mode 100644
index a72f00db37f6..000000000000
--- a/devel/p5-File-HStore/files/patch-Makefile.PL
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../File-HStore-0.09-original/Makefile.PL Sun Nov 26 11:05:53 2006
-+++ Makefile.PL Tue Jul 17 18:08:11 2007
-@@ -5,8 +5,7 @@
- WriteMakefile(
- NAME => 'File::HStore',
- VERSION_FROM => 'lib/File/HStore.pm', # finds $VERSION
-- PREREQ_PM => { 'Digest::SHA1' => '0',
-- 'Digest::SHA2' => '0',
-+ PREREQ_PM => { 'Digest::SHA' => '0',
- 'File::Copy' => '0',
- 'Test::More' => '0',
- 'File::Path' => '0' }, # e.g., Module::Name => 1.1