aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Modified/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-07-08 12:18:07 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-07-08 12:18:07 +0000
commit5fdb1d332d2447fa0fe9729b3863a8967001c4d0 (patch)
tree6023da295d2e8d7f3522cfde3d5c2b9a84e5b96d /devel/p5-File-Modified/Makefile
parent81593e6fc3765c141cc26d670f650ee969f4030c (diff)
downloadports-5fdb1d332d2447fa0fe9729b3863a8967001c4d0.tar.gz
ports-5fdb1d332d2447fa0fe9729b3863a8967001c4d0.zip
Add devel/p5-File-Modified, a Perl module for checking intelligently if
files have changed.
Notes
Notes: svn path=/head/; revision=113212
Diffstat (limited to 'devel/p5-File-Modified/Makefile')
-rw-r--r--devel/p5-File-Modified/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-File-Modified/Makefile b/devel/p5-File-Modified/Makefile
new file mode 100644
index 000000000000..2283ce7385ee
--- /dev/null
+++ b/devel/p5-File-Modified/Makefile
@@ -0,0 +1,30 @@
+# New Ports Collection Makefile for: p5-File-Modified
+# Date created: 2004-07-08
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= File-Modified
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module for checking intelligently if files have changed
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Modified.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${PERL} -pi -e 's/\r\n/\n/;' -e 's/^use warnings;//' ${WRKSRC}/Modified.pm
+
+.include <bsd.port.post.mk>