aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Path-Tiny
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-10-20 08:17:42 +0000
committerWen Heping <wen@FreeBSD.org>2010-10-20 08:17:42 +0000
commit610fcf35e913581f43a7523666afd30481ada1ec (patch)
tree34e6c0862b41eee51c8b8ed8f84e5db8769c687c /devel/p5-File-Path-Tiny
parent3c17ca5e06c5cf637432dc97984c450e33d86e05 (diff)
downloadports-610fcf35e913581f43a7523666afd30481ada1ec.tar.gz
ports-610fcf35e913581f43a7523666afd30481ada1ec.zip
Provides recursive versions of mkdir() and rmdir()
with as little code and overhead as possible. WWW: http://search.cpan.org/dist/File-Path-Tiny/ PR: ports/151588 Submitted by: "ports@c0decafe.net" <ports@c0decafe.net>
Notes
Notes: svn path=/head/; revision=263334
Diffstat (limited to 'devel/p5-File-Path-Tiny')
-rw-r--r--devel/p5-File-Path-Tiny/Makefile21
-rw-r--r--devel/p5-File-Path-Tiny/distinfo3
-rw-r--r--devel/p5-File-Path-Tiny/pkg-descr4
-rw-r--r--devel/p5-File-Path-Tiny/pkg-plist9
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-File-Path-Tiny/Makefile b/devel/p5-File-Path-Tiny/Makefile
new file mode 100644
index 000000000000..c0a407d03484
--- /dev/null
+++ b/devel/p5-File-Path-Tiny/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-File-Path-Tiny
+# Date created: 2010-10-20
+# Whom: ports@c0decafe.net <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Path-Tiny
+PORTVERSION= 0.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Lightweight File::Path alternative
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Path::Tiny.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Path-Tiny/distinfo b/devel/p5-File-Path-Tiny/distinfo
new file mode 100644
index 000000000000..5ea53a4e627d
--- /dev/null
+++ b/devel/p5-File-Path-Tiny/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-Path-Tiny-0.1.tar.gz) = 3a2ac2277304b6a1c017f24c8327f55a
+SHA256 (File-Path-Tiny-0.1.tar.gz) = cb7a4d31fe42b61e406523be950acf142cab3d0e00081acd243f77ebe9ee8d37
+SIZE (File-Path-Tiny-0.1.tar.gz) = 5922
diff --git a/devel/p5-File-Path-Tiny/pkg-descr b/devel/p5-File-Path-Tiny/pkg-descr
new file mode 100644
index 000000000000..51bc7577974a
--- /dev/null
+++ b/devel/p5-File-Path-Tiny/pkg-descr
@@ -0,0 +1,4 @@
+Provides recursive versions of mkdir() and rmdir()
+with as little code and overhead as possible.
+
+WWW: http://search.cpan.org/dist/File-Path-Tiny/
diff --git a/devel/p5-File-Path-Tiny/pkg-plist b/devel/p5-File-Path-Tiny/pkg-plist
new file mode 100644
index 000000000000..f3b42a0fd5d7
--- /dev/null
+++ b/devel/p5-File-Path-Tiny/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/File/Path/Tiny.pm
+%%SITE_PERL%%/File/Path/Tiny.pod
+%%SITE_PERL%%/mach/auto/File/Path/Tiny/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Path/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File/Path
+@dirrmtry %%SITE_PERL%%/File