aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IO-Prompt
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-09-13 12:51:07 +0000
committerLars Thegler <lth@FreeBSD.org>2005-09-13 12:51:07 +0000
commitc509e5b55e61654cb105a082c7e6e5ff76906abd (patch)
treef230bcb8aeae4db5731ecb9ae7ad5cb9039b38d6 /devel/p5-IO-Prompt
parentc1f0131186baed9fba363523fd769a04b34c5bc3 (diff)
downloadports-c509e5b55e61654cb105a082c7e6e5ff76906abd.tar.gz
ports-c509e5b55e61654cb105a082c7e6e5ff76906abd.zip
Add p5-IO-Prompt 0.99.2, interactively prompt for user input.
Notes
Notes: svn path=/head/; revision=142592
Diffstat (limited to 'devel/p5-IO-Prompt')
-rw-r--r--devel/p5-IO-Prompt/Makefile36
-rw-r--r--devel/p5-IO-Prompt/distinfo2
-rw-r--r--devel/p5-IO-Prompt/pkg-descr5
-rw-r--r--devel/p5-IO-Prompt/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-IO-Prompt/Makefile b/devel/p5-IO-Prompt/Makefile
new file mode 100644
index 000000000000..94a049f8418e
--- /dev/null
+++ b/devel/p5-IO-Prompt/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: devel/p5-IO-Prompt
+# Date created: 13 September 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Prompt
+PORTVERSION= 0.99.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/D/DC/DCONWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Interactively prompt for user input
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/Want.pm:${PORTSDIR}/devel/p5-Want
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Prompt.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if m|use 5.008;|' \
+ ${WRKSRC}/lib/IO/Prompt.pm
+.endif
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IO-Prompt/distinfo b/devel/p5-IO-Prompt/distinfo
new file mode 100644
index 000000000000..5d4c38976240
--- /dev/null
+++ b/devel/p5-IO-Prompt/distinfo
@@ -0,0 +1,2 @@
+MD5 (IO-Prompt-0.99.2.tar.gz) = 4c5b5360e00ffa731bfd6badb8a15843
+SIZE (IO-Prompt-0.99.2.tar.gz) = 13627
diff --git a/devel/p5-IO-Prompt/pkg-descr b/devel/p5-IO-Prompt/pkg-descr
new file mode 100644
index 000000000000..1659ead5616b
--- /dev/null
+++ b/devel/p5-IO-Prompt/pkg-descr
@@ -0,0 +1,5 @@
+By default, this module exports a single function 'prompt'. It
+prompts the user to enter some input, and returns an object that
+represents the user input.
+
+WWW: http://search.cpan.org/dist/IO-Prompt/
diff --git a/devel/p5-IO-Prompt/pkg-plist b/devel/p5-IO-Prompt/pkg-plist
new file mode 100644
index 000000000000..a296e30ba5dd
--- /dev/null
+++ b/devel/p5-IO-Prompt/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/IO/Prompt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Prompt/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Prompt
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/IO 2>/dev/null || true