aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-IPC-Shareable
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2000-09-06 16:02:18 +0000
committerSADA Kenji <sada@FreeBSD.org>2000-09-06 16:02:18 +0000
commit3438772fd526788348c62cf7fc3d11a752535d5f (patch)
tree4f917e96cb057afd3fb265f7712c1f911d8044ac /devel/p5-IPC-Shareable
parent178a4d3aa29d0701cf1f2a0e8485fd6b0b05b8c0 (diff)
downloadports-3438772fd526788348c62cf7fc3d11a752535d5f.tar.gz
ports-3438772fd526788348c62cf7fc3d11a752535d5f.zip
New port: IPC-Shareable
IPC::Shareable allows you to tie a a variable to shared memory making it easy to share the contents of that variable with other Perl processes. PR: ports/18816 Submitted by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
Notes
Notes: svn path=/head/; revision=32340
Diffstat (limited to 'devel/p5-IPC-Shareable')
-rw-r--r--devel/p5-IPC-Shareable/Makefile27
-rw-r--r--devel/p5-IPC-Shareable/distinfo1
-rw-r--r--devel/p5-IPC-Shareable/pkg-comment1
-rw-r--r--devel/p5-IPC-Shareable/pkg-descr7
-rw-r--r--devel/p5-IPC-Shareable/pkg-plist4
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-IPC-Shareable/Makefile b/devel/p5-IPC-Shareable/Makefile
new file mode 100644
index 000000000000..45960cb0aa4d
--- /dev/null
+++ b/devel/p5-IPC-Shareable/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-IPC-Shareable
+# Date created: May 25th 2000
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-Shareable
+PORTVERSION= 0.51
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/Storable.pm:${PORTSDIR}/devel/p5-Storable
+
+USE_PERL5= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= IPC::Shareable.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-Shareable/distinfo b/devel/p5-IPC-Shareable/distinfo
new file mode 100644
index 000000000000..8c995f5cef3f
--- /dev/null
+++ b/devel/p5-IPC-Shareable/distinfo
@@ -0,0 +1 @@
+MD5 (IPC-Shareable-0.51.tar.gz) = 2ea26ce7f8d90c5bbd9310242ebc181d
diff --git a/devel/p5-IPC-Shareable/pkg-comment b/devel/p5-IPC-Shareable/pkg-comment
new file mode 100644
index 000000000000..a308067ea585
--- /dev/null
+++ b/devel/p5-IPC-Shareable/pkg-comment
@@ -0,0 +1 @@
+Share Perl variables between processes
diff --git a/devel/p5-IPC-Shareable/pkg-descr b/devel/p5-IPC-Shareable/pkg-descr
new file mode 100644
index 000000000000..15324807aa3b
--- /dev/null
+++ b/devel/p5-IPC-Shareable/pkg-descr
@@ -0,0 +1,7 @@
+ IPC::Shareable allows you to tie a a variable to shared memory making
+ it easy to share the contents of that variable with other Perl
+ processes. Currently either scalars or hashes can be tied; tying of
+ arrays remains a work in progress. However, the variable being tied may
+ contain arbitrarily complex data structures - including references to
+ arrays, hashes of hashes, etc. See the "REFERENCES" entry in this
+ manpage below for more information.
diff --git a/devel/p5-IPC-Shareable/pkg-plist b/devel/p5-IPC-Shareable/pkg-plist
new file mode 100644
index 000000000000..c512714ae915
--- /dev/null
+++ b/devel/p5-IPC-Shareable/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/IPC/Shareable/SharedMem.pm
+lib/perl5/site_perl/%%PERL_VER%%/IPC/Shareable.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/Shareable/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/Shareable