aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Java/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-02 23:40:27 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-02 23:40:27 +0000
commitf2b7c59aa2a2aafc226eecc3cf7c1d66c34d1909 (patch)
tree3029b696aa3ebbde8ae92097da04ffe4f4c0889e /devel/p5-Java/Makefile
parentd1d963b937ed5f7ba8f4f3cb90fe3048aa56600c (diff)
downloadports-f2b7c59aa2a2aafc226eecc3cf7c1d66c34d1909.tar.gz
ports-f2b7c59aa2a2aafc226eecc3cf7c1d66c34d1909.zip
Add p5-Java 4.7, perl extension for accessing a JVM remotely or locally.
PR: ports/92566 Submitted by: Simun Mikecin <numisemis@yahoo.com> Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=164246
Diffstat (limited to 'devel/p5-Java/Makefile')
-rw-r--r--devel/p5-Java/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-Java/Makefile b/devel/p5-Java/Makefile
new file mode 100644
index 000000000000..fcfa4e85612b
--- /dev/null
+++ b/devel/p5-Java/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Java
+# Date Created: 27 January 2006
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Java
+PORTVERSION= 4.7
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=Java
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Perl extension for accessing a JVM remotely or locally
+
+USE_RC_SUBR= javaserver.sh
+PERL_CONFIGURE= YES
+USE_JAVA= yes
+JAVA_VERSION= 1.1+
+
+MAN3= Java.3 JavaArray.3
+
+post-patch:
+ ${RM} ${WRKSRC}/java_server_install.pl
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/p5-Java
+ ${INSTALL_DATA} ${WRKSRC}/JavaServer.jar ${PREFIX}/share/p5-Java
+
+.include <bsd.port.mk>