aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Module-Release/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-03-14 09:48:44 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-03-14 09:48:44 +0000
commit9e99989bebe2519663a4142bd1a19b51f8e00c39 (patch)
treeb7ac8afb0f092dba81dbc8a4b75622b50b273d7d /devel/p5-Module-Release/Makefile
parent841b3bd0d5b609dbfce0880596c6105369950f3c (diff)
downloadports-9e99989bebe2519663a4142bd1a19b51f8e00c39.tar.gz
ports-9e99989bebe2519663a4142bd1a19b51f8e00c39.zip
Add p5-release 0.99, upload files to CPAN and SourceForge.
Notes
Notes: svn path=/head/; revision=131171
Diffstat (limited to 'devel/p5-Module-Release/Makefile')
-rw-r--r--devel/p5-Module-Release/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-Module-Release/Makefile b/devel/p5-Module-Release/Makefile
new file mode 100644
index 000000000000..76a6052f334c
--- /dev/null
+++ b/devel/p5-Module-Release/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: release
+# Date created: 14 Mart 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= release
+PORTVERSION= 0.99
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BD/BDFOY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Upload files to CPAN and SourceForge
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
+ ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/ConfigReader/Simple.pm:${PORTSDIR}/devel/p5-ConfigReader-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.24
+
+MAN1= release.1
+MAN3= Module::Release.3
+
+.include <bsd.port.mk>