aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-MooseX-ChainedAccessors/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-04-03 12:54:17 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-04-03 12:54:17 +0000
commit88333791fad495193a35cd14f34d7c6e547ba9ec (patch)
treee6add77c9dd7221c5569502010cac4c000c9323b /devel/p5-MooseX-ChainedAccessors/Makefile
parent36ab9fbbb09f09eaff805770608eb8918d68bd17 (diff)
downloadports-88333791fad495193a35cd14f34d7c6e547ba9ec.tar.gz
ports-88333791fad495193a35cd14f34d7c6e547ba9ec.zip
MooseX::ChainedAccessors is a Moose Trait which allows for method chaining on
accessors by returning $self on write/set operations. WWW: http://search.cpan.org/dist/MooseX-ChainedAccessors/ This new port is needed to update www/p5-HTML-FormFu.
Notes
Notes: svn path=/head/; revision=272150
Diffstat (limited to 'devel/p5-MooseX-ChainedAccessors/Makefile')
-rw-r--r--devel/p5-MooseX-ChainedAccessors/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/p5-MooseX-ChainedAccessors/Makefile b/devel/p5-MooseX-ChainedAccessors/Makefile
new file mode 100644
index 000000000000..21c9565e82b8
--- /dev/null
+++ b/devel/p5-MooseX-ChainedAccessors/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: MooseX-ChainedAccessors
+# Date created: 2011-04-03
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-ChainedAccessors
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PERLER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Accessor class for chained accessors with Moose
+
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Moose::Meta::Attribute::Custom::Trait::Chained.3 \
+ MooseX::ChainedAccessors.3 \
+ MooseX::ChainedAccessors::Accessor.3 \
+ MooseX::Traits::Attribute::Chained.3
+
+.include <bsd.port.mk>