aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-MooseX-Types-Path-Class
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2008-07-28 00:54:40 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2008-07-28 00:54:40 +0000
commit4a30b8e755cc2669051dc90e1ea245598102ca25 (patch)
tree40fcdf00d58295ffb9216d4a1587a60781bb257b /devel/p5-MooseX-Types-Path-Class
parent4ae2bb15b7596b0c1fd65204d18d9a841369bb50 (diff)
downloadports-4a30b8e755cc2669051dc90e1ea245598102ca25.tar.gz
ports-4a30b8e755cc2669051dc90e1ea245598102ca25.zip
New port: devel/p5-MooseX-Types-Path-Class, A Path::Class type library for Moose
Notes
Notes: svn path=/head/; revision=217724
Diffstat (limited to 'devel/p5-MooseX-Types-Path-Class')
-rw-r--r--devel/p5-MooseX-Types-Path-Class/Makefile29
-rw-r--r--devel/p5-MooseX-Types-Path-Class/distinfo3
-rw-r--r--devel/p5-MooseX-Types-Path-Class/pkg-descr13
-rw-r--r--devel/p5-MooseX-Types-Path-Class/pkg-plist9
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-MooseX-Types-Path-Class/Makefile b/devel/p5-MooseX-Types-Path-Class/Makefile
new file mode 100644
index 000000000000..ddfdbd677cc3
--- /dev/null
+++ b/devel/p5-MooseX-Types-Path-Class/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: devel/p5-MooseX-Types-Path-Class
+# Date created: 28 Jul 2008
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-Types-Path-Class
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= A Path::Class type library for Moose
+
+RUN_DEPENDS= p5-MooseX-Types>=0.04:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Getopt>=0.05:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-Path-Class>=0.16:${PORTSDIR}/devel/p5-Path-Class
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= MooseX::Types::Path::Class.3
+
+post-extract:
+ @${PERL} -i -ne 'print unless m,build_requires,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Types-Path-Class/distinfo b/devel/p5-MooseX-Types-Path-Class/distinfo
new file mode 100644
index 000000000000..2edcc014bea6
--- /dev/null
+++ b/devel/p5-MooseX-Types-Path-Class/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-Types-Path-Class-0.04.tar.gz) = c6604117d0f637e7299eca71060819c1
+SHA256 (MooseX-Types-Path-Class-0.04.tar.gz) = c5ee1b65783fd327e03cf2c6613a4349f75d89b58a18abf2332062a810e3f047
+SIZE (MooseX-Types-Path-Class-0.04.tar.gz) = 13270
diff --git a/devel/p5-MooseX-Types-Path-Class/pkg-descr b/devel/p5-MooseX-Types-Path-Class/pkg-descr
new file mode 100644
index 000000000000..78f27d1fd0a4
--- /dev/null
+++ b/devel/p5-MooseX-Types-Path-Class/pkg-descr
@@ -0,0 +1,13 @@
+This is a utility that creates common Moose subtypes, coercions and option
+specifications useful for dealing with Path::Class objects as Moose attributes.
+
+This module constructs coercions (see Moose::Util::TypeConstraints) from both
+'Str' and 'ArrayRef' to both Path::Class::Dir and Path::Class::File objects.
+It also adds the Getopt option type ("=s") for both Path::Class::Dir and
+Path::Class::File (see MooseX::Getopt).
+
+This is just meant to be a central place for these constructs, so you don't
+have to worry about whether they've been created or not, and you're not tempted
+to copy them into yet another class (like I was).
+
+WWW: http://search.cpan.org/dist/MooseX-Types-Path-Class/
diff --git a/devel/p5-MooseX-Types-Path-Class/pkg-plist b/devel/p5-MooseX-Types-Path-Class/pkg-plist
new file mode 100644
index 000000000000..25f8f104bc50
--- /dev/null
+++ b/devel/p5-MooseX-Types-Path-Class/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/MooseX/Types/Path/Class.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Types/Path/Class/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Types/Path/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Types/Path
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Types
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX
+@dirrmtry %%SITE_PERL%%/MooseX/Types/Path
+@dirrmtry %%SITE_PERL%%/MooseX/Types
+@dirrmtry %%SITE_PERL%%/MooseX