aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE-XS-Queue-Array
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-05-26 11:47:53 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-05-26 11:47:53 +0000
commit80b19c3e854368fe74a6195630f4a2eae2c9af4e (patch)
treeda478e8328cca9df15a83aee50250341950aa679 /devel/p5-POE-XS-Queue-Array
parent93ab03eb2cf16bf06a1a19dd225233040c2d7564 (diff)
downloadports-80b19c3e854368fe74a6195630f4a2eae2c9af4e.tar.gz
ports-80b19c3e854368fe74a6195630f4a2eae2c9af4e.zip
Add p5-POE-XS-Queue-Array 0.001, XS implementation of POE::Queue::Array.
PR: ports/97903 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
Notes
Notes: svn path=/head/; revision=163474
Diffstat (limited to 'devel/p5-POE-XS-Queue-Array')
-rw-r--r--devel/p5-POE-XS-Queue-Array/Makefile33
-rw-r--r--devel/p5-POE-XS-Queue-Array/distinfo3
-rw-r--r--devel/p5-POE-XS-Queue-Array/pkg-descr4
-rw-r--r--devel/p5-POE-XS-Queue-Array/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-POE-XS-Queue-Array/Makefile b/devel/p5-POE-XS-Queue-Array/Makefile
new file mode 100644
index 000000000000..5e6c36cb1a8a
--- /dev/null
+++ b/devel/p5-POE-XS-Queue-Array/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: devel/p5-POE-XS-Queue-Array
+# Date created: 22 May 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-XS-Queue-Array
+PORTVERSION= 0.001
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= XS implementation of POE::Queue::Array
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::XS::Queue::Array.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-POE-XS-Queue-Array/distinfo b/devel/p5-POE-XS-Queue-Array/distinfo
new file mode 100644
index 000000000000..27bab6ccb193
--- /dev/null
+++ b/devel/p5-POE-XS-Queue-Array/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-XS-Queue-Array-0.001.tar.gz) = 8a778f7dcc901dd6f3424537d54a96f2
+SHA256 (POE-XS-Queue-Array-0.001.tar.gz) = 77bff315075d319b5d95dbdf188392a42bfeee0c2bf60562c3475f1654924573
+SIZE (POE-XS-Queue-Array-0.001.tar.gz) = 10529
diff --git a/devel/p5-POE-XS-Queue-Array/pkg-descr b/devel/p5-POE-XS-Queue-Array/pkg-descr
new file mode 100644
index 000000000000..d61022fe0190
--- /dev/null
+++ b/devel/p5-POE-XS-Queue-Array/pkg-descr
@@ -0,0 +1,4 @@
+This class is an implementation of the abstract POE::Queue interface.
+It implements a priority queue using C, with an XS interface supplied.
+
+WWW: http://search.cpan.org/dist/POE-XS-Queue-Array/
diff --git a/devel/p5-POE-XS-Queue-Array/pkg-plist b/devel/p5-POE-XS-Queue-Array/pkg-plist
new file mode 100644
index 000000000000..111d5f40a5d4
--- /dev/null
+++ b/devel/p5-POE-XS-Queue-Array/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/POE/XS/Queue/Array.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Queue/Array/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Queue/Array/Array.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Queue/Array/Array.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Queue/Array
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS/Queue
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE/XS/Queue
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POE