aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Pod-Tests
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-01-23 00:04:58 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-01-23 00:04:58 +0000
commit6dd8941796acbb6d88a911bd433edf2b2dc27eb8 (patch)
tree4e969d69421210b5c6a0084a38d545bbcd9f3074 /devel/p5-Pod-Tests
parentfab8454b6853f07f531583d0ea96bb4782b8b235 (diff)
downloadports-6dd8941796acbb6d88a911bd433edf2b2dc27eb8.tar.gz
ports-6dd8941796acbb6d88a911bd433edf2b2dc27eb8.zip
Adding port devel/p5-Pod-Tests, extracts embedded tests and code examples from POD.
Submitted by: aaron Approved by: tobez
Notes
Notes: svn path=/head/; revision=154206
Diffstat (limited to 'devel/p5-Pod-Tests')
-rw-r--r--devel/p5-Pod-Tests/Makefile27
-rw-r--r--devel/p5-Pod-Tests/distinfo3
-rw-r--r--devel/p5-Pod-Tests/pkg-descr19
-rw-r--r--devel/p5-Pod-Tests/pkg-plist5
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-Pod-Tests/Makefile b/devel/p5-Pod-Tests/Makefile
new file mode 100644
index 000000000000..e5d0c271b317
--- /dev/null
+++ b/devel/p5-Pod-Tests/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Pod-Tests
+# Date created: 20 Nov 2005
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Tests
+PORTVERSION= 0.18
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Extracts embedded tests and code examples from POD
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= pod2test.1
+MAN3= Pod::Tests.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Pod-Tests/distinfo b/devel/p5-Pod-Tests/distinfo
new file mode 100644
index 000000000000..7a11403d0546
--- /dev/null
+++ b/devel/p5-Pod-Tests/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pod-Tests-0.18.tar.gz) = dab7e41c23a1c01fa3e96f6237781dda
+SHA256 (Pod-Tests-0.18.tar.gz) = 79be48ca5483015ff3c537f9b5e434f381ed2d6d34e72094ab3a0e57d1644850
+SIZE (Pod-Tests-0.18.tar.gz) = 18608
diff --git a/devel/p5-Pod-Tests/pkg-descr b/devel/p5-Pod-Tests/pkg-descr
new file mode 100644
index 000000000000..9c9c148802af
--- /dev/null
+++ b/devel/p5-Pod-Tests/pkg-descr
@@ -0,0 +1,19 @@
+This is a specialized POD viewer to extract embedded tests and code
+examples from POD. It doesn't do much more than that. pod2test does the
+useful work.
+
+After creating a Pod::Tests object, you parse the POD by calling one of
+the available parsing methods documented below. You can call parse as many
+times as you'd like, all examples and tests found will stack up inside the
+object.
+
+Once extracted, the tests can be built into stand-alone testing code using
+the build_tests() and build_examples() methods. However, it is recommended
+that you first look at the pod2test program before embarking on this.
+
+WWW: http://search.cpan.org/dist/Pod-Tests
+Author: Michael G Schwern <schwern@pobox.com>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/devel/p5-Pod-Tests/pkg-plist b/devel/p5-Pod-Tests/pkg-plist
new file mode 100644
index 000000000000..2f3e34d387fa
--- /dev/null
+++ b/devel/p5-Pod-Tests/pkg-plist
@@ -0,0 +1,5 @@
+bin/pod2test
+%%SITE_PERL%%/Pod/Tests.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod-Tests/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod-Tests
+@dirrmtry %%SITE_PERL%%/Pod