aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Proc-Fork
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-10 14:56:30 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-10 14:56:30 +0000
commit6096c5ee131cca47143358b8fe7b91d695727e4a (patch)
tree4ca211be92d6eb836095e24b742381b22986b4da /devel/p5-Proc-Fork
parentefd185c5b1965919b4acd969d0073e9be4e5cf39 (diff)
downloadports-6096c5ee131cca47143358b8fe7b91d695727e4a.tar.gz
ports-6096c5ee131cca47143358b8fe7b91d695727e4a.zip
Add devel/p5-Proc-Fork, a Perl module that provides simple, intuitive
interface to the fork() system call.
Notes
Notes: svn path=/head/; revision=153198
Diffstat (limited to 'devel/p5-Proc-Fork')
-rw-r--r--devel/p5-Proc-Fork/Makefile28
-rw-r--r--devel/p5-Proc-Fork/distinfo3
-rw-r--r--devel/p5-Proc-Fork/pkg-descr8
-rw-r--r--devel/p5-Proc-Fork/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Proc-Fork/Makefile b/devel/p5-Proc-Fork/Makefile
new file mode 100644
index 000000000000..256929e13086
--- /dev/null
+++ b/devel/p5-Proc-Fork/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Proc-Fork
+# Date created: 10 January 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Fork
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Proc::Fork - Simple, intuitive interface to the fork() system call
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::Fork.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Proc-Fork/distinfo b/devel/p5-Proc-Fork/distinfo
new file mode 100644
index 000000000000..26933edab945
--- /dev/null
+++ b/devel/p5-Proc-Fork/distinfo
@@ -0,0 +1,3 @@
+MD5 (Proc-Fork-0.11.tar.gz) = bdc91ce4def70bd0b27e8a5660276316
+SHA256 (Proc-Fork-0.11.tar.gz) = 996f8a9eb00d3a2a04a01c91cc15aa1345ca63bf2817b01ccadf334c0406e8b5
+SIZE (Proc-Fork-0.11.tar.gz) = 6175
diff --git a/devel/p5-Proc-Fork/pkg-descr b/devel/p5-Proc-Fork/pkg-descr
new file mode 100644
index 000000000000..c32e552597b5
--- /dev/null
+++ b/devel/p5-Proc-Fork/pkg-descr
@@ -0,0 +1,8 @@
+This module provides an intuitive, Perl-ish way to write forking
+programs by letting you use blocks to illustrate which code section
+executes in which fork. The code for the parent, child, retry handler
+and error handler are grouped together in a "fork block". The clauses
+may appear in any order, but they must be consecutive (without any other
+statements in between).
+
+WWW: http://search.cpan.org/dist/Proc-Fork/
diff --git a/devel/p5-Proc-Fork/pkg-plist b/devel/p5-Proc-Fork/pkg-plist
new file mode 100644
index 000000000000..73d8240d43da
--- /dev/null
+++ b/devel/p5-Proc-Fork/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Proc/Fork.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Fork/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Fork 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Proc 2>/dev/null || true