aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Proc-Wait3
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-09-23 14:42:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-09-23 14:42:08 +0000
commit4770d6aa57e53d2d1e15105635c0a1c529e3782c (patch)
treea3ee36935931f461b91b4608cfb6678da556e9ab /devel/p5-Proc-Wait3
parentbb99b8106cc9137efd2f5d2286bb65994375c68c (diff)
downloadports-4770d6aa57e53d2d1e15105635c0a1c529e3782c.tar.gz
ports-4770d6aa57e53d2d1e15105635c0a1c529e3782c.zip
Add devel/p5-Proc-Wait3, a Perl extension for wait3 system call.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=241982
Diffstat (limited to 'devel/p5-Proc-Wait3')
-rw-r--r--devel/p5-Proc-Wait3/Makefile22
-rw-r--r--devel/p5-Proc-Wait3/distinfo3
-rw-r--r--devel/p5-Proc-Wait3/pkg-descr8
-rw-r--r--devel/p5-Proc-Wait3/pkg-plist7
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Proc-Wait3/Makefile b/devel/p5-Proc-Wait3/Makefile
new file mode 100644
index 000000000000..61005bc3be13
--- /dev/null
+++ b/devel/p5-Proc-Wait3/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Proc-Wait3
+# Date created: 23 September 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Wait3
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl extension for wait3 system call
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::Wait3.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Proc-Wait3/distinfo b/devel/p5-Proc-Wait3/distinfo
new file mode 100644
index 000000000000..dcfb07128fd9
--- /dev/null
+++ b/devel/p5-Proc-Wait3/distinfo
@@ -0,0 +1,3 @@
+MD5 (Proc-Wait3-0.03.tar.gz) = af5b362f3d1db4af8c34495b63f33c90
+SHA256 (Proc-Wait3-0.03.tar.gz) = 77bac5f02740f95918bb08f47142aa1e08babacd855cf0713216a6e92aa3eb36
+SIZE (Proc-Wait3-0.03.tar.gz) = 2962
diff --git a/devel/p5-Proc-Wait3/pkg-descr b/devel/p5-Proc-Wait3/pkg-descr
new file mode 100644
index 000000000000..d9109165db4a
--- /dev/null
+++ b/devel/p5-Proc-Wait3/pkg-descr
@@ -0,0 +1,8 @@
+Proc::Wait3 module implements wait3 system call in Perl.
+If any child processes have exited, this call will "reap" the zombies
+similar to the perl "wait" function. By default, it will return
+immediately and if there are no dead children, everything will be
+undefined. If you pass in a true argument, it will block until a child
+exits (or it gets a signal).
+
+WWW: http://search.cpan.org/dist/Proc-Wait3/
diff --git a/devel/p5-Proc-Wait3/pkg-plist b/devel/p5-Proc-Wait3/pkg-plist
new file mode 100644
index 000000000000..b3d306079b2f
--- /dev/null
+++ b/devel/p5-Proc-Wait3/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Proc/Wait3.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3/Wait3.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3/Wait3.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Proc