aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Project-Gantt
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-21 09:04:13 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-21 09:04:13 +0000
commit90d10715d986f6246353f529eae14018b0b08701 (patch)
tree1ed7126b5223b3a9b79d60c3cee12c532fc02464 /devel/p5-Project-Gantt
parent6ab958cbb140910efe011ccad1b0eb40547ebf33 (diff)
downloadports-90d10715d986f6246353f529eae14018b0b08701.tar.gz
ports-90d10715d986f6246353f529eae14018b0b08701.zip
- this module create Gantt charts to manage project scheduling
Approved by: co-mentor (vanilla)
Notes
Notes: svn path=/head/; revision=119898
Diffstat (limited to 'devel/p5-Project-Gantt')
-rw-r--r--devel/p5-Project-Gantt/Makefile33
-rw-r--r--devel/p5-Project-Gantt/distinfo2
-rw-r--r--devel/p5-Project-Gantt/pkg-descr6
-rw-r--r--devel/p5-Project-Gantt/pkg-plist16
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/p5-Project-Gantt/Makefile b/devel/p5-Project-Gantt/Makefile
new file mode 100644
index 000000000000..4e3b9afcc6ea
--- /dev/null
+++ b/devel/p5-Project-Gantt/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: devel/p5-Project-Gantt
+# Date created: Thu Oct 21 16:46:26 CST 2004
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Project-Gantt
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AW/AWESTHOLM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Create Gantt charts to manage project scheduling
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Class/Date.pm:${PORTSDIR}/devel/p5-Class-Date \
+ ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/Gantt
+
+MAN3= Project::Gantt.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= This program only support perl 5.8.0 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Project-Gantt/distinfo b/devel/p5-Project-Gantt/distinfo
new file mode 100644
index 000000000000..fc33c33f5adb
--- /dev/null
+++ b/devel/p5-Project-Gantt/distinfo
@@ -0,0 +1,2 @@
+MD5 (Project-Gantt-1.01.tar.gz) = 5a9bbd6ce7011943baf3e0302933d819
+SIZE (Project-Gantt-1.01.tar.gz) = 15661
diff --git a/devel/p5-Project-Gantt/pkg-descr b/devel/p5-Project-Gantt/pkg-descr
new file mode 100644
index 000000000000..acd19eadcba2
--- /dev/null
+++ b/devel/p5-Project-Gantt/pkg-descr
@@ -0,0 +1,6 @@
+Project::Gantt provides the ability to easily draw Gantt charts for
+managing the schedules of projects and many other things.
+Gantt charts provide a simple, easy to comprehend, visual
+representation of a schedule.
+
+WWW: http://search.cpan.org/~awestholm/Project-Gantt/
diff --git a/devel/p5-Project-Gantt/pkg-plist b/devel/p5-Project-Gantt/pkg-plist
new file mode 100644
index 000000000000..5e8ac899b357
--- /dev/null
+++ b/devel/p5-Project-Gantt/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Project/Gantt.pm
+%%SITE_PERL%%/Project/Gantt/DateUtils.pm
+%%SITE_PERL%%/Project/Gantt/GanttHeader.pm
+%%SITE_PERL%%/Project/Gantt/Globals.pm
+%%SITE_PERL%%/Project/Gantt/ImageWriter.pm
+%%SITE_PERL%%/Project/Gantt/Resource.pm
+%%SITE_PERL%%/Project/Gantt/Skin.pm
+%%SITE_PERL%%/Project/Gantt/SpanInfo.pm
+%%SITE_PERL%%/Project/Gantt/Task.pm
+%%SITE_PERL%%/Project/Gantt/TextUtils.pm
+%%SITE_PERL%%/Project/Gantt/TimeSpan.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Project/Gantt/.packlist
+@dirrm %%SITE_PERL%%/Project/Gantt
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Project/Gantt
+@unexec rmdir %D/%%SITE_PERL%%/Project 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Project 2>/dev/null || true