aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SVN-Web
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-13 12:32:20 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-13 12:32:20 +0000
commitf7c4d2a1a96559ea604801a646df9bb2efd8739c (patch)
treeb3bc56d9e784cd8c0744b18677bdfce5c3c305b3 /devel/p5-SVN-Web
parent9bcce1d013faa4f9460f723abc4785f32e9cb36d (diff)
downloadports-f7c4d2a1a96559ea604801a646df9bb2efd8739c.tar.gz
ports-f7c4d2a1a96559ea604801a646df9bb2efd8739c.zip
- Respect DESTDIR
- Remove unnecessary dependencies pulled by PERL_MODBUILD Bump PORTREVISION for this. PR: ports/101886 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=170461
Diffstat (limited to 'devel/p5-SVN-Web')
-rw-r--r--devel/p5-SVN-Web/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/devel/p5-SVN-Web/Makefile b/devel/p5-SVN-Web/Makefile
index 591a1778e1eb..634880c22bcd 100644
--- a/devel/p5-SVN-Web/Makefile
+++ b/devel/p5-SVN-Web/Makefile
@@ -7,6 +7,7 @@
PORTNAME= SVN-Web
PORTVERSION= 0.47
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= SVN
@@ -15,23 +16,22 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= Subversion repository web frontend
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
- ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
p5-Exception-Class>=1.22:${PORTSDIR}/devel/p5-Exception-Class \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-Locale-Maketext-Lexicon>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
- p5-Template-Plugin-Number-Format>=0:${PORTSDIR}/www/p5-Template-Plugin-Number-Format \
- p5-Text-Diff-HTML>=0:${PORTSDIR}/textproc/p5-Text-Diff-HTML \
p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
- p5-Template-Plugin-Clickable>=0:${PORTSDIR}/www/p5-Template-Plugin-Clickable \
+ p5-Locale-Maketext-Lexicon>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
p5-Template-Plugin-Clickable-Email>=0:${PORTSDIR}/www/p5-Template-Plugin-Clickable-Email \
- p5-Template-Plugin-Subst>=0:${PORTSDIR}/www/p5-Template-Plugin-Subst
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-Template-Plugin-Clickable>=0:${PORTSDIR}/www/p5-Template-Plugin-Clickable \
+ p5-Template-Plugin-Number-Format>=0:${PORTSDIR}/www/p5-Template-Plugin-Number-Format \
+ p5-Template-Plugin-Subst>=0:${PORTSDIR}/www/p5-Template-Plugin-Subst \
+ p5-Text-Diff-HTML>=0:${PORTSDIR}/textproc/p5-Text-Diff-HTML
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
@@ -50,13 +50,18 @@ MAN3= SVN::Web.3 \
SVN::Web::action.3
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/svnweb-install ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/svnweb-install ${TARGETDIR}/bin
@${ECHO}
@${CAT} ${PKGMESSAGE}
@${ECHO}
.include <bsd.port.pre.mk>
+
.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6 or newer. Please install lang/perl5 or lang/perl5.8, and try again
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
.endif
.include <bsd.port.post.mk>