aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-ClassAPI
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-04-02 15:34:46 +0000
committerLars Thegler <lth@FreeBSD.org>2005-04-02 15:34:46 +0000
commitd0efc3fdad2bcb2b3b17cab9b93d320891cf26e1 (patch)
tree1b8dbafa9d10571bccbd13eea274a7f678f52711 /devel/p5-Test-ClassAPI
parente5be53418d7eedfbc16af599aca089320ba9a33c (diff)
downloadports-d0efc3fdad2bcb2b3b17cab9b93d320891cf26e1.tar.gz
ports-d0efc3fdad2bcb2b3b17cab9b93d320891cf26e1.zip
Add p5-Test-ClassAPI 1.02, provides basic first-pass API testing for
large class trees.
Notes
Notes: svn path=/head/; revision=132206
Diffstat (limited to 'devel/p5-Test-ClassAPI')
-rw-r--r--devel/p5-Test-ClassAPI/Makefile31
-rw-r--r--devel/p5-Test-ClassAPI/distinfo2
-rw-r--r--devel/p5-Test-ClassAPI/pkg-descr6
-rw-r--r--devel/p5-Test-ClassAPI/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Test-ClassAPI/Makefile b/devel/p5-Test-ClassAPI/Makefile
new file mode 100644
index 000000000000..af31473b1b06
--- /dev/null
+++ b/devel/p5-Test-ClassAPI/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Test-ClassAPI
+# Date created: 24 March 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-ClassAPI
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Provides basic first-pass API testing for large class trees
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
+ ${SITE_PERL}/Config/Tiny.pm:${PORTSDIR}/devel/p5-Config-Tiny
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::ClassAPI.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+post-patch:
+ @${PERL} -pi -e 's,\r,,' ${WRKSRC}/lib/Test/ClassAPI.pm
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-ClassAPI/distinfo b/devel/p5-Test-ClassAPI/distinfo
new file mode 100644
index 000000000000..20299949637d
--- /dev/null
+++ b/devel/p5-Test-ClassAPI/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-ClassAPI-1.02.tar.gz) = f242a7d8ca652d7207a50461e328dafc
+SIZE (Test-ClassAPI-1.02.tar.gz) = 14175
diff --git a/devel/p5-Test-ClassAPI/pkg-descr b/devel/p5-Test-ClassAPI/pkg-descr
new file mode 100644
index 000000000000..666e75729ae1
--- /dev/null
+++ b/devel/p5-Test-ClassAPI/pkg-descr
@@ -0,0 +1,6 @@
+For many APIs with large numbers of classes, it can be very useful
+to be able to do a quick once-over to make sure that classes,
+methods, and inheritance is correct, before doing more comprehensive
+testing. This module aims to provide such a capability.
+
+WWW: http://search.cpan.org/dist/Test-ClassAPI
diff --git a/devel/p5-Test-ClassAPI/pkg-plist b/devel/p5-Test-ClassAPI/pkg-plist
new file mode 100644
index 000000000000..dfd5d979037c
--- /dev/null
+++ b/devel/p5-Test-ClassAPI/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/ClassAPI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/ClassAPI/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/ClassAPI
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true